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About the Tutorial Exercises

 

The following tutorial exercises provide step-by-step instructions for creating various kinds 
of text effects. These tutorials do not require any speciÞc media Þles, although the Þrst 
exercise uses an imported text Þle. If you do not have the text Þle, you can complete the 
exercise by typing or importing text. Some of the exercises use fonts that you may not have 
on your system. You can replace them with any fonts that you like.

 

Exercise 1: Creating a Rolling Title Effect

 

Title Crawl 

 

allows you to easily create title rolls and crawls. The text is automatically aligned 
and animated so that you do not have to set keyframes in the timeline.

You can create a title page in the Text window where you can type, edit or import text and 
set the font, size, justiÞcation, color, opacity, spacing, shadows, and borders. The parameters 
in the Text window are applied on a character basis, meaning that you can apply separate 
styles to different characters. 

The 

 

Style Palette

 

 allows you to save favorite styles and apply them to other text effects. 
These styles can be copied and shared with other users or used on other computers. In this 
exercise you will create a title roll then save and apply the styles.

 

Creating a Title Page

 

1.

 

Create a new composition and add the media that you want to use as the background 
to the timeline. These exercises use a solid color, but you can use whatever you like. 

 

2.

 

Set the duration of the composition to ten seconds.

 

3.

 

Select the background layer in the timeline.

 

4.

 

Choose Effects > Boris > Title Crawl.

The Text window opens.

 

5.

 

Click the 

 

Import File button

 

 at the bottom of the Text window. In the 
dialog box that opens, navigate to the �Credits.txt� Þle and click 

 

OK

 

.

If you have not downloaded this Þle, simply click in the top of the 
Text window and type several lines of alternating text. The examples in this 
exercise show a credit roll, but you can use whatever sort of text you like.

 

6.

 

Press Command-A (Macintosh) or Control-A (Windows) to select all the text.

 

7.

 

In the Style tab in the Text window, use the menus to set the font and size of the text and 
center justify the text. You may want to increase the size of the text to a point size over 
40 depending on which font you choose.
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8.

 

In the Text window, select only the Þrst line of text. (The words �Senior Producer� if you 
are using the imported Þle.)

 

9.

 

Click the Color Fill tab to open the color Þll controls. Use 

 

Style Color

 

 to choose a color 
for the text.

 

10.

 

Select the �Boris Yamnitsky� text and assign this text a different color. 

 

11.

 

Click 

 

Apply

 

 to display the changes you made in the Comp window. The Text window 
will automatically close.

 

Saving and Applying Styles

 

You can use the Style Palette to save, name, and apply styles for future use.

 

1.

 

Click the Title Crawl Þlter�s banner in the Effect Controls window to reopen the Text 
window.

 

2.

 

Click the 

 

Style Palette button

 

 in the bottom of the Text window. 

Style tab Font menu Font size menu Center Justification button

Color Fill 
tab
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3.

 

To create a category for your styles, click the 

 

Add Category icon

 

. Type the name �Credit 
Roll Styles� in the dialog box and click 

 

OK

 

.

 

4.

 

To add the current style to the selected 
category, select the �Boris Yamnitsky� text in 
the Text window and click the 

 

Add Style 
icon

 

. 

 

5.

 

Click the thumbnail for the new style, click 
the 

 

Rename Style icon

 

, type �Name Style� in 
the dialog box and click 

 

OK

 

. The thumbnail 
and name of the style appear in the right 
column. 

 

6.

 

In the Text window, select the �Senior 
Producer� text and click the 

 

Add Style icon

 

. 
Enter the name �Title Style� in the dialog box 
and click 

 

OK

 

. The thumbnail and name of 
the style appear in the right column.

 

7.

 

Now you will apply the saved styles to the 
remaining text. Press Command-A 
(Macintosh) or Control-A (Windows) to 
select all the text. Double-click the �Title 
Style� thumbnail in the Style Palette to apply that style to all the text in the Text 
window. 

 

8.

 

Select the �Boris Yamnitsky� text and double-click the Name Style thumbnail in the 
Style Palette to apply that style. Repeat this step for each remaining line that contains a 
name.

 

9.

 

Close the Style Palette.

 

10.

 

Click 

 

Apply

 

 to close the Text window.

 

Rolling the Text Page

 

In this section you will roll the text page you created.

 

1.

 

In the Effect Controls window, select the 

 

1:2:1 Deßicker

 

 

 

checkbox

 

 to apply a vertical blur 
to help eliminate ßickering and reduce jagged edges. 

 

2.

 

Make sure that the 

 

Composite on Original checkbox 

 

is selected. When this is selected, 
the Þlter composites the text over the source layer. When this checkbox is deselected, 
the text is composited over an alpha channel. Layers in the timeline that are below the 
Þltered layer are visible.

 

3.

 

Set the 

 

Animation Style menu 

 

to 

 

Roll

 

.

Add Category

Add Style

Rename Style
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4.

 

Preview the composition. The title page is automatically positioned and animated to 
roll up the screen in order. 

 

Credit roll

 

Time 00:00:01:00 Time 00:00:03:00 Time 00:00:09:00

 

Masking the Edges of the Text Frame

 

Now you will mask the edges of the text frame so that the credit roll appears to fade in and 
out at the Title Safe Area.

 

1.

 

In the Effect Controls window, adjust 

 

Mask Start

 

 and 

 

Mask End 

 

to mask the text at the 
edges at the top and bottom edges of the frame. 

 

2.

 

In the Effect Controls window, adjust 

 

Blend Start

 

 and 

 

Blend End

 

 to soften the edges of 
the mask.

 

3.

 

Preview the composition. The title page is automatically positioned and animated to 
roll up the screen in order. 

 

Credit roll

 

Time 00:00:01:00 Time 00:00:03:00 Time 00:00:09:00

 

Exercise 2: Creating an Animated Type On Effect

 

Vector Text 

 

a

 

llows you to easily create animated text effects. The Type On parameter group 
allows you to create animated type on effects. 

 

1.

 

Create a new composition and add the media that you want to use as the background 
to the timeline. These exercises use a solid color, but you can use whatever you like. 

 

2.

 

Set the duration of the composition to ten seconds.
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3.

 

Select the background layer in the timeline.

 

4.

 

Choose Effect > Boris > Vector Text.

 

5.

 

The Text window appears. Click in the window and type �extreme� then press Return 
and type �OVERSHOOT.�

 

6.

 

Double-click to select the word �extreme� and make any adjustments to the font, text 
color, shadow and Þll properties. 

The illustrations in this exercise use Arial Black font at 72 points, but you can use 
whatever type of text you like.

 

7.

 

In the Text window, double-click to select the word �OVERSHOOT� and make any 
adjustments to the font, text color, shadow and Þll properties.

The illustrations in this exercise use Eddie Fisher font at 132 points, but you can use 
whatever type of text you like.

 

8.

 

Click the 

 

Force Center JustiÞcation button

 

.

 

9.

 

When the text appears the way that you want, click 

 

Apply

 

 then close the Text window.

Make sure that Text Wrap is set to No Wrap. This parameter is found in the Page 
tab in the Text window. By default it is set to No Wrap.

 

10.

 

In the Effect Controls window, select the 

 

Composite on Original checkbox

 

. 

 

11.

 

Click the disclosure triangle to expand the Type On parameter group.

 

12.

 

Click the Stopwatch to create a keyframe for 

 

Text Type On

 

 at the Þrst frame of the layer. 
Set 

 

Text Type On

 

 to 

 

0

 

. 

 

13.

 

Set 

 

Reveal Time 

 

to 

 

1200

 

 and 

 

Fade 

 

to 

 

0

 

. 

 

14.

 

Move the current-time marker to time 00:00:03:15 in the layer. Set 

 

Text Type On

 

 to 

 

100

 

. 

 

15.

 

Preview the animation. Several characters fade on at a time. 

 

Time 00:00:01:00 Time 00:00:02:00 Time 00:00:03:00

 

Changing the parameters under the Type On tab affects each character as it �types� 
onscreen. You will try adjusting some of the other parameters to experiment with other 
animation effects.
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16.

 

Select the Þrst keyframe in the layer. In the Type On parameter group, set 

 

Shift Y 

 

to 

 

-480

 

. Set 

 

Scale Y

 

 to 

 

3000

 

. 

 

17.

 

Preview the animation. The text now scales and shifts as it types on screen. 

 

Time 00:00:01:00 Time 00:00:02:00 Time 00:00:03:00

 

18.

 

Select the Þrst keyframe in the Text track. In the Type On parameter group, set 

 

Overshoot

 

 to 

 

-100

 

. 

 

19.

 

Preview the animation. The text now appears to bounce as it scales and shifts.

 

Exercise 3: Creating Text on a Path

 

Now you will put text that you create on a motion path. 

 

1.

 

Create a new composition and add the media that you want to use as the background 
to the timeline. These exercises use a solid color, but you can use whatever you like. 

 

2.

 

Set the duration of the composition to three seconds.

 

3.

 

Select the background layer in the timeline.

 

4.

 

Choose Effects > Boris > Vector Text.

 

5.

 

The Text window appears. Click in the window and type some text. The following 
examples show the phrase �See ya LATER...� However, you can use any text that you 
like.

 

6.

 

Select the text and make any adjustments to the font, text color, shadow and Þll 
properties. The examples in this exercise use the font Impact at 72 points, but you can 
use any font and size that you like.

 

7.

 

When the text appears the way that you want, click 

 

Apply

 

 then close the Text window.

Make sure that Text Wrap is set to No Wrap. This parameter is found in the Page 
tab in the Text window. By default it is set to No Wrap.

 

8.

 

In the Effect Controls window, select the 

 

Composite on Original checkbox

 

. When this is 
selected, the Þlter composites the text over the source layer. When this checkbox is 
deselected, the text is composited over an alpha channel. Layers in the timeline that are 
below the Þltered layer are visible.
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9.

 

In the Effect Controls window, click the disclosure triangle to expand the Path 
parameter group.

 

10.

 

Choose Circle from the Path Type menu. Use the Point 1 and Point 2 parameters to 
adjust the size of the circle. Point 1 sets the center point of the circular path. Point 2 sets 
the radius of the circle.

The Comp window updates, showing the 
text wrapped around the Path. 

11. Click the Stopwatch to create a keyframe for 
On Path Motion at the Þrst frame of the layer. 
Set On Path Motion to 100. 

12. Move the current-time marker to time 
00:00:03:00 in the layer. Set On Path Motion 
to 1 X 2.00.

13. Preview the animation. The text now rotates 
twice around the circular path.

Time 00:00:00:00 Time 00:00:01:20 Time 00:00:02:16

Exercise 4: Creating Text with a Backdrop
In this exercise you will create text with a backdrop using both the Vector Text and Vector 
Shape Þlters. 

1. Create a new composition and add the media that you want to use as the background 
to the timeline. These exercises use a solid color, but you can use whatever you like. 

2. Set the duration of the composition to four seconds.

3. Select the background layer in the timeline.

4. Choose Effect > Boris > Vector Text.

5. The Text window appears. Click in the window and type �Coming Soon.�

6. Make any adjustments to the font, text color, shadow and Þll properties. 
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The illustrations in this exercise use the 
settings shown in the illustration at right: 
Denmark font at 60 points with blue Fill 
and a Solid Shadow. However, you can use 
whatever type of text you like.

7. When the text appears the way that you 
want, click Apply to close the Text 
window.

8. In the Effect Controls window, select the 
Composite on Original checkbox. When this is selected, the Þlter composites the text 
over the source layer. When this checkbox is deselected, the text is composited over an 
alpha channel. Layers in the timeline that are below the Þltered layer are visible.

9. Select the background layer in the timeline.

10. Choose Effect > Boris > Vector Shape.

11. Make sure that the Vector Shape Þlter is above the Vector Text Þlter in the Effects 
Controls window. 

12. Click the disclosure triangle to expand 
the Primitive Shape parameter group. 

13. Choose the shape that you want from the 
Shape Primitive menu. 

The illustrations in this exercise use the 
Oval shape, but you can use whatever 
shape you like.

14. Adjust the Shape Left, Shape Top, Shape 
Right, and Shape Bottom parameters 
until the shape appears behind your text. 
These parameters set the positions of the 
corners of a rectangle in which the oval is 
inscribed. These values are scaled as 
percentages of the width and height of 
the Comp window.

The illustrations show Shape Left set to 
5.00 and Shape Right to 95.00, but you 
can use whatever parameters you like. 

15. Click the disclosure triangle to expand the Border 1 parameter group.

16. Leave the Border Type menu set to Bevel.
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17. Use the Eyedropper tool to set the 
border Color to the same color as your 
text Þll. 

18. Click the disclosure triangle to expand 
the Shape Fill parameter group.

19. Click to deselect the Shape Fill 
checkbox.

This creates an unÞlled backdrop.

20. Preview your effect. Now you will 
animate the backdrop. 

21. In the Border 1 parameter group, click the Stopwatch to create a keyframe for Border 
End at the Þrst frame of the layer.

22. Move the current-time marker to time 00:00:01:00 in the layer. Set Border End to 100. 

The Border now animates on.

Time 00:00:00:00 Time 00:00:00:20 Time 00:00:01:00

Exercise 5: Using Expressions to Animate Text and a Backdrop
Expressions can create a relationship between two properties. In this case you will use 
expressions to animate the Vector Text and the Vector Shape together.

1. Complete the steps in the previous sections, �Exercise 4: Creating Text with a 
Backdrop� on page 107.

2. Move the current-time marker to the Þrst frame in the layer. 

3. Click the disclosure triangle to expand the Transformations parameter group in the 
Vector Shape Þlter.

4. Click the Stopwatch to animate the Spin and PreRotate Position X/Y parameters.

5. Click the disclosure triangle to expand the Page Transformations parameter group in 
the Vector Text Þlter.

6. Click the Stopwatch to animate the Spin and PreRotate Position X/Y parameters.

7. Press the U key or choose Animation >Reveal Animating Properties.
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8. In the Timeline window, select the Spin and PreRotate Position X/Y parameters for the 
Vector Shape. 

9. Choose Animations > Add Expression.

10. Click the disclosure triangle next to Spin and drag the Pick Whip from the Spin 
parameter for the Vector Shape to the Spin parameter for the Vector Text. For 
information on the Pick Whip, see your After Effects documentation.

11. Click the disclosure triangle next to PreRotate Position X/Y and drag the Pick Whip from 
the PreRotate Position X/Y parameter for the Vector Shape to the PreRotate Position X/Y 
parameter for the Vector Text. 

The Spin and PreRotate Position X/Y parameters for the Vector Shape turn red in the 
timeline.

12. With the current-time marker at the Þrst frame in the layer, set Spin (in the Vector Text) 
to 35 degrees. 

13. Move the current-time marker to time 00:00:03:00 in the layer and create a new 
keyframe for the PreRotate Position X/Y parameter for the Vector Text by selecting the 
PreRotate Position X/Y and choosing Animation > Add Keyframe.

14. Move the current-time marker to time 00:00:04:00 in the layer and set PreRotate Position 
X/Y parameter for the Vector Text to 1200 x 243. 

15. Preview the effect. The text and backdrop now animate out of frame for one second.

Exercise 6: Creating a Text Scrambler Effect
In this exercise you will create a random text effect using the Text Scrambler Þlter. The text 
will appear randomly scrambled, then it will reveal itself in an animated wave-like effect to 
be a familiar phrase.

1. Create a new composition and add the media that you want to use as the background 
to the timeline. These exercises use a solid black color, but you can use whatever you 
like. 

2. Set the duration of the composition to four seconds.

3. Select the background layer in the timeline.

4. Choose Effects > Boris > Text Scrambler.

5. The Text window appears. Click in the window and type some text. The following 
examples show the phrase �the quick brown fox jumped over the lazy dog.� However, 
you can use any text that you like.

6. Select the text and make any adjustments to the font, text color, shadow and Þll 
properties. The examples in this exercise use the font Courier New at 100 points, but 
you can use any font and size that you like.

7. When the text appears the way that you want, click Apply to close the Text window.



111
• 
• 
• 
•
•
•

8. In the Effect Controls window, select the Composite on Original checkbox. When this is 
selected, the Þlter composites the text over the source layer. When this checkbox is 
deselected, the text is composited over an alpha channel. Layers in the timeline that are 
below the Þltered layer are visible.

9. Move the current-time marker to the beginning of the timeline.

10. In the Page Transformations parameter group in the Effect controls window, adjust 
Position X/Y so that the text appears at the bottom third of the screen. Set Master Scale 
to 22. Set Scale X to 90.

11. In the Variations parameter group, click the Stopwatch to create a keyframe for User 
Text Variation at the Þrst frame of the layer and set this to 14. When you adjust User Text 
Variation, each ASCII character value offsets by a certain amount. This includes spaces 
between words. When Letter Variation is 0, no variation occurs.

12. Choose User Text from the Generator Type menu. Choosing User Text allows you to 
type a phrase into the Text window for this effect. 

13. Choose Random Text from the Variation Mode menu. Random Text uses alphabetical 
characters for the text randomization. The characters are randomized so that repeated 
letters in the original words are not necessarily the same. 

14. Choose Right to Left from the Progress Order menu. Choosing this option will type the 
text on from right to left.

15. Move the current-time marker to 00:00:02:00 in the timeline.

16. In the Variations parameter group, click the Stopwatch to create a keyframe for 
Progress and set this parameter to 100. The Progress parameter allows you to control 
which characters change. 

17. In the Type On parameter group, click the Stopwatch to create a keyframe for Text Type 
On and set this parameter to 0. Text Type On adjusts the percentage of the text that is 
visible in each frame.
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18. In the Type On parameter group, enable the Always Visible checkbox. Selecting the 
Always Visible checkbox forces characters to remain visible while the transformations 
are progressively applied. 

19. In the Type On parameter group, set Reveal Time to 1565, set Fade to 34, set Shift Y to 
-25, set Scale X to 143, set Scale Y to 415 and set Rotate to 4 degrees. These parameters 
transform the letters during the portion of the effect where the words are revealing 
themselves. You can only see their effects while Progress and Text Type On are 
animating. 

20. Move the current-time marker to 00:00:03:00 in the timeline.

21. In the Variations parameter group, set User Text Variation to 100. Setting this parameter 
to 100 here stops it from animating until the end of the effect. Set Progress to 0. Setting 
this parameter to 0 stops any characters from changing until the end of the effect

22. In the Type On parameter group, click the Stopwatch to create a keyframe for Text Type 
On and set this parameter to 100. Setting this parameter to 100 stops characters from 
typing on until the end of the effect.

23. Play the effect. The words reveal themselves in a wave-like effect.

.

Time 00:00:00:00 Time 00:00:02:03

Time 00:00:02:14 Time 00:00:02:24
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24. Play the effect without the Always Visible parameter checked. Notice how the effect is 
changed and you cannot see all of the letters when they are not animating.

Time 00:00:00:00 Time 00:00:02:03

Time 00:00:02:14 Time 00:00:02:24



114   

• 
• 
• 
•
•
•


