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Introduction

 

Welcome to Boris Red 3GL. These Release Notes contain information regarding supported 
hosts, hardware and operating systems, known limitations, and other important 
information about the product.

For information on installing Boris Red 3GL into your host application, see the Installation 
Guide which is included as a pdf Þle on your CD.

For information about Boris Red software updates, other Boris products, and additional 
resources, visit our web site at www.borisfx.com.

 

Supported Hosts

 

Boris Red 3GL supports the following host applications. Because host versions update 
frequently, please visit our website at www.borisfx.com for updated information on 
supported versions for each host.

 

Macintos

 

h

 

Windows

 

Adobe

 

®

 

 Premiere

 

®

 

 6.0, 6.5 Adobe

 

®

 

 After Effects

 

® 

 

6.0
Apple

 

®

 

 Final Cut Pro

 

® 3.0, 4.0

 

Adobe

 

®

 

 Premiere

 

®

 

 6.0, 6.5, Adobe Premiere 
Pro

 

®

 

 1.0
Avid

 

®

 

 Media Composer

 

®

 

, Avid 
Symphony

 

® 4.7, 4.8, 

 

Avid 
XpressMac

 

®, 

 

Avid Xpress DV

 

® 

 

3.0, 
3.5.4, Avid Xpress Pro

 

®

 

Avid

 

®

 

 Media Composer

 

®

 

, Avid 
Symphony

 

®,

 

 Avid Xpress

 

®

 

, Avid Xpress 
DV

 

® 

 

3.0, 3.5.4

 

, 

 

Avid Xpress Pro

 

®

 

Media 100

 

®

 

 Media 100 i

 

® 

 

8.1 DPS

 

®

 

 Velocity

 

® 

 

8.2

 

IMC

 

® 

 

Incite

 

® 

 

3.0
In:Sync

 

® 

 

Blade

 

®

 

 2.2, In:Sync 

 

Speed~Razor

 

® 

 

5.5
Media 100

 

®

 

 iFinish 4.6 
Pinnacle purple

 

®, 

 

Pinnacle 

 

silver

 

® 4.01, 

 

Pinnacle 

 

Edition

 

® 5.0

 

Sony

 

®

 

 Vegas

 

® 

 

4.0
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Supported Operating Systems

 

Red 3GL supports the following operating systems. 

 

Macintosh

 

Macintosh OS X v10.2.6 and above (see note below).

To take advantage of the new OpenGL features in Red 3GL, you must have Mac 
OS 10.2.6 or later installed.

Red 3GL no longer supports Macintosh OS Classic 9.x.

 

Windows

 

Windows 2K

 

®

 

, Windows XP

 

®

 

Minimum System Requirements

 

We recommends at least 512MB of memory assigned to the host application for both 
Macintosh and Windows users using Red 3GL

To run Boris Red 3GL, QuickTime version 6.0 or later must be installed on your system. An 
installer for QuickTime for Windows is included on the Boris Red CD. QuickTime 6.0 is 
automatically installed on Macintosh OS X systems. Boris Red 3GL supports dual 
processors, Hyper Threading, and Altivec acceleration.

 

New Features in Red 3GL

 

Red 3GL contains many new features. See the separate 

 

Red 3GL New Features.pdf 

 

document for explanations of all of these new features.

 

Support for Automatic Duck Composition Import

 

Red supports Automatic Duck Pro Import to bring host sequences from Final Cut Pro and 
Avid systems into Boris Red. Supported effects are translated, and your timeline is recreated 
as a composition in Boris Red. In addition, your media and composition are added to the 
Project window. An installer for Automatic Duck Pro Import LT is included on the Boris Red 
3GL installation CD. This is a 30-day, fully-functioning demo.

For more information, see your Automatic Duck documentation or visit

 

 
www.automaticduck.com

 

. For information on using Automatic Duck, see 
Appendix B, �Working with Hosts,� in Volume I of the Red User Guide.
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Supported Hardware and Drivers

 

You need the following hardware and system requirements to use the new hardware 
dependent features in Red 3GL. For detailed information on the OpenGL feature in Red 
3GL, see the Understanding OpenGL pdf on your Red CD or Volume I in the Red User 
Guide.

 

Supported OpenGL Hardware

 

Due to a problem with the Macintosh OS, Final Cut Pro version 4.0 does not 
support Red�s OpenGL feature.When you launch Final Cut Pro version 4.0, 
OpenGL is automatically disabled. If you attempt to enable OpenGL in the Red 
Preferences, you will crash when you apply back to Final Cut. We expect this 
problem to be Þxed in Macintosh OS 10.3, after which you can enable OpenGL in 
Red�s Preferences window.

You can still use Red 3GL without OpenGL or with an older card, you just won�t 
gain as much acceleration while working. 

The following graphics cards and drivers are supported for the new OpenGL features in 
Red 3GL. OpenGL is a cross-platform standard that accelerates the rendering of 2D and 3D 
graphics. Most newer video cards have hardware-based OpenGL acceleration. If your 
system does not include the recommended minimum requirements, Red will initially 
default OpenGL to Off. You can re-enable OpenGL in the Red Preferences window.

This list is current as of the initial Red 3GL release. Boris FX will maintain an 
updated list of tested video cards on our web site: www.Borisfx.com.

For detailed information on how to use OpenGL, see Volume I in the Red User 
Guide.

 

Graphics Card 

 

•   

 

NVidia GeForce

 

•   

 

NVidia Quadro

 

•   

 

ATI FireGL (See the ATI note below.)

 

•   

 

ATI Radeon (8000 and later) (See the ATI notes.)

 

•   

 

ATI Rage 128 (Macintosh Only) (See the ATI note.)

 

•   

 

Matrox Parhelia

 

NOTE for NVidia users: 

 

The NVidia GeForce 2 is not supported for OpenGL in 
Red 3GL.

 

NOTE for ATI users: 

 

ATI model cards that are TNT enabled are not supported for 
OpenGL in Red 3GL.
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NOTE for ATI Radeon users: 

 

You may need to adjust the ATI Radeon control 
panel for OpenGL to work in Red. The ATI Radeon control panel is a modiÞcation 
to the Win display settings and provides several options and modiÞers for your 
card. The ATI Radeon control panel is a separate download/install, and is not the 
actual ATI Radeon driver. In the ATI Radeon control panel, go to the OpenGL Tab 
and move the 

 

Performance-Balance-Quality slider

 

 all the way to 

 

QUALITY

 

. If 
you do not adjust this slider, you may see display problems such as rainbow type 
artifacting in the Composite window when OpenGL is enabled.

 

NOTE for ATI Radeon users: 

 

The only supported and tested driver as of the initial 
Red 3GL is the 7-90-030605m-009437c Driver set which is available in the Previous 
Driver section of the ati web site. 

 

Checking your OpenGL Hardware, Software, Drivers and Settings

 

The Þrst time you launch Boris Red 3GL, an internal test is run on your system to determine 
whether your hardware meets the minimum requirements necessary for OpenGL 
Hardware acceleration. If your hardware does not meet the minimum requirements, 
OpenGL is disabled by default on your system. 

To perform the OpenGL 
Hardware test manually, 
press the 

 

Test OpenGL 
Hardware button

 

 in the 
Preferences window�s 
Render tab.

Depending on the amount 
of memory your graphics 
card has, this test may take 
a few minutes to run.

After the test is run, a window displays speciÞcs of the hardware and drivers installed on 
your system which are necessary to run OpenGL. If any test results show your system may 
have problems running OpenGL, the errors are detailed in this window. 

If you want, click the 

 

Copy to Clipboard button

 

 to copy this information to your system 
and clipboard. This allows you to print or email this information. When you Þnish, click 

 

OK

 

 
to close this window.
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Depending on your system, the test may take a few seconds to complete. The test stresses 
your OpenGL hardware, so you should run the test with a typical workload on your system. 
Before you run the OpenGL hardware test, launch any graphics applications that you 
usually run while you edit (any graphics intensive applications you are running at the time 
may affect the results).

Red 3GL uses the following guidelines for optimal OpenGL performance. Some of this 
information does not affect Red�s hardware testing but is useful for technical support if you 
are having OpenGL problems:

 

•   

 

Graphics Card-

 

- See the table and notes on page 5. Also see the updated list on the 
Boris FX website.

 

•   

 

OpenGL version-

 

-Should be 1.2 and higher.

 

•   

 

Driver Version-

 

-See the table and notes on page 5. Also see the updated list on the 
Boris FX website. As a general rule, driver versions created in 2003 should be installed.

 

•   

 

Texture Rectangle-

 

-This is an advanced OpenGL image sizing feature. If you are 
having OpenGL problems, this provides useful information for technical support.

 

•   

 

Texture Memory-

 

-

 

 

 

Texture Memory displays the amount of memory on the video card 
available for Red to use for textures (layer images).To use Red 3GL without display or 
performance problems, Texture Memory

 

 

 

must be at least 32MB. Texture Memory 
available is not the absolute of memory on your card, but rather the amount available 
to Red.

 

•   

 

Texture Dimension

 

 displays the maximum texture size that can be used with the video 
card.

 

•   

 

If you are using a Macintosh, you must have at least Macintosh OS 10.2.6 on your 
machine to support OpenGL; your 

 

Macintosh OS Version

 

 is displayed.
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OpenGL Errors

 

When the OpenGL Hardware Test is run, error messages may display if your system fails. 
These errors display as Hardware Status errors or Critical Testing errors. 

 

Hardware Status errors 

 

report the status of your current system setup against Red�s 
recommended video card manufacturer, model and driver. These errors will not prevent 
you from using OpenGL, they just warn you that your speciÞc system and setup may cause 
problems with OpenGL. Hardware Status errors can include messages such as insufÞcient 
available texture memory or reports that your video card was not recognized by Red�s 
internal hardware testing. When you receive a Hardware Status error, OpenGL is 
automatically disabled when you launch Red. However, you can manually enable OpenGL 
in the Red Preferences window. 

To enable OpenGL in the Red Preference window, open the Preferences window by 
choosing Edit > Preferences (Windows) or Boris Red > Preferences (Macintosh). Click the 
Render Tab and select the

 

 Accelerated Draft Preview checkbox

 

. Choose the appropriate 
choice from the 

 

OGL Acceleration menu

 

. 

 

On, Max. texture caching

 

 provides the best 
performance and is the recommended setting.

 

Critical Testing errors

 

 report speciÞc errors that will not allow you to use OpenGL in Red. 
When you receive a Critical Testing error, OpenGL is automatically disabled when you 
launch Red. If you receive a Critical Testing error, you should not enable OpenGL in the REd 
Preferences or you may crash.

Due to a problem with Apple�s architecture, Final Cut Pro version 4.0 does not 
support Red�s OpenGL feature. When you launch Final Cut Pro version 4.0, a 
Critical Testing error is reported and OpenGL is automatically disabled. When this 
problem is resolved in a later version of Final Cut Pro, you can enable OpenGL in 
Red�s Preference window.

Certain errors are inßuenced by the display properties set on your video card. The 
display property settings are card-driver speciÞc. As a general rule, the display 
properties should be set to 32 bits of color, with the depth buffer set to at least 16 
bits. On many cards the OpenGL capabilities are reduced when higher display 
resolution and refresh rates are set.

You can still use Red 3GL without OpenGL or with an older card, you just won�t 
gain as much acceleration while working. 

 

Troubleshooting OpenGL Issues

 

To toggle OpenGL off, use the keyboard shortcut Command or Control-[. To turn it back on, 
the keyboard shortcut Command-] (Macintosh) or Control-] (Windows). Menu choices also 
appear in the Preview menu and in the Preferences window. You can still use Red 3GL 
without OpenGL or with an older card, you just won�t gain as much acceleration while 
working.
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Display problems such as white, rainbow or garbage images in the Composite window may 
be related to OpenGL. If this occurs, open the Preference window�s and change the 

 

OpenGL 
Acceleration menu 

 

to use less texture caching. This option is in the Render tab. Texture 
caching is used for textures (layer images) and is related to the amount of Texture memory 
on the video card. Display problems related to OpenGL will not affect your rendered effects.

If you experience OpenGL problems, setting the 

 

OpenGL Acceleration menu

 

 to 
use less texture caching will improve OpenGL reliability and reduce stress on your 
card, although it will lessen OpenGL performance.

 

Supported Preview to Monitor Hardware

 

You can now output video to an external monitor through a FireWire converter box or 
through supported video hardware connected to your system. You can output media at any 
project size and immediately view your working frame without rendering the timeline. 

Some hosts which have native Preview to Monitor (PTM) where Red passes a frame and the 
host displays it. If a host has this ability, for example Avid, then nothing changes from the 
Red 2.x capabilities. However, if a host did not have native PTM ability, then you can use 
the new Preview to Monitor feature. The user does not have hardware choices in the 
Preferences window if Red uses native host PTM (since the host controls the hardware 
connection).

The plug-in version Red can only use the FireWire output if the NLE releases it 
while Red is running. A number of hosts (for example Premiere) will not release 
control of the primary display hardware while they are launched. This prevents 
Red's Preview to Monitor feature from working either in the plug-in or the Red 
Engine until the NLE releases control of the FireWire hardware.

However, Red looks for all possible output devices upon installation, and lists the results in 
the Device menu in the Preview tab of the Boris Red preferences. As a result, users may be 
able to use a different output device for Red than the one that the host application uses. The 
host application may use its own capture hardware for display, leaving the FireWire port 
available. 

For the Þrst time with Boris Red 3GL, video-out capabilities are also available in the 
standalone Boris Red Engine. This enables anyone with supported video hardware, 
whether built into their computers, included with their NLEs, or provided through third 
parties, to see the work they create in Boris Red immediately on television monitors.

Red 3GL supports the following video cards for the new Preview to Monitor (PTM) feature 
in both the Red Engine and while using Red in your host. For detailed information on the 
new PTM feature, see Volume I of the User Guide.

Make sure you have the latest drivers installed for the supported video cards.
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Supported PTM Cards

 

•   Cinewave®

•   Matrox ®Parhelia®

•   AJA® Xena®

•   Canopus® RT® (See note below.)

NOTE for Macintosh Users: Most cards supporting standard QuickTime video out 
capabilities and drivers should work.

NOTE for Windows Users: Although the previous cards were internally tested and 
approved, other cards may work as well. We also support standard Þrewire out. 
Many Canopus RT boards will work, although we cannot guarantee they all will.

NOTE for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

Once the hardware is connected, choose Connect to Monitor from the Preview menu. 
Commands in the Preview menu allow you to set the video display. You can output media 
at any project size and immediately view your working frame without rendering the 
timeline. 

When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite window, 
the image displays on the external monitor, using the Resolution and Quality settings 
speciÞed in the Composite window. 

When you choose Display HQ on Monitor from the Preview menu, the image displays on 
the external monitor, using the Full Resolution and High Quality settings, regardless of the 
Resolution and Quality settings in the Composite window. When you choose Auto-Update 
Monitor from the Preview menu, every frame of your effect previews to the external video 
monitor connected This allows you to drag the CTI in the timeline and view updating 
frames. This option is not available in some host applications or system conÞgurations.

Once the hardware is connected, conÞgure the Red Preferences to use this feature. See the 
next section for details.
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Enabling Preview to Monitor

NOTE for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

To enable the Preview to Monitor feature, launch Red 3GL and open the Preferences 
window.

1. Choose File > Preferences (Windows), or Boris Red or Edit> Preferences (Macintosh).

2. Click to select the Preview tab.

3. In the External Monitor Output section, choose 
your Firewire Converter box or Video 
hardware board from the Device menu. 

The Device menu displays all the supported 
hardware connected to your system.

4. Choose an option from the Mode menu if applicable. For example, if you are using a 
Firewire Converter box, you can choose PAL and NTSC formats from the Mode menu.

5. Click OK to save your settings and exit the Preferences window.

The Preview to Monitor preferences will be saved and applied to all Red projects 
unless your Red 3GL preference Þle is rebuilt.

Displaying Frames on your External Monitor
Commands in the Preview menu allow you to set the video display: 

•   When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor 
is enabled and the following three options in the menu become available:

•   When you choose Auto-Update Monitor from the Preview menu, every frame of your 
effect previews to the external video monitor. This allows you to drag the CTI in the 
timeline and view updating frames. The image displays on the external monitor, using 
the Resolution and Quality settings speciÞed in the Composite window.

Enabling Auto-Update Monitor will slow Red since every frame updates in the 
external monitor.

•   When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite 
window, the current frame displays on the external monitor, using the Resolution 
and Quality settings speciÞed in the Composite window. 
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•   When you choose Display HQ Frame to Monitor from the Preview menu, the image 
displays on the external monitor, using Full Resolution and High Quality settings, 
regardless of the Resolution and Quality settings in the Composite window. 

Disconnecting Preview to Monitor
To disconnect Preview to Monitor (for example if you want to connect another device to 
your video board while editing with Boris Red), exit Red. When you relaunch Red, the 
external monitor is not connected until you choose Connect to External Monitor in the 
Preview menu.

Tips for Using the Preview to Monitor Feature

NOTE for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

•   Preview to Monitor automatically disconnects when you exit Red 3GL. This means 
each time you launch Red, you need to choose Preview > Connect to External Monitor 
in order to reconnect and see your image on the external monitor.

•   To change the Preview to Monitor device or mode, disconnect Red 3GL�s Preview to 
Monitor feature by choosing Disconnect External Monitor from the Preview menu. 
Enter the Red 3GL Preference window�s Preview tab to choose a new Device or Driver 
from the External Monitor Output menus. You can also reconnect via the Preview menu 
with those new settings in the same session.

•   Displaying images on an external monitor 
requires compressing and resizing the images. 
Red 3GL may run slower if you have Auto 
Update enabled. Deselect Auto-Update 
Monitor in the Preview menu to remain 
connected to the external monitor but not 
automatically update frames. 

Manually update frames to your external 
monitor by choosing Preview > Display Frame 
to Monitor, or Preview > Display HQ Frame to 
Monitor, or by pressing the Display Frame to 
Monitor button on the upper-right corner of the 
Composite window. Display Frame 

to Monitor 
Button
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Important Note on Missing Filters

Several BCC Þlters are not included on the Boris Red 3GL installation CD. Instead, the BCC 
DeGrain, BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur Þlters 
will be available as a free download to registered users. These Þlters will be available on the 
Downloads page at www.borisfx.com.

You must register Boris Red 3GL to be eligible to download the BCC DeGrain, BCC 
Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur Þlters. See 
the Install Guide PDF on your Red 3GL CD for details on registering.

Important Information for Avid Users

Avid users can now apply Boris Red as a Þlter to titles created using the Avid Title tool.

Applying Boris Red as a Title-Matte Effect
You can apply Boris Red directly to titles created in the Avid timeline. For example, if you 
have a bin with saved titles, you could apply a Þlter to the titles in Red.

1. Edit an Avid title or matte key into the Avid timeline.

2. Open the Avid Effect Palette and select Boris Red from the Effect categories.

3. From the list of available Red effects, drag the Boris Red Title-Matte Effect to the title 
or matte key in the Avid timeline.

Dragging the Title-Matte effect onto an Avid title or matte key is a destructive 
process which replaces the title or matte key. Additionally, removing a Title-Matte 
effect removes the title�s nested alpha channel. To remove a Title-Matte effect and 
preserve the title or matte key, use the Undo command instead of the Remove 
Effect command.

4. Click the Other Options button in the Avid Effect Editor to launch the Red interface and 
create your effect.

If the title or matte key looks blocky when Red opens, select its Face track in the 
timeline. In the Host Media tab, choose Straight Alpha from the Key menu. This 
usually happens automatically.

Replacing a Title-Matte Effect

Since a title is replaced by applying the Title-Matte effect, to re-edit a title with a Title-Matte 
Effect (for example to change the text or a font) you must save the Title-Matte effect while 
you are in Red (in the File menu). Recreate the Avid title and overwrite the older title in the 
Avid timeline. Drag a Red Title-Matte Effect to the new title. In Red, open the saved effect 
and apply it to the new title.
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Important Information for Final Cut Pro Users

Due to a problem in the Macintosh OS, Final Cut Pro version 4.0 does not support 
Red�s OpenGL feature.When you launch Final Cut Pro version 4.0, OpenGL is 
automatically disabled. If you attempt to enable OpenGL in the Red Preferences, 
you will crash when you apply back to Final Cut. We expect this problem to be 
Þxed in Macintosh OS 10.3, after which you can enable OpenGL in Red�s 
Preferences window.

NOTE for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

•   Final Cut Pro 4.0 users can now use Boris Red as a transition, taking advantage of a 
new transition architecture jointly developed between Boris FX and Apple. See 
Appendix B in Volume I of the Red User Guide for information on applying Boris Red 
as a transition in Final Cut Pro 4.0.

•   Red 3GL includes a Static Generator for Final Cut Pro. The Static Generator allows you 
to create a static slate which takes advantage of Final Cut Pro�s real-time capabilities. 
When you apply the Static Generator, the Boris timeline opens with a duration of one 
frame which can then be applied to Final Cut Pro as a static slate.

•   If you want to enter the Red interface to edit an existing Red effect, make sure the time 
indicator is positioned on the effect you want to edit before launching Boris Red. 
Otherwise, the Boris interface will not appear.

•   Users working in 16x9 or non-broadcast square pixel (non 4x3) aspect ratios should 
make sure Video Aspect ratio settings are properly set in the General tab of the Red 3GL 
preferences. In some cases it is now necessary for the user to set this. This was 
automatically set by Final Cut Pro in the past. This change was made because the 
preference wasn't being set correctly in some situations. The Red 3GL Video Aspect 
Ratio preference defaults to 4x3, so it is now usually necessary for users to change the 
preference when working in 16x9 or a non-broadcast square pixel (non 4x3) aspect 
ratio.

•   Do not export from Boris Red unless the host resolution is set to 100%. Otherwise, you 
will get reduced image quality, because the host does not provide Red with full-sized 
frames. 

Likewise, if Final Cut Pro is at less than full resolution (100%), previews at full size 
appear in reduced quality.

•   In some instances the Boris Red 3GL plug-in crashes due to an apparent conßict with 
MacsBug v6.6.3. If you have MacsBug 6.6.3 installed and experience crashing, try 
disabling or running an earlier version of MacsBug when using Boris Red.

•   If both Red 3GL and an earlier version of Red are installed within Final Cut Pro, the 
Effects menu lists both versions with the same name: Boris Red. The top item in the list 
is Boris Red 3GL and the second item in the list is the earlier version of Boris Red 2.x. 
We recommend you uninstall earlier versions of Red when using Red 3GL.
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Installing and Using Adobe After Effects Filters within Boris Red

Boris FX provides a supported list of AE Þlters for use inside Boris Red. For best results, use 
only supported AE Þlters inside Boris Red. An list of Supported, Conditionally Supported 
and Unsupported Þlters can be found on our web site: www.borisfx.com.

Supported Þlters were tested on single-processor machines. While these Þlters 
should also work in multi-processor machines, it is possible you will experience 
unexpected results or your machine may crash. If you have problems with 
supported Þlters in multi-processor machines, try disabling the MP functionality 
on your machine and recreating your Þlter effect.

Boris Red 3GL includes four free DigiEffects Delirium Þlters: DE Day for Night, DE 
Fog Factory, DE Fireworks and DE Electrical Arcs. These Þlters are installed in the 
Boris Plug-ins folder when you install Boris Red 3GL. For more information about 
these Þlters, see the DigiEffects_info.pdf and the DeliriumUserGuide.pdf 
documents included on the Boris Red 3GL CD. See the Known Limitations Filters 
section on page 27 for information on limitations using these Þlters in Red.

NOTE for Tinder Users: When you use Tinder Þlters, Tinder�s Effect Viewer UI 
only works properly when the Red Composite window is set to Full Resolution. 
Additionally the Effect Viewer may disappear after dragging tracks around. Use 
the regular UI controls if you experience this problem.

Important Information on Using After Effects Filters
•   Checkboxes and menus cannot be animated. 

•   Time remapping Þlters do not work in Boris Red.

•   After Effects Þlters used inside Boris Red may take longer to render than most Boris 
Red effects.

•   None of Adobe's built-in After Effects Þlters work inside Boris Red.

•   Some of the After Effects Þlters need to be frame rendered. If renders appear noisy or 
jittery, deselect the Better Quality Field Rendering checkbox in the Boris Preferences 
window and re-render the effect.

•   You can install up to 900 AE Þlters in Boris Red. If you have more than 900 Þlters 
installed, you will not see some of your Þlters inside Boris Red. If you reach the Þlter 
limit, a warning appears when you launch Boris Red, asking you to remove some Þles 
from the BorisPlugins folder and restart Boris Red. You can ignore the warning dialog 
and continue to work in Boris Red but you will not have access to all the AE plug-ins 
inside the BorisPlugins folder. You can use the Plugin Filter Manager to hide the Þlters 
you don�t need in Red. See Chapter 4, �Creating Effects �in Volume I of the User Guide 
for more information on using the Plugin Filter Manager.
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Installing AE Filters for Macintosh
Macintosh users should place supported After Effects Þlters in the following folder:

System Folder (or Library)/Application Support/BorisFX/BorisPlugins.

The Þlters appear in the Filters menu within Boris Red.

Installing AE Filters for Windows
Windows users should place supported After Effects Þlters in the following folder:

C:\Program Files\Boris FX, Inc.\BorisPlugins.

The Þlters appear in the Filters menu within Boris Red.

Important Information about Exporting to Flash

Supported Effects
The following effects are supported for exporting as Vector to Flash.

•   Text

•   Spline media

•   2D Charts (which consist of text and spline shapes)

Other bitmap elements such as video or still graphics can be included in the exported Flash 
Þle and will be JPEG-compressed. In the Export preferences you can set the quality of the 
JPEG compression. 

When you export text to Flash, any texture that was applied to the text is ignored.

When you export text with a gradient Þll to Flash, the resulting .swf Þle is blank.

Red exports Flash .swf Þles that are compliant with the Flash 5 architecture. If you 
are using QuickTime to preview your exported .swf Þles, you need the version of 
QuickTime that supports the Flash 5 format.

Exporting as Flash
Boris Red allows you to export Þles in the Macromedia Flash (SWF) format. This feature 
allows you to export compositions as compact, vector-based Þles optimized for web 
viewing. For example, you could export a Type On effect to include on a web page.
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The SWF format was designed primarily for animated 3D Line Art objects, so it works well 
when exporting settings that contain spline and text animations. Settings that contain video 
or animated bitmaps, however, generate rather large Þles. You might want to consider 
exporting such animations as a QuickTime or AVI Þle. See �Exporting Effects as Movies� on 
page 297 in Volume I in the Red User Guide for more information. 

There are some limitations with the Flash export feature. You cannot export 3D Extrusion 
tracks as Flash. Settings that contain 3D Extrusion tracks will export as a blank track. The 
Flash export feature does not support shadows or gradients used as Texture tracks. 
However, you can export a static gradient as a bitmap background. 

To prepare to export to Flash, you should change any shape track containing EPS 
Þles, text, or Spline media to 3D Line Art shape. Because you cannot use the 3D 
Line Art shape with the Brush tool, you cannot export brush strokes as Flash.

To export a track as a Flash Þle:

1. Select the appropriate track in the timeline.

2. Choose File > Export > Flash.

A dialog box appears that allows you to name and save the Þle.

3. Name the track and click Save.

The composition is exported using the Flash Export settings, which are controlled by 
the Preferences window�s Export tab. 

For more information, see Chapter 4 in Volume I in the Red User Guide.

Important Note on Creating Time Effects within Boris Red

The following important notes pertain to Time Þlters, including Optical Flow.

•   Exporting an effect containing a Time Þlter (including Optical Flow) with host media 
is NOT recommended. If you want to export from Red with Optical Flow (or any Time) 
Þlter in the timeline, you should use imported media in the source track.

This is because most hosts will not give Red both Þelds at set-up (preview). In that case, 
what goes into the motion estimator is the Þrst Þeld of each frame. If the motion is small 
from one frame to the next, and/or includes little �crossing motion,� the preview will 
appear close to the rendered output. However, if the motion is large, and/or includes 
a lot of �crossing motion,� it is important for the motion estimator to have access to both 
Þelds in order to see an accurate preview of the rendered result.

•   Some hosts do not allow plug-ins to access host frames at different times. If your host 
does not allow Boris Red to access alternate frames, an �X� displays in the Composite 
window when you apply a Time effect to host video. If you run into this limitation, 
instead of applying to host video, set the source media for these Þlters to Movie media 
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Þles (QuickTime, AVI) instead. This may require exporting your timeline video from 
the host application as a movie. If you are using Media 100 i, you can easily bring in 
native Media 100 movie Þles through the Bin Browser.

Important Information about Working with Motion Filters
•   You should use the Snap CTI to KeyFrame option (Track > Snap CTI to KeyFrame) 

when working with the Motion Þlters to avoid confusion. For example, this option is 
not selected and you move the CTI off a selected keyframe. Then you adjust the Search 
and Target parameters using on-screen controls. A new keyframe is not created. 
Instead, the selected keyframe is adjusted. This could cause your media to track 
incorrectly. If you want to create a new keyframe, you must deselect all keyframes 
before adjusting parameters on-screen.

•   While Interpolation Fields appear next to the Search/Target tab parameters, you 
should not adjust the Interpolation. Leave the Interpolation set to Hold. Adjusting the 
Interpolation will not affect the tracking but may cause on-screen parameters to 
display incorrectly.

•   You can work at Half or Quarter Resolution to achieve a preview of a motion Þlter. But 
if the motion tracker fails repeatedly, you may have to work at Full Resolution.

•   You can only adjust the Search and Target regions in the Motion Þlter track's Preview 
window. The Source track does not display the region controls; the Composite window 
does not display the region controls.

•   The Þeld order of the media must match the Þeld order setting in the Media tab. You 
can set this in the Import tab in the Preferences window. See Volume II in the Red User 
Guide for more information.

Important Information Using the KeyFrame Library

The Þrst time you browse the KeyFrame Library effects within the Library Browser you 
must generate thumbnail images for the effects. 

1. Open the Boris Library Browser, by choosing Window > Library Browser, 
clicking the Open Library Browser button in the timeline or pressing 
Command-9 (Macintosh) or Control-9 (Windows).

2. Select an effect or effect folder and click the Generate Thumbnails button. For more 
information on using the KeyFrame Library, see Volume I of the Red User Guide.

We recommend that when you build thumbnail previews for the KeyFrame 
Library, you do this in the Red Engine rather than within your host application. 
Because building previews actually renders your effect, this process can take as 
much as 25-30% longer in the plug-in than in the Red Engine.
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Also Included with Red 3GL

•   Boris Red 3GL installs four DigiEffects Delirium Þlters: DE Day for Night, DE Fog 
Factory, DE Fireworks and DE Electrical Arcs. These Þlters are installed in the Boris 
Plug-ins folder when you choose to install the BCC Plugins for Red using the Boris Red 
Components install choice in the Red installer. For information about these Þlters, see 
the DigiEffects_info.pdf documentation included on the Boris Red CD. See the Known 
Limitations Filters section on page 27 for information on limitations using these Þlters.

•   The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu and offers the equivalent of 
over 600 pages of text, with over three hours of narrated video to take you into as much 
or as little detail as you need, for any kind of task you might want to perform.

Seamlessly integrated into Boris Red, the Intelligent Assistant operates in a resizable 
ßoating window above Red, so that you can easily work along with provided 
examples. Along with instructions for speciÞc tasks, the Intelligent Assistant also 
provides insight into broader-based effects-creation strategies, a number of tutorials, 
and creative examples of Þnished projects using illustrated techniques. The Intelligent 
Assistant is fully searchable and hyperlinked. Its modular structure makes it easy to 
use. Users with internet connections can automatically download new content.

More information on the Intelligent Assistant is available in Volume I of he Red 
Users Guide. See �Boris Red Online Help: The Intelligent Assistant� for 
information.
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Changes to the Red 3GL User Guide

The following features or changes were introduced after the Red 3GL User Guide was 
printed. The Red 3GL User Guide is now divided into two volumes. The two volumes are 
designed to help you understand the many options offered by Boris Red so that you may 
use this complex program to its fullest potential. A separate PDF document of the User�s 
Guides is located on the Boris Red CD-ROM.

The illustrations in the Boris Red User Guides appear as grayscale images. If you 
need to view an illustration in color, see the UserGuide.pdf located on the Boris 
Red CD-ROM, and accessible from the Red 3GL Help menu.

Keyboard Shortcuts
The Keyboard Shortcuts Appendix was not included in the printed version of Volume I of 
the Red User Guide. Instead this information appears in a separate Keyboard Shortcuts pdf 
on the Red CD.

New Modifier Keys for Dial controls
When using the mouse on dial controls, you can now use the following modiÞers:

•   Press the Shift key to round the marks on the dial controls to the nearest 45 degrees.

•   Press Control (Windows) or Command (Macintosh) to round the marks on the dial 
controls to the nearest 10 degrees.

•   Press Shift-Control (Windows) or Shift-Command (Macintosh) to round the marks on 
the dial controls to the nearest 5 degrees.

•   Press Shift-Control (Windows) or Shift-Command (Macintosh) and use the mouse 
wheel to round the marks on the dial controls to the nearest 45 degrees.

When tracking with a mouse wheel on dial controls, you can now use the following 
modiÞers:

•   Use the mouse wheel with no modiÞer keys to move the dial controls in 1 degree 
increments.

•   Press the Shift key and use the mouse wheel to round the marks on the dial controls to 
the nearest 10 degrees.

•   Press Control (Windows) or Command (Macintosh) and use the mouse wheel to round 
the marks on the dial controls to the nearest .1 degrees.
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Fixed Bugs in Boris Red 3GL

Red 3GL Þxes many bugs. Fixed bugs include the following:

•   Windows only: When resuming a paused render in the Render Queue, the render now 
resumes where you stopped it rather than at the beginning.

•   Windows only: If you delete a composition from the Render Queue then choose Undo 
and render the composition, you will no longer receive a �Failed to render because of 
errors� error message.

•   Undoing a keyframe move on a spline object track will undo the keyframe and also 
undo the manipulations at that keyframe.

•   When you create two Spline Objects and use the Hollow Arrow tool to lasso them, you 
can now use the Combine Contours feature (Tools > Path > Combine Contours). 

•   Top Down text punctuation is now placed correctly for Japanese text.

•   Copying and pasting (and importing) Kanji text from other applications no longer 
exhibits problems. 

•   Mac OS X only- If you import an .rtf format that was created in the OS X application 
Text Edit, the formatting will now appears correctly in the Red Text window. 

•   The Combine Contours command now allows you to combine multiple shapes at once.

Known Limitations in Red 3GL

Red 3GL includes the following known limitations. 

General Limitations
•   The Motion Blur Button is a global preference. That means that, when you render, all 

settings will respect the last setting of this checkbox in the UI. This is not a bug, but can 
be confusing when you render multiple effects in the Render Queue.

•   MP Users only: On MP systems, the Red render thermometer in the Composite 
window does not clear after frames in the Comp window are updated. The render 
thermometer stays fully drawn. 

•   If you tumble an object that has an image bump map (such as a movie or still image 
Þle), you may see a moire pattern as it tumbles. 

•    Windows only: If you reopen a saved setting where you previously changed the color 
of a border or gradient using the eyedropper, in some instances the color will have 
reverted back to its original color. 

•   When you save a style to the Materials tab in the Style Palette, it does not correctly save 
the Source type that was used in the Bump Map tab.

•   The V key in the new Color Preview feature does not work to commit to a color. You 
can use the C key to dynamically preview colors, but you cannot use the V key to 
commit to them. Click the mouse instead.
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•   When you open settings created in previous versions of Red, Red 3GL ignores controls 
that were initially enabled in the Lights 2 and 3 tabs.

•   If you import Þles into Red that were created in Adobe Illustrator version 9, they 
display as transparent. Save the Þle in Illustrator version 8, or as an EPS Þle instead.

•   When you search for a missing media Þle using the Search button in the Media Files 
window, it may not Þnd Þles that were moved to another local drive. Manually browse 
to the new location of the Þle and press the Replace button.

•   Tracks containing PSD Þles that have been converted to containers do not correctly 
update if you modify them (for example in Photoshop) and then use the Reload Files 
command.

•   The PixelChooser mask renders into Þnal rendered effects. It should only display in the 
Composition window.

•   Files exported to Flash from Red cannot be used in Macromedia Flash authoring 
applications such as Flash MX.

•   If you use the Keyframe Time Þeld in the timeline to move keyframes, all keyframes 
that a moving keyframe passes are merged to it. Instead, move keyframes past one 
another by dragging the mouse.

•   If a track in the timeline has media nested inside one or more of its tracks, moving the 
parent track up or down in the timeline will cause the track to open and display all of 
its subtracks., including opening all of the nested tracks.

•   Photoshop (.psd) Þles with adjustment layers will display incorrectly in Red if you 
convert their track to a container. Turn off any adjustment layers in Photoshop before 
importing .psd Þles if you plan on converting them to containers.

•   Resuming a partial render of an exported QuickTime Þle may have some undesirable 
side-effects. In particular, video compressed with codecs that use frame-differencing 
and data-rate-limiting (such as Sorenson or Cinepak) may exhibit some of the 
following behavior during playback. 

Some frames following the resume point may be corrupted. The data rate may be 
slightly larger than expected. Also, if the Þle includes an audio track, a slight blip may 
be heard at the resume point. This may occur with any codec.

•   If you use Frame-Differenced movies in Boris Red (including movies compressed with 
Apple�s Quicktime Animation codec, and some movies compressed with Sorenson), 
you will see reduced performance within Red. The use of Frame-Differenced movies is 
not recommended within Red.

•   When Þeld media is exported or previewed as frames, only the Þrst Þeld is used.

•   If you are using a still image Þle as media in a track, then make changes to the source 
still image Þle and save the Þle using the same name, attempting to import the updated 
still image Þle into the original track will not change the media as expected. To refresh 
the media so the updated still image is displayed, use the Reload Files command.

•   Using non-square pixel aspect ratios (i.e. 720x480) can distort the EPS media type when 
used with the 3D Plane Shape. Use the 3D Line Art shape instead.
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•   Any effect that uses a Þlter involving edge detection (for example, Edgelight, RGB 
Edges, Particles, spotlights with edge effects, etc.) should be rendered with the Better 
Quality Field Rendering checkbox selected. Otherwise, the rendered effect will jitter. 

•   In the 2D and 3D Particles Þlters, increasing the particle size scale can cause some 
custom shapes to truncate. You can avoid this by looking at the initial, unscattered 
particle grid. If some particles are cut off by the frame when you increase their size, 
then they will remain cut off throughout the duration of the effect. To avoid this, adjust 
the size parameters so that no particles are initially cut off.

•   The Þrst rendered frame of effects using the 2D Particles Advanced Þlter will display 
particles, although you will not see particles in the Þrst frame of a preview.

•   When an image is full size in the Composite window, you must deselect the Shape 
control in the Composite window�s Controls menu to directly manipulate an object�s 
Mask or Crop controls. .

•   Windows only: Balance and Volume controls have no effect on audio tracks containing 
AVI Þles or MP3 Þles. 

•   Windows only: Boris RED exports Flash.swf Þles that are compliant with the Flash 5 
architecture. If you are using QuickTime to preview your exported.swf Þles, your 
QuickTime version must support the Flash 5 format. Older versions of QuickTime 
display the background as a solid color.

•   Final Cut Pro 4.0 only: When you use Red as a Transition in Final Cut Pro 4.0, the Red 
Preferences are not respected. This means that when you relaunch Red as a Transition, 
changes you make to Quality and Resolution and other settings in the Red Preferences 
are ignored and need to be reset each time.

•   Final Cut Pro 4.0 only: The Red banner in the Effect Control tab disappears after you 
apply an effect, click the Red banner to launch Red, and then apply back to FCP. You 
can still click in the area where the Red banner previously displayed, or click the 
Options button to reenter Red.

•   Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-in with 
FireWire for Red's Preview to Monitor feature, must disconnect before clicking the 
Apply button or FCP will crash. To disconnect, choose Preview > Disconnect External 
Monitor.

•   Avid XpressDV and Speed~Razor only: The Tool window can be forced into the 
background if you open it then click a window it is ßoating over.

•   Avid AVX 1.5 hosts only: High quality two-Þeld host media may look Þeld doubled on 
the external monitor within the Red UI. This is because the Avid AVX 1.5 architecture 
passes us one Þeld, and we double it. Set Host Field Order (in the Import tab in the 
Preferences window) to None to Þx this. This setting only affects exports of host video 
using Þelds as frames. 

•   Windows Avid Xpress Pro Only: Due to a problem on Avid�s side, you will crash when 
exporting a QT movie if you choose Avid�s MPEG 2 codec.

•   iFinish only: Intermittently, iFinish�s Media 100 codec is not available within Red�s 
QuickTime Export options list. Quitting and relaunching iFinish may Þx this.

•   Premiere 6 only: When exporting host media through RED, use Fields > None to export 
movies, rather than choosing upper or lower Þelds.
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•   Pinnacle systems only: Although choices appear for accessing video tracks 1 - 32, you 
can only successfully access tracks 1 and 2. Tracks higher than two display as black. 
This is a limitation of the Pinnacle plug-in architecture. 

•   Sony Vegas only: If a Boris effect is prerendered in the Vegas timeline, future changes 
to that effect in Boris will be saved but do not appear in the Vegas Preview window 
until you remove the prerender in Vegas (Tools > Clean up Prerendered Video).

•   Sony Vegas only: Vegas only previews a single frame of video in Boris Red. The 
preview frame is taken from the current position of the Vegas cursor. To preview your 
effect with updating source media, exit Red and preview the effect in the Vegas Video 
timeline. 

•   Sony Vegas only: Motion Blur does not display in a rendered effect if you apply Red 
directly to a clip in Vegas. Instead, import the media directly into the Red timeline and 
you will see motion blur after you render your effect.

•   Sony Vegas only: The Þrst time you launch Red you may get an OpenGL Context error. 
If you see this error and continue through it to enter Red, changing a track�s media type 
to Movie media will crash your machine. Launch Red again and you should be able to 
successfully enter Red with no errors.

Limitations with OpenGL
•   Due to a problem in the Macintosh OS, Final Cut Pro version 4.0 does not support Red�s 

OpenGL feature.When you launch Final Cut Pro version 4.0, OpenGL is automatically 
disabled. If you attempt to enable OpenGL in the Red Preferences, you will crash when 
you apply back to Final Cut. We expect this problem to be Þxed in Macintosh OS 10.3, 
after which you can enable OpenGL in Red�s Preferences window.

•   Extruded shapes inside Z-Space Containers will display in the Composition window 
in OpenGL Draft mode even when the extruded shape is grayed out in the timeline.

•   There are situations where the Render thermometer does not update when you work 
with OpenGL enabled in High Quality mode. For example, creating effects while a 
Þlter track is selected or if you click the CTI in the timeline. When you drag along the 
timeline the Render thermometer always updates.

Limitations with Keyboard Shortcuts
•    Windows Only: The shortcut for changing color channels to RGB is labelled incorrectly. 

The Preview menu displays Color Channel as (ALT+-), but the actual shortcut is 
(ALT+`). You can assign new shortcuts in the Shortcuts window. See 
Volume I in the User Guide for more information on creating shortcuts.

•    Windows Only: The shortcut for hiding marks is listed as (CTRL+ALT+�), however that 
shortcut does not work. Use the menu choice in the Preview menu, or create your own 
shortcut in the Keyboard Shortcuts window instead. You can assign new shortcuts in 
the Shortcuts window. See Volume I in the User Guide for more information on creating 
shortcuts.
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•   Windows Only: After creating new keyboard shortcuts, certain items in the Windows 
menu may show duplicate keyboard shortcuts (for example, the Filter Palette and 
Media Files window display the same keyboard shortcut). You can assign new 
shortcuts in the Shortcuts window. See Volume I in the User Guide for more 
information on creating shortcuts.

Limitations with the Spline Object Media Type
•   Windows Only: There are instances when you may want to include tracks that use the 

3D Plane shape in a 3D Container that uses the 3D Model Renderer. This allows you to 
apply 3D parameters such as Materials, Textures and Bump Maps to two dimensional 
shapes. When you use one of these two dimensional shapes in a 3D Model container, 
the track is called a 3D Primitive. However, render problems can occur when you 
enable a Bump Map for a Spline Object or Spline Primitive track in a 3D Model 
Container. Areas of the Bump Map can appear as a solid dark color or with dark bands 
if the track is tumbled or spun in 3D space. The workaround for this problem is to 
extrude the Spline track by assigning it the 3D Extrusion shape. Then set the Extrusion 
and Bevel amounts to zero to maintain the Flat look.

•   If you select a group of splines in the Composite window and adjust one of the Path 
track�s control parameters, the changes are not applied to any of the splines. The Path 
controls can only adjust one spline at a time.

•   The Reverse Keyframes command (Track > Reverse Keyframes) does not work in 
Spline effects. 

•   If you apply a spline style from the Style Palette to a spline primitive shape, the shape 
resets back to the default shape values.

•   Spline effects using the extruded pencil with animated borders may exhibit frames that 
look different after rendering than they did when creating and previewing the effect. 
These frames will display the pencil as ßat, and not extruded. If you see this, use the 
pen tool in the Tool Palette to slightly adjust any point in a way that won�t noticeably 
change your effect.

Limitations with Text Features
•   Windows only: You cannot apply styles to text in the Text window. If you apply a style, 

it appears to work, but once you close the Text window, the style reverts back.

•   When the Text window is open, changes made in the Controls window (such as 
Margin, Wrap, or Font) will not update to the Composite window.

•   The Date format Day/Month/Year in the Date/Time generator displays a comma at the 
end if you have suppressed the time display.

•   When Top-Down text is selected, the Text Wrap menu setting is ignored. 

•   Tracking controls the global horizontal spacing of the characters in an effect. Tracking 
behaves differently depending on whether the text was created with the Text tool or in 
the Text window. When you create text with the Text tool, the tracking honors the 
justiÞcation that is set in the Transform tab. When you create text in the Text window, 
the tracking is applied with center justiÞcation. If you want to track to the right or left 
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using text that was created in the Text window, select the text with the Text tool and 
move it slightly. Then set the justiÞcation in the Transform tab. The Tracking now uses 
the justiÞcation. For more information, see �Working with the Transform Tab� in 
Volume 1 of the Red User Guide.

•   When using Kanji text, the underline option overlaps certain characters, depending on 
their size. 

•   Importing RTF documents using the Insert Text feature in the timeline�s contextual 
menu will cause all tab delimited text to appear on the Þrst line in Red, rather than in 
multiple lines. You will need to manually insert line breaks to break up the text. 

•   Text on a Path moving from right to left will display upside down. To correct this, 
manually reverse the path, or click the Reverse Path checkbox in the Path tab. 

•   Windows Only: The Style Palette lets you save thumbnails of the available fonts on 
your system in the Fonts tab. The Þrst time you launch this tab you have to add a 
category and use the Rebuild Category button to generate the thumbnails. After that 
you only need to rebuild the category if you add more fonts to your system. Unlike the 
other tabs in the Style Palette, you cannot save styles to the Font tab, so the Apply 
controls as well as the Add Style and Rename Style buttons do not appear when you 
are in the Font tab.

However, on Windows systems, the Font category that you create appears in both the 
Font tab and the Text tab. In addition, the Text categories also appear in both of these 
tabs. To avoid confusion, make sure that you give the Font category a descriptive name 
such as �System Fonts.�

•   Text effect settings created in previous versions of Red may appear to have different 
leading and spacing values when opened in Red 3GL. 

•   If you Flip an image vertically and then render it through the host, the rendered video 
appears jittery. Enable the Better Quality Field Rendering checkbox to render correctly.

•   Text Radial edge widths over 18 points appear strange in characters like �o� and others 
with centers. 

Limitations with Chart Features
•   Accented letters such as é are not passed from the Chart Editor to the Chart Container 

correctly. Therefore, a Chart Legend or Grid label that uses accented characters must be 
entered directly into the text track, using the Text tool or Text window. If this is 
necessary, it must be done as a Þnal step when building the chart. This is because 
editing the chart data or enabling/disabling the Legend or Grid updates this text using 
Chart Editor text; as a result, the accented characters will be lost.

•   When both the Reveal and Remove checkboxes are enabled in the Animation tab, 
Position X no longer animates when you work with extruded Bar and Pie Charts.

•   Removing an extruded Bar Chart by selecting the Reveal Shape checkbox in the 
Animation tab does not work correctly. Instead of animating the height of the bars 
sequentially, they are simply removed individually. In addition, when this checkbox is 
selected, the Overlap Time parameter is not respected.
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•   For the most reliable results, the Animate button should not be in static mode. For 
more information, see Chapter 1 in Volume I of the Red User Guide.

•   On certain systems, extruded pie charts pieces may incorrectly display their corners. 
Reduce the bevel to 0 to Þx this.

•    If you have long names for the X axis (defaults: South, East, West, and North), and you 
are animating the chart (if you have animation turned on) the names will not line up 
with the actual chart.

•   Selecting the Apply Current Spline Style checkbox can create unintended changes if the 
setting is modiÞed after another spline style is selected. For example, you create a static 
Line chart setting with the Apply Current Spline Style checkbox selected. You apply 
another spline style from the Style Palette to a different track. If you then animate the 
chart, the chart will update with the latest spline style, rather than the style originally 
saved with the effect. The only workaround necessary is to reapply the original spline 
style from the Style Palette.

•   Depending on the scale you set for a Line Chart, you may see small nicks or 
indentations in the lines when you work in Full Resolution. Slightly increase or 
decrease the scale of the line chart to Þx this.

Limitations with Filters
•   If you have a large number of presets installed for BCC Þlters, the parameters in the 

BCC Þlters become less responsive and the rendering time increases.

•   If you apply a BCC Colorize Þlter as a standalone Þlter to the timeline, the gradient bar 
displays black instead of showing colors. This only happens when you apply it as a 
standalone Þlter, apply the Þlter to a track instead.

•   Windows Only: Do not press the About Box for the Delirium DE Day for Night FX 
Þlter. You will crash Red.

•   Avid Xpress DV only: The Þnal render of an Optical Flow effect that is applied to host 
media renders slightly jittery. 

•   When the default interpolation is set to Constant in the Preferences window, and a 
Motion Tracker Þlter is added to the timeline, resetting the default interpolation in the 
Preferences window will result in no keyframes being generated for the Motion Tracker 
when you move the tracker target/region until you exit and re-enter Red.

•   The Fire Þlter renders with the Þelds reversed unless you render it with Better Quality 
Field Rendering enabled.

•   In the Fire Þlter, when using text as a Map layer, the size of the text is ignored and will 
frequently display garbage. Map text to a Shape, then nest the shape layer inside the 
Fire Þlter to correct this problem. 

•   Some Þlters create effects that evolve over time based on their parameter settings. The 
output of these Þlters (for example Velocity Remap, Particle System, Comet) depends 
on their parameter values for the entire effect, and changing a parameter value on any 
frame in the effect changes the output for all subsequent frames. If you use one of these 
Þlters and see a jump in the animation after changing a parameter, the jump is probably 
because Red did not invalidate frames that were affected by the change. You can Þx this 
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by choosing Edit > Purge Frame Cache, and previewing again. Your rendered output 
does not use the cached frames from the preview, so even if you forget to purge the 
frame cache, your Þnal render will appear correctly.

•   Time Þlters do not work with host video when rendering in many hosts. They work 
with Movie media when rendering in the host. For more information on this limitation, 
see �Important Note on Creating Time Effects within Boris Red� on page 17. 

•   Time Þlters always use the Þrst Þeld of Þelded media when frame rendering or 
previewing.

•   Due to improvements made to many Þlters, some Þlters (for example Burnt Film) do 
not look exactly as they did in Red 2.5. 

•   The Motion Tracker Filter�s Analyze button won�t analyze the total length of the 
timeline if a movie Þle�s length is shorter than the duration of the effect and the movie 
Þle is set to Loop. 

Limitations with BCC Grain Filters
•   The grain Þlter presets do not store the grain sample, only the Þlter settings. If you load 

a Match Grain preset and want to use a stored grain signature, you have to load that as 
well. If you load a DeGrain preset with the Lock Sample checkbox enabled, Red will not 
acquire the sample. 

•   If you select a preset in the Match Grain Þlter, the preset name does not appear in the 
control.

•   The BCC DeGrain and Match Grain Þlters can only be used when Red�s Composite 
window is set to Full Resolution. When you apply the BCC DeGrain or Match Grain 
Þlters, if you are not in Full Resolution an error message warns you to set the 
Composite window to Full resolution. If you do not set the Composite window to Full 
Resolution, a red �X� will display in the sample box.
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Registration

Make sure to register your product in order to receive the latest technical and upgrade 
information.

You can register either by Þlling out the registration form online at 
http://borisfx.com/support/register.html or by sending us your completed registration 
card. 

We offer registered users one year of free technical support starting from the date of 
purchase. In addition, registered users have access to some free upgrades and new preset 
effects designed speciÞcally for Boris Red.

Contacting Technical Support

For technical support, contact Boris Red technical support specialists:

web: http://www.borisfx.com/support/

e-mail: support@borisfx.com

phone: 617-451-9900

hours: 9am-5pm Eastern Time (United States & Canada, GMT �05:00)


	Introduction
	Supported Hosts
	Supported Operating Systems
	Macintosh
	Windows

	Minimum System Requirements
	New Features in Red 3GL
	Support for Automatic Duck Composition Import
	Supported Hardware and Drivers
	Supported OpenGL Hardware
	Graphics Card
	Checking your OpenGL Hardware, Software, Drivers and Settings
	OpenGL Errors
	Troubleshooting OpenGL Issues

	Supported Preview to Monitor Hardware
	Supported PTM Cards

	Enabling Preview to Monitor
	Displaying Frames on your External Monitor
	Disconnecting Preview to Monitor
	Tips for Using the Preview to Monitor Feature

	Important Note on Missing Filters
	Important Information for Avid Users
	Applying Boris Red as a Title-Matte Effect
	Replacing a Title-Matte Effect


	Important Information for Final Cut Pro Users
	Installing and Using Adobe After Effects Filters within Boris Red
	Important Information on Using After Effects Filters
	Installing AE Filters for Macintosh
	Installing AE Filters for Windows

	Important Information about Exporting to Flash
	Supported Effects
	Exporting as Flash

	Important Note on Creating Time Effects within Boris Red
	Important Information about Working with Motion Filters
	Important Information Using the KeyFrame Library
	Also Included with Red 3GL
	Changes to the Red 3GL User Guide
	Keyboard Shortcuts
	New Modifier Keys for Dial controls

	Fixed Bugs in Boris Red 3GL
	Known Limitations in Red 3GL
	General Limitations
	Limitations with OpenGL
	Limitations with Keyboard Shortcuts
	Limitations with the Spline Object Media Type
	Limitations with Text Features
	Limitations with Chart Features
	Limitations with Filters
	Limitations with BCC Grain Filters

	Registration
	Contacting Technical Support

