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Introduction

Welcome to Boris Red 3GL. For information about Boris Red and other Boris products, or 
to register your copy of Boris Red, visit our web site at www.borisfx.com.

The Installation Guide contains instructions for installing and launching Boris Red inside 
each of the supported host non-linear editing applications. Look for your host and 
operating system, then follow the instructions in that section.

For information on supported operating systems and host applications, minimum system 
memory requirements, new features, and known limitations, see the Release Notes located 
on the Boris Red CD.

Technical Support
For technical support, visit the Boris Technical Forum at www.borisfx.com/support, or e-
mail support@artelsoft.com. You can also call (617) 451-9900, 9:00 am to 5:00 pm EST. 

Registration
Make sure to register your product in order to receive the latest technical and upgrade 
information.

You can register either by Þlling out the registration form online at http://borisfx.com/
support/register.html or by sending us your completed registration card.

We offer registered users one year of free technical support starting from the date of 
purchase. In addition, registered users have access to some free upgrades, and preset effects 
designed speciÞcally for Boris Red. 

You must register Boris Red 3GL to be eligible to download the BCC DeGrain, 
BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur Þlters.  
See �Important Note on Missing Filters� on page 4 for more information.
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Supported Hosts

Boris Red 3GL supports the following host applications. For updated information on 
supported versions for each host, please visit our website at http://www.borisfx.com.

Supported Operating Systems

Boris Red 3GL supports the following operating systems.

Supported Macintosh Operating Systems
Mac OS X v10.2.6 and above (see note below).

To take advantage of the new OpenGL features in Red 3GL, you must have 
Macintosh OS 10.2.6 or later installed.

Macintosh OS Classic 9.x is not supported in Red 3GL

Supported Windows Operating Systems
Windows 2K®, Windows XP®

Macintosh Windows
Adobe® Premiere® 6.0, 6.5 Adobe® After Effects® 6.0
Apple® Final Cut Pro® 3.0, 4.0 Adobe® Premiere® 6.0, 6.5, Adobe Premiere 

Pro® 1.0
Avid® Media Composer®, Avid 
Symphony® 4.7, 4.8, Avid 
XpressMac®, Avid Xpress DV® 3.0, 
3.5.4, Avid Xpress Pro®

Avid® Media Composer®, Avid 
Symphony®, Avid Xpress®, Avid Xpress 
DV® 3.0, 3.5.4, Avid Xpress Pro®

Media 100® Media 100 i® 8.1 and 
later

DPS® Velocity® 8.2

IMC® Incite® 3.0
In:Sync® Blade® 2.2, In:Sync Speed~Razor® 
5.5
Media 100® iFinish 4.6 
Pinnacle purple®, Pinnacle silver® 4.01, 
Pinnacle Edition® 5.0
Sony® Vegas® 4.0
Installation Guide        3



           
Minimum System Requirements
We recommends at least 512MB of memory assigned to the host application for both 
Macintosh and Windows users using Red 3GL:

To run Boris Red 3GL, QuickTime version 6.0 or later must be installed on your system. An 
installer for QuickTime for Windows version 6.0 is included on the Boris Red. Boris Red 
3GL supports dual processors, Hyper Threading, and Altivec acceleration.

Important Note on Missing Filters

Several BCC Þlters are not included on the Boris Red 3GL installation CD. Instead, the BCC 
DeGrain, BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur Þlters 
will be available as a free download to registered users. These Þlters will be available on the 
Downloads page at www.borisfx.com.

You must register Boris Red 3GL to be eligible to download the BCC DeGrain, 
BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur Þlters.  
See �Registration� on page 2 for details.

KeyFrame Library

The KeyFrame Library is a collection of preset Boris Red settings, allowing you to quickly 
create complicated effects. The Boris Library Browser allows you to quickly preview and 
apply settings Þles from the KeyFrame Library, including settings Þles that you add or 
customize. You can add, remove, or change these settings Þles at any time. 

The Library Browser is a great way to teach yourself how to use Boris. To easily 
adjust a settings Þle from the KeyFrame Library, turn on Smart View in the 
timeline. Smart View allows you to quickly display only the parameter tracks that 
were adjusted in your effect. 

The KeyFrame Library is installed in the following directory on Windows hosts:
(User�s Install Directory)\Boris FX, Inc.\Keyframe Libraries\Red 3.0 KeyFrame Library

The KeyFrame Library is installed in the following directory on Macintosh hosts:
Library/Application Support/BorisFX/Red 3.0 KeyFrame Library
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The Þrst time you browse the KeyFrame Library within the Boris Library Browser 
you must generate thumbnail images for the effects. To do this, select an effect or 
effect folder in the Browser, and click the Generate Thumbnails button. For more 
information on using the KeyFrame Library, see Chapter 4, �Creating Effects,� in 
Volume I of your Red User Guide.

We recommend that you build the thumbnail previews for the KeyFrame Library 
in the Red KeyFramer or Engine rather than within your host application. Because 
building previews actually renders your effect, this process can take as much as 
25-30% longer in the plug-in than in the Red KeyFramer or Engine.

KeyFramer and Red Engine

The Boris Red KeyFramer is a standalone application designed to create Boris effects ofßine 
using any computer. The KeyFramer is a cross-platform application which can be 
duplicated and distributed free of charge. The KeyFramer lets you save settings Þles; actual 
effect rendering requires a host application with the Boris plug-in installed. 

The KeyFramer features the same user interface as the plug-in used within your host 
application. The default video images are proxy images. You can also import still images, 
EPS or movie Þles, or create color, gradient, spline, natural or text media in the KeyFramer. 

Due to space limitations, the Boris KeyFramer has not been included on the Boris 
Red CD. You can download the KeyFramer from the Boris web site.

You can also install and use the standalone Red Engine instead of working within a host 
application. The Red Engine uses the same interface as the plug-in and the KeyFramer. The 
Red Engine lets you export Þles as QuickTime, AVI or Flash from the Render Queue in the 
Project window. You can only use the Red Engine on systems where you have performed a 
full install of Red.

The Red Engine is installed by default to:

Macintosh: 

Drive/Desktop/Boris Red 3GL/Boris Red Engine 3.0

Windows: 

c:\Program Files\Boris FX, Inc.\Boris Red 3GL\Boris Red Engine 3.0
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Installing on Macintosh OS™ Hosts

The following information explains how to install Red 3GL into hosts running on the 
Macintosh operating system.

Logging into Macintosh OS X Systems

If your system is set up to support multiple users, you must log on as an Administrator to 
install Boris under Macintosh OS X.

Removing Older Versions
Remove any previous installations of Boris Red before installing Boris Red 3GL

1. Delete the older Boris Red plug-in from the host application�s plug-in folder.

2. Delete the Boris Red Preferences Þle(s), from the System Folder�s Preferences folder.

NOTE: Render all effects created with previous versions of Boris Red before 
installing Red 3GL. Once you install Boris Red 3GL and delete earlier versions of 
the plug-in, unrendered effects made with earlier versions of Red can cause 
problems in certain circumstances.

If you customized or added settings Þles to an older KeyFrame Library, back up these 
custom Þles in a separate location and then delete the older KeyFrame Library. The new 
Red 3GL KeyFrame Library replaces the older KeyFrame Library and adds additional 
settings that showcase the new features. Once you install Red 3GL, open the saved settings 
Þles in Red 3GL, and resave them with preview images in the Boris Red 3GL KeyFrame 
Library by choosing File > Save Project Copy to Library. You can then preview the settings 
Þles in the Boris Red 3GL Library Browser. You should Þnish projects with effects created 
in previous versions of Boris Red before installing the newer version.
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Support for Automatic Duck Composition Import
Red supports Automatic Duck composition import. This allows you to import your 
timeline from an After Effects, Avid or Final Cut Pro host system into the Red Engine. 
Automatic Duck's Automatic Composition Import plugin imports Avid® OMF® 
Compositions, including all your media and clips. Supported effects are translated and 
your timeline is recreated as a composition in Boris Red. In addition, your media and 
composition are added to the Project window.

When you install Red 3GL, Automatic Duck LT is automatically installed. This is a 30-day, 
fully-functioning demo.

For more information, see your Automatic Duck documentation or visit 
www.automaticduck.com. For information on using Automatic Duck, see 
Appendix B, �Working with Hosts,� in Volume I of the Red User Guide.

Installing into Adobe® Premiere® 

1. Launch the Boris Red Installer application from the Red CD. 

2. If you are running on a system that supports multiple users, enter your Name and 
password. Click OK.

3. Enter your name, organization, and product serial number found in the front cover of 
your User Guide or on the registration card. Click OK.

4. When the Boris splashscreen appears, click Continue.

5. Select one or more of the following options from the menu. Selecting all three choices 
is recommended:

• Boris Red Engine: Installs the standalone Red Engine.
• Boris Red for Premiere: Installs the appropriate Boris Red plug-in(s) for Premiere.
• Boris Red Components: Allows you to choose individual components to install. 

The components include the Red User Guide, the KeyFrame Library, the Red 
Styles and the BCC Plugins for Red.

6. Click Install.

The Boris Red plug-in Þle(s), Red Styles and the KeyFrame Library are installed to their 
correct locations on your hard drive. Depending on whether you chose to install these 
additional components, it also installs a Boris Red folder to your hard drive, which 
contains the necessary documentation and the Red Engine application.

7. If you have multiple versions of Premiere installed, specify the version of Premiere 
where you want to install the plug-in. Click OK.

Once the installation is complete, the Intelligent Assistant installer appears.
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8. Follow the onscreen directions to install the Intelligent Assistant. The Intelligent 
Assistant is a sophisticated online help system that is fully integrated into Boris Red 
3GL. It is directly accessible from the Help menu. 

9. When the Intelligent Assistant is installed, click Quit. Launch Premiere to ensure that 
installation of Boris Red was successful. Boris Red appears in your Transitions palette 
and under Filters.

10. If you have an previous Boris Red version installed for Premiere, both versions appear 
in your Transition window and Filter dialog. To remove the earlier version, locate the 
�Adobe Premiere Plug-Ins� folder and remove the older Plug-in Þles.

11. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Transition

1. Place the clips you want to use in the transition on the Video 1a and Video 1b tracks, 
overlapping them enough to create a transition of the desired length.

2. In the Transitions palette, locate the Boris icon. Drag the icon onto the Transitions track 
between the clips on Video 1a and Video 1b.

3. Double-click the Transition icon in the timeline to enter the Red interface. You can now 
open a settings Þle from the KeyFrame library, or create your own effect.

4. To exit the Red interface, click either Cancel to close Red without saving changes to the 
effect or Apply to close Red and apply changes to the effect.

5. Render Red effects the same way you would render any other effect. For more 
information, consult your Premiere or Premiere Pro documentation.

Applying Boris Red as a Filter

1. Select a clip in the timeline.

2. In the Transitions window, click the Video Tab. 

3. In the 3rd Party Folder, choose the Boris Red Filter. The Boris Red interface opens.

You can now open a settings Þle from the KeyFrame library, or create your own effect.

4. To exit Red, click Cancel to close without saving changes or Apply to close and apply 
changes. Render Red effects the same way you would render any other effect. 

To preview the Boris Red effect when you return to the Premiere timeline, press 
the Command key and drag the time indicator along the track.
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Applying Boris Red as a Composition Clip

1. Choose New from the File menu. 

2. Choose Boris Red Composition. The Boris Red interface opens.

3. You can now create a Boris Red effect and use it as a source in your timeline for 
transitions and Þlters. The new comp clip is put into the Project window and can be 
dragged into the Premiere timeline as a clip.

4. To exit the Red interface, click either Cancel to close Red without saving changes to the 
effect or Apply to close Red and apply changes to the effect. Render Red effects the 
same way you would render any other effect. 

Tips for Using Boris Red with Adobe Premiere and Premiere Pro

•   When using a Red effect that creates an alpha channel (such as a title, a shape that does 
not Þll the screen, or a particle effect), the alpha channel appears black (rather than 
transparent) in the preview until you Control-click the effect in the timeline, choose 
Video Options > Transparency and in the Key Type menu, choose Alpha.

•   Premiere is limited to two source track inputs. To use additional images and Þles, add 
the images directly within Red. Enter the Red interface and add unlimited tracks in the 
Red timeline, importing movie and still image Þles, creating color, natural and 
gradient tracks and layering spline and text tracks over your effect.

•   To display the Premiere sequence�s timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. You can open the 
Preferences window by choosing Boris Red > Preferences (Macintosh) or Edit > 
Preferences (Windows). 

Installing into Apple® Final Cut Pro®

1. Launch the Boris Red Installer application from the Red CD. 

2. If you are running on a system that supports multiple users, enter your Name and 
password. Click OK.

3. Enter your name, organization, and product serial number found in the front cover of 
your User Guide or on the registration card. Click OK.

4. When the Boris splashscreen appears, click Continue.

5. Select one or more of the following options from the menu. Selecting all three choices 
is recommended:

• Boris Red Engine: Installs the standalone Red Engine.
• Boris Red for Final Cut Pro: Installs the appropriate Boris Red plug-in(s) for Final 

Cut Pro.
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• Boris Red Components: Allows you to choose individual components to install. 
The components include the Red User Guide, the KeyFrame Library, the Red 
Styles and the BCC Plugins for Red.

6. Click Install.

The installer automatically installs the Boris Red plug-in Þle(s), Red Styles and the 
KeyFrame Library to their correct locations on your hard drive. Depending on whether 
you chose to install these additional components, it also installs a Boris Red folder to 
your hard drive, which contains the necessary documentation and the Red Engine 
application.

7. If you have multiple versions of Final Cut Pro installed, specify the version of Final Cut 
Pro where you want to install the plug-in. Click OK.

8. Follow the onscreen directions to install the Intelligent Assistant. The Intelligent 
Assistant is a sophisticated online help system fully integrated into Boris Red 3GL. It 
is directly accessible from the Help menu and offers the equivalent of over 600 pages 
of text. 

9. When the Intelligent Assistant is installed, click Quit. Launch Final Cut Pro to ensure 
that installation of Boris Red was successful. Boris Red appears in the Filters tab in the 
Viewer window and in the Video Transitions submenu in the Effects menu.

10. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Filter in Final Cut Pro

1. Select the clip to which you want to apply an effect and choose Effects > Video Filters 
> Boris > Boris Red.

2. Use one of the following procedures to add the effect:

• In the Viewer window, click the Filters tab. 
• In the Effect tab in the Browser, drag the Red effect icon to the clip in the timeline. 

The Red interface opens automatically. You can now create or load an effect. Seven 
numbered Video controls in the Filter tab allow you to use multiple video layers inside 
Red. Drag video clips into the Video controls to make them accessible inside Red.

3. To exit the Red interface, click Cancel to exit without applying changes or Apply to exit 
and apply changes. Render a Red effect the way you would any other effect in FCP. 

4. To re-enter the Boris Red interface at any time, click Options in the Filter tab.
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Applying Boris Red as a Generator 

Red 3GL also includes a Static Generator for Final Cut Pro. The Static Generator 
allows you to create a static slate which takes advantage of Final Cut Pro�s Real- 
Time capabilities. When you apply the Static Generator, the Red timeline opens 
with a duration of one frame which can then be applied to Final Cut Pro as a static 
slate.

1. Select the clip to which you want to apply an effect.

2. Choose Red from the Generator menu or in the Effect tab in the Browser, drag the Red 
effect icon to the clip in the timeline. 

3. Click the Red banner in the Controls tab in the Viewer. This opens the Red interface.

4. To exit the Red interface, click Cancel to exit without applying changes or Apply to exit 
and apply changes. Render a Red effect the way you would any other effect in FCP.

Applying Boris Red as a Transition in Final Cut Pro (Version 4.0 Only)

Beginning with Version 4.0, Final Cut Pro allows you to apply plug-ins as transitions. 
However, color space issues can occur when applying plug-ins as a transition. FCP 4.0 does 
not support YUV color space for plug-ins. So Red transitions render in RGB. This may cause 
visible color shifts when you create transitions in a YUV project. To correct this problem, see 
�Rendering Final Cut Pro Effects in RGB� on page 11. When you apply Red as a Þlter, color 
shifts are not an issue.

If you are working with an older version of Final Cut Pro, see �Applying Boris Red as a 
Transition in Older Versions of Final Cut Pro� on page 12.

1. Click to select an edit point between two clips in your sequence. Alternatively, you can 
position the Canvas or Timeline playhead at the desired edit point.

2. Choose Video Transitions from the Effects menu, then choose Boris > Boris Red 
Transition from the submenu. 

3. Click the Red banner in the Controls tab in the Viewer. This opens the Red interface.

4. To exit the Red interface, click Cancel to exit without applying changes or Apply to exit 
and apply changes. Render a Red effect the way you would any other effect in FCP.

Rendering Final Cut Pro Effects in RGB

1. Choose Settings from the Sequence menu.

2. In the Sequence Settings window, click the Video Processing tab.

3. Click to enable the Always Render in RGB checkbox. 

4. Click OK to save your changes.
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Applying Boris Red as a Transition in Older Versions of Final Cut Pro

If you are using an older version of Final Cut Pro, the plug-in architecture does not allows 
you to use plug-in Þlters as transitions. However, you can use the following procedure to 
use Boris Red to build transition effects between clips.

1. Place the outgoing shot on V1 and the incoming shot on V2. Overlap the clips for the 
duration that you want your transition.

2. Set your Canvas window to 100%. The Canvas window must be set to full size so that 
the clips come into Boris Red at the right size.

3. Use one of the following procedures to apply a Þlter to the overlap segment on V1:

• In the Viewer window, click the Filters tab. 
• In the Effect tab in the Browser, drag the Boris Red effect icon to the clip in the 

timeline. 

The Red interface opens automatically. You can now create or load an effect. Red refers 
to the clip that you are Þltering as V1. The remaining tracks in the Media menu refer to 
V2 through V7 in the wells in the Red Filter tab in the Viewer window. 

4. To exit the Boris Red interface, click Cancel to exit without applying changes or Apply 
to exit Boris Red and apply changes. 

5. Take the portion of V2 that was to the left of your cut, and drag it into the V2 well. By 
placing the V2 clip in the V2 well, it will appear in V2 when the transition renders. If 
you create a track in a Boris Red transition, but don't actually put anything on that track 
in the well, Boris Red renders black for that layer. If you want, you can delete the 
overlap section of V2 from the timeline and move the rest of the clip to V1.

6. Render a Boris Red effect the way you would any other effect in Final Cut Pro.

Tips for Using Boris Red with Apple Final Cut Pro

•   Due to a problem in the Macintosh OS, Final Cut Pro version 4.0 does not support 
Red�s OpenGL feature.When you launch Final Cut Pro version 4.0, OpenGL is 
automatically disabled. If you attempt to enable OpenGL in the Red Preferences, you 
will crash when you apply back to Final Cut. We expect this problem to be Þxed in 
Macintosh OS 10.3, after which you can enable OpenGL in Red�s Preferences window.

•   Before applying Red as a Þlter, you may want to engage the Caps Lock key. This 
prevents the Red interface from launching, and allows access to the wells without 
having to enter and exit Red. Once the desired clips or subclips are added to the wells, 
disengaging the Caps Lock key automatically launches Red.

•   Red refers to the clip that you are Þltering as V1. The rest of the tracks in the Media 
menu refer to V2 through V7 in the wells inside the Red Filter tab in the Viewer 
window. They do not refer to FCP timeline tracks. Clips or trimmed subclips from the 
timeline or the Browser can be added to the wells by dragging and dropping.
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•   In certain instances, it may be more useful to apply Red to a slug. The default length 
for slugs is two minutes, but you can adjust the length. This creates titles that are 
discrete elements; they can be moved on the timeline or have their length changed 
without moving any video tracks. Rendering is also faster.

•   Red can be used on systems with the RTMac board to create static titles. You can 
animate the titles in real time using the parameters on the Generator�s Motion tab. 
With the RTMac board installed, titles created with Red play in real time as long as no 
keyframes were added in the Generator�s Controls tab. 

•   Set your Canvas window to 100%. The Canvas window must be set to full size so that 
the clips come into Boris Red at the right size.

•   If your effect is composited over a background, applying Boris Red as a generator will 
render faster since you don�t have to render the background video.

•   Video for your effect needs to be currently displayed in the Canvas or Viewer to launch 
the Boris Red interface.

•   To use a trimmed source clip in one of the Final Cut Pro Filter tab input wells, mark in 
and out on a clip in the FCP timeline and choose Modify > Make Subclip. Select the 
new subclip in the Project Browser and drag it into one of the input wells in the Filter 
tab.

•   You can also use Automatic Duck to import your entire timeline into Boris Red. See 
�Support for Automatic Duck Composition Import� on page 584 in Volume I of the 
Red User Guide for details.

•   To display the Final Cut Pro timeline�s timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. You can open the 
Preferences window by choosing Boris Red > Preferences. 

Installing into Avid Systems
The following instructions are for Avid® systems, including Media Composer®, 
Symphony®, Xpress Mac®, XpressDV®, and Xpress Pro®.

1. Launch the Boris Red Installer application from the Red CD. 

2. If you are running on a system that supports multiple users, enter your Name and 
password. Click OK.

3. Enter your name, organization, and product serial number found in the front cover of 
your User Guide or on the registration card. Click OK.

4. When the Boris splashscreen appears, click Continue.

5. Select one or more of the following options from the menu. Selecting the Red Engine, 
the appropriate Avid version, and all of the Components is recommended:

• Boris Red Engine: Installs the standalone Red Engine.
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• Boris Red for Avid Products (New Versions): Installs the appropriate Boris Red 
plug-in for the following (and later) versions of Avid Xpress 5.8, Media Composer 
11.8, Symphony 4.8, Film Composer 11.8 and Media Composer Adrenaline 1.0. 

• Boris Red for Avid Products (Old Versions): Installs the appropriate Boris Red 
plug-in for Avid versions earlier than those in the above install choice. 

• Boris Red Components: Allows you to choose individual components to install. 
The components are the Red User Guides, the KeyFrame Library, the Red Styles 
and the BCC Plugins for Red.

6. Click Install.

The installer automatically installs the Boris Red plug-in Þle(s), Red Styles and the 
KeyFrame Library to their correct locations on your hard drive. Depending on whether 
you chose to install these additional components, it also installs a Boris Red folder to 
your hard drive, which contains the necessary documentation and the Red Engine 
application.

7. If you have multiple versions of Avid installed, specify the version of Avid where you 
want to install the plug-in. Click OK.

Once the installation is complete, a window displays the Intelligent Assistant installer.

8. Follow the onscreen directions to install the Intelligent Assistant. The Intelligent 
Assistant is a sophisticated online help system fully integrated into Boris Red 3GL. It 
is directly accessible from the Help menu and offers the equivalent of over 600 pages 
of text, with far more illustrations than you'll Þnd in other help systems. 

9. Once the Intelligent Assistant is installed, click Quit. Launch Avid to ensure that 
installation of Boris Red was successful. Boris Red appears as a category in the Effect 
Palette.

NOTE: If you currently have an earlier version of Boris Red installed for Media 
Composer or Xpress, the Boris Red installer will not replace the older Boris AVX 
plug-in with the new version You should manually remove the earlier version.

10. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.
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Applying Boris Red as a Filter or Transition

1. Open the Effects Palette from the Tools 
menu. Boris Red appears as an effect 
category on the left. Click to select the 
Boris Red category.

Several different types of Boris effects 
appear: Boris Red 1-Input, 2-Input, 4-
Input and 6-Input, Boris Red Title-Matte 
and Boris Red Transition. 

The instructions for applying effects are the same whether you apply a Boris Red, 
Boris GRAFFITI or Boris FX effect. 

2. Choose the appropriate effect on the right side of the Effects Palette:

• To apply Boris Red as a transition between two clips, choose Boris Red Transition 
effect. 

• Choose the effect that corresponds to the number of video tracks from the Avid 
timeline that you want to use in Boris Red. For example, if you want to Þlter a 
single track from the Avid timeline, use the Boris Red 1-Input effect. If you want 
to apply multiple tracks of titles to a single track from the Avid timeline, you 
would also choose the Boris Red 1-Input effect.

• To apply Red to an Avid title or matte key, choose Boris Red Title-Matte Effect. See 
the next section for details.

3. Drag the icon for the desired effect into a clip or into a transition between two clips.

4. Enter Effects Mode. 

5. If you are using a Boris Transition effect, type a duration in the Duration Þeld in the 
Effect Editor. If you are using any other Red effect, the duration is determined by the 
duration of the clip to which you apply the effect.

6. In the Effect Editor, click the Other Options button.

The Red interface appears, containing one track 
for each input in the effect. You can add as many 
new tracks as you want, though you are limited to 
the number of inputs for the type of effect you are 
using. For example, if you use a Boris Red 4-input 
effect, you are limited to four tracks from the Avid 
timeline. However, you can create as many Boris 
Red tracks as you want. You can now open a 
settings Þle from the KeyFrame Library, or create 
your own custom effect.

Other Options button
Installation Guide        15



7. To exit the Boris Red interface, click either Cancel to close Red without saving changes 
to the effect or Apply to close Red and apply changes to the effect.

8. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your Avid documentation.

NOTE for AVX 1.0 users: Avid versions that support AVX 1.0 preview only a single 
frame of video in Red. The preview frame is taken from the current position of 
Avid�s time indicator. In AVX 1.0, to preview your effect with the updating source 
media, exit the Red interface and preview the effect in the Avid timeline. Versions 
of Avid supporting AVX 1.5 can view all the Avid video frames within Red.

Applying Boris Red as a Title-Matte Effect

You can apply Boris Red directly to titles created in the Avid timeline. For example, if you 
have a bin with saved titles, you could apply a Þlter to the titles in Red.

1. Edit an Avid title or matte key into the Avid timeline.

2. Open the Avid Effect Palette and select Boris Red from the Effect categories.

3. From the list of available Red effects, drag the Boris Red Title-Matte Effect to the title 
or matte key in the Avid timeline.

Dragging the Title-Matte effect onto an Avid title or matte key is a destructive 
process which replaces the title or matte key. Additionally, removing a Title-Matte 
effect removes the title�s nested alpha channel. To remove a Title-Matte effect and 
preserve the title or matte key, use the Undo command instead of the Remove 
Effect command.

4. Click the Other Options button in the Avid Effect Editor to launch the Red Interface and 
create your effect.

If the title or matte key looks blocky when Red opens, select its Face track in the 
timeline. In the Host Media tab, choose Straight Alpha from the Key menu. This 
usually happens automatically.

Replacing a Title-Matte Effect

Since a title is replaced by applying the Title-Matte effect, i to re-edit a title with a Title-
Matte Effect (for example to change the text or a font) you must save the Title-Matte effect 
while you are in Red (in the File menu). Recreate the Avid title and overwrite the older title 
in the Avid timeline. Drag a Red Title-Matte Effect to the new title. In Red, open the saved 
effect and apply it to the new title.
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Tips for Using Boris Red with Avid Systems

•   For the best results with layered effects, only apply the Boris Red Input effect which 
uses the number of tracks you need from the Avid timeline. When applying an effect 
with too many inputs, the extra tracks add overhead to the AVX interface, which slows 
rendering considerably. For example, to use two tracks from the Avid timeline and add 
two tracks of titles, use the Boris Red 2-Input effect not the Boris Red 4-Input effect.

•   Boris Red is limited to six tracks from the Avid timeline. However, you can import 
QuickTime reference Þles as Movie media which allows you to use an unlimited 
number of tracks from your Avid timeline. You need to export the QuickTime reference 
Þles, identify their names and navigate to them in the Movie dialog. For information, 
see your Avid documentation.

•   You can use Automatic Duck to import your entire Avid timeline into Boris Red. See 
�Support for Automatic Duck Composition Import� on page 584 in Volume I of the 
Red User Guide for details.

•   When you have multiple unrendered Boris Red effects in your timeline, you should 
turn off the Avid Render on the Fly option to avoid slowing down your playback.

•   Red reads tracks from the top down. Avid reads tracks from the bottom up. For 
example, you want to create an effect in Boris Red using six tracks from your Avid 
timeline. Add the Boris Red 6-Input effect to the top track in your timeline. However, 
when you open Boris Red, the V6 track from your Avid is the V1 track in Boris Red. To 
keep from getting confused, you may want to rename your tracks in Boris Red.

•   The Avid Title Tool allows you to create many titles in real time. However, the titling 
capabilities in Boris Red are more extensive. One way to optimize your rendering 
times is to create your title in Red then instead of applying the effect, export to 
QuickTime, without the underlying video. Import the QuickTime into the Avid using 
the Avid Codec which includes support for Alpha. If your system supports real-time 
matte keys, the imported title plays in real time. 

•   To optimize the rendering of static titles, create your title in Red. Instead of applying 
the effect, export as a PICT or Targa Þle, without the underlying video. Then import 
the PICT or Targa into the Avid.

•   Unlike some Avid systems, all Boris applications support larger -than-project Þle sizes. 
You can easily import large images for pan-and-zoom documentary-style animations. 
Apply Red to any clip of the proper length. Once Red is open, press the Media icon to 
assign the large Still Image Þle to the track. Animate the scale and position as desired. 
The PICT format limits images to 4000 pixels, which may not be large enough. When 
saving your images, use the TIFF format instead. Images display at 72 dpi in Red 
(standard video resolution), so it makes sense to create images at this size in your still 
image application. This also reduces render times by not processing pixels that video 
can't display. Render times are longer than video renders as sizes increase beyond 
video scale: an image of 4000 x 4000 pixels at 72 dpi is roughly 45 times the size of a 
video frame. Assign as much RAM as possible to your Avid before rendering large 
Þles.
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•   Avid systems do not provide support for Adobe After Effects Þlters. However, many 
Adobe After Effects Þlters plug into Boris Red. After Effects Þlters appear in the Red 
Þlter list in the same way native and BCC Þlters do. This allows you to use Red as a 
gasket to apply third-party After Effects Þlters to clips in your Avid timeline. Apply 
and use Adobe After Effects Þlters the same way you would use native Red Þlters. For 
more information on Þlters, see Volume II of the Red User Guide.

•   If you apply a multi-input effect to the Avid timeline with fewer tracks than the 
number of inputs selected for your effect, the monitor displays an unsupported 
resolution error For example, you want to use three video tracks in the Avid timeline 
in a Red effect. Red provides 1,2,4, and 6 input effects. If you apply a Red 4-input effect, 
design the effect, and click Apply; the Avid Record window displays the error. To Þx 
this problem, create a blank fourth video track in the Avid timeline (even if it is not 
referenced by your effect). Then your video displays in the Avid Record window. 
Alternatively, you could apply a Red 2-input effect and import the third track into Red 
as a movie using a QuickTime reference Þle.

•   To display the Avid sequence�s timecode in Red, set the View Time menu in the General 
tab in the Preferences window to Program Timecode. You can open the Preferences 
window by choosing Boris Red > Preferences (Macintosh) or Edit > Preferences 
(Windows). 

Note for AVX 1.0 Users: Avid hosts that use AVX 1.0 preview only a single frame of 
video in Boris Red. The preview frame is taken from the current position of Avid�s 
timeline indicator. To preview your effect with updating source media, exit Boris 
Red and preview the effect in the Avid timeline. This is a limitation of the AVX 1.0 
architecture which does not impact rendering of your effect.This problem does not 
occur on systems using AVX 1.5.

Installing into Media 100 i®

1. Launch the Boris Red Installer application from the Boris Red CD. Click Continue.

2. If you are running on a system that supports multiple users, enter your Name and 
password. Click OK.

3. Enter your name, organization, and product serial number found in the front cover of 
your User Guide or on the registration card. Click OK.

4. When the Boris splashscreen appears, click Continue.

5. Select one or more of the following options from the menu. Selecting all three choices 
is recommended:

• Boris Red Engine: Installs the standalone Red Engine.
• Boris Red for Media 100: Installs the appropriate Boris Red plug-in(s) for Media 

100 i.
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• Boris Red Components: Allows you to choose individual components to install. 
The components include the Red User Guides, the KeyFrame Library, the Red 
Styles and the BCC Plugins for Red.

6. Click Install.

The installer automatically installs the Boris Red plug-in Þle(s), Red Styles and the 
KeyFrame Library to their correct locations on your hard drive. Depending on whether 
you chose to install these additional components, it also installs a Boris Red folder to 
your hard drive, which contains the necessary documentation and the Red Engine 
application.

7. If you have multiple versions of Media 100 i installed, specify the version of
Media 100 i where you want to install the plug-in. Click OK.

Once the installation is complete, a window displays the Intelligent Assistant installer.

8. Follow the onscreen directions to install the Intelligent Assistant. The Intelligent 
Assistant is a sophisticated online help system fully integrated into Boris Red 3GL. It 
is directly accessible from the Help menu and offers the equivalent of over 600 pages 
of text, with far more illustrations than you'll Þnd in other help systems.

9. When the Intelligent Assistant is installed, click Quit. Launch Media 100 i to ensure that 
installation of Boris Red was successful. Boris Red appears as a DVE transitions 
category.

NOTE: If you have an earlier Boris Red version installed for Media 100 i, both 
versions appear in your Transition menu. To remove the earlier version, locate the 
Media 100 i �DVE� folder and remove the older Boris Red plug-in.

10. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red in Media 100 i

You can apply Boris Red in Media 100 i as either a transition, Þlter, or Comp Clip.

You can access the Media 100 i Bin browser from within Boris Red by pressing the 
Media icon in the timeline track and choosing Bin Browser from the menu

Applying Boris as a Transition

1. Place the clips you want to use in the transition on the Video A and Video B tracks, 
overlapping them enough to create a transition of the desired length.
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2. Double-click the Transition Arrow (in the FX track between the A and B track.) This 
puts the Edit Suite into Transition mode, where you can set the duration of the 
transition by dragging the red and green trim handles or by typing the total length in 
the Length box. You can also click the appropriate icon to choose a �Start on Cut,� �End 
on Cut,� �Centered on Cut,� or �Custom� transition. 

3. To choose a Red effect, use the buttons in the upper right corner of the Edit Suite. Click 
the third button to display a pop-up menu of DVEs. Choose Boris Red from the menu.

4. To enter the Boris Red interface, click the Custom Settings button. You can now either 
open settings from the KeyFrame library or create your own custom effect.

5. To exit the Boris Red interface, click either Cancel to close Boris Red without saving 
changes to the effect or Apply to close Boris Red and apply changes to the effect.

6. Click Apply in the Edit Suite to apply the changes you made in Boris Red.

7. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

Applying Boris Red as a Filter or Comp Clip

1. Select either a Bin window or Timeline window and choose New Composition from 
the Tools menu. A Comp Clip is created on Video Track A or in a bin. 

2. Double-click the Comp Clip to put Edit Suite into Edit Clip mode.

3. To enter the Boris Red interface, click the Edit button. You can now open settings from 
the Keyframe Library or create your own custom effect.

4. To exit the Boris Red interface, click Cancel to close Boris Red without saving changes 
to the effect, or Apply to close Boris Red and apply changes to the effect.

5. Click Apply in the Edit Suite to apply the changes you made in Boris Red.

6. Click Render in the Edit Suite to render the Comp Clip you just created.

Applying Boris Red as a Title

1. Select the Program window or a bin. In the Tools menu, choose New Title.

2. Double-click Title and choose Edit in the Edit Suite.

3. To enter the Boris Red interface, click the Edit button. 

You can now open settings from the Keyframe Library or create your own custom 
effect.

4. To exit the Boris Red interface, click Cancel to close Boris Red without saving changes 
to the effect, or Apply to close Boris Red and apply changes to the effect.

5. Click Apply in the Edit Suite to apply the changes you made in Boris Red.
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6. Click Render in the Edit Suite to render the Comp Clip you just created.

NOTE: Static Titles play in real time and do not need to be rendered.

Exporting a Media 100 Timeline to Boris Red

1. You can export your Media 100 timelines directly to the Red Engine. 

2. Copy the Media100ProjectImporter Þle into your �BorisPlugins� folder. 

This Þle should be located on your Media 100 install CD, in the Media 100 After Effects 
Plug-in folder.

3. Choose Export to....After Effects from the Media 100 File menu. 

The Þle that you export from Media 100 has a �.M1A� extension. 

4. Launch the Red Engine and choose File > Import. Navigate to the Þle that you 
exported. 

5. The Red timeline changes to the M1A Þle. 

Tips for using Boris Red with Media 100 and 100i 

•   When you create a Red effect in the Media 100 timeline, the interface opens with the 
settings of the last Red effect you created so that you can easily create a similar effect. 
To create an entirely new effect, choose File > New Project.

•   Titles created with the Constant interpolation play in real time on Media 100 systems 
that support real-time static titles. To animate, change the Default interpolation from 
Constant in the Preferences window.

•   You can open clips from the Bin Browser directly in Red. Press the Media icon on a 
track and choose Bin Browser from the menu that appears. A ßoating window opens 
with all the clips in your Bin Browser. Choose the appropriate clip from the window. 
In the Red timeline, the clip displays the icon for Movie media.

•   Red lets you import large images for �pan-and-zoom� documentary-style animations. 
Apply Boris Red to any clip of the appropriate duration. Once Red is open, press the 
Media icon to assign the Still Image File. Animate the scale and position as desired.

The PICT format limits images to 4000 pixels, which may not be large enough. When 
saving your images, use the TIFF format instead. Images display at 72 dpi in Red 
(standard video resolution), so it makes sense to create images at this size. This reduces 
render times by not processing pixels that video can't display. Render times are longer 
than video renders as sizes increase beyond typical video scale: a 4000 x 4000 pixel 
image at 72 dpi is roughly 45 times the size of a video frame.Assign as much RAM as 
possible to Media 100 before rendering large Þles.
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•   The current version of Media 100 changes the clip name when digitizing at new 
resolutions, which can cause Boris Red to lose track of the Þle. The easiest way to avoid 
lost media is to use clips at their Þnal resolution inside Boris Red. Otherwise, open 
Boris Red and manually reassign the media with its new name after you redigitize.

•   To use Þles with alpha channels inside Red, don't place them on the Media 100 
timeline. Media 100 doesn't pass alpha channel information to Red. Apply Red either 
using a solid black clip as a placeholder, or a copy of your clip with alpha. Once inside 
Red, assign the Source media to a Movie Þle or Still Image File, and turn off the 
placeholder track in Media 100. The alpha channel now renders properly.

•   To display the Media 100 sequence timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. 

Installing for Microsoft® Windows® Hosts

The following information explains how to install Red 3GL into Windows hosts.

Removing Older Versions
Remove any previous installations of Boris Red via the Add/Remove Programs Control 
Panel before installing Boris Red 3GL. 

NOTE: Render all effects created with previous versions of Boris Red before you 
install Red 3GL. Once you install Boris Red 3GL and delete earlier versions of the 
plug-in, unrendered effects made with earlier versions of Red could cause 
problems in some instances.

If you have customized or added settings Þles to an older KeyFrame Library, back up these 
custom Þles in a separate location and then delete the older KeyFrame Library. The new 
Red 3GL KeyFrame Library replaces the existing library and adds additional settings. Once 
you install Red 3GL, open the saved settings Þles in Red 3GL, and resave them with 
preview images into the Boris Red 3GL KeyFrame Library by choosing File > Save Project 
Copy to Library. You can then preview the settings Þles in the Boris Red 3GL Library 
Browser. You should Þnish projects with effects created in previous versions of Boris Red 
before installing the newer version.

Logging On to Your System

To correctly install Boris Red, you must log on to your system as an Administrator.
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Support for Automatic Duck Composition Import
Red supports Automatic Duck composition import. This allows you to import your 
timeline from an After Effects, Avid or Final Cut Pro host system into the Red Engine. 
Automatic Duck's Automatic Composition Import plugin lets you import an Avid® OMF® 
Composition, including all your media and clips. Supported effects are translated and 
recreated, and your timeline is recreated as a composition in Boris Red. In addition, your 
media and composition are added to the Project window.

When you install Red 3GL, Automatic Duck LT is automatically installed. This is a 30-day, 
fully-functioning demo.

For more information, see your Automatic Duck documentation or visit 
www.automaticduck.com. For information on using Automatic Duck, see 
Appendix B, �Working with Hosts,� in Volume I of the Red User Guide.

Installing into Adobe® After Effects® 
These instructions apply to Adobe After Effects running on Windows platforms. The 
current version of Boris Red is only compatible with After Effects version 6 running on 
Windows. Support for Macintosh versions is planned for a future release.

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A �Component Selection� window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second �Component Selection� window displays the default component selections 
of Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette 
and the BCC Plugins. Users are encouraged to install all of these items. Choosing the 
BCC Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.
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8. Click Install to begin the installation. Or, if you want to change any of your installation 
settings, click Back.

9. A Setup status window updates a status bar as each of the components is installed.

10. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

11. Click Next.

12. A �Setup Complete� window offers a checkbox option to install the Intelligent 
Assistant. The Intelligent Assistant is a sophisticated online help system fully 
integrated into Boris Red 3GL. It is directly accessible from the Help menu and offers 
the equivalent of over 600 pages of text, with far more illustrations than you'll Þnd in 
other help systems. If you choose to install the Intelligent Assistant, follow the 
onscreen instructions to complete the installation.

13. Click Finish. Launch After Effects to ensure that installation of Boris Red was 
successful.

14. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red in Adobe After Effects

These instructions apply to Adobe After Effects running on Windows platforms. The 
current version of Boris Red is only compatible with After Effects version 6 running on 
Windows. Support for Macintosh versions is planned for a future release.

1. In the timeline, select the layer to which you want to apply the effect.

2. Choose Effect > Boris > Boris Red. Boris Red appears in the Effect window.

3. If you want, set the numbered Video input menus to the desired layer in the current 
composition. This enables you to use multiple video tracks within Boris Red.

4. Click Options to enter the Boris Red interface. Create or load your effect.

5. To exit the Boris Red interface, click either Cancel (to close Boris Red without saving 
changes to the effect) or Apply (to close Boris Red and apply changes to the effect).

6. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your After Effects documentation.



Tips on Using Boris Red in Adobe After Effects

•   As an NLE plugin, RED assumes host video is the project size, and in a compositor like 
AE this is often not the case. If you use non-project size media from the AE timeline in 
RED, it does not preview/display at the proper size (although it will be the correct size 
in the AE Comp Window once you've closed out of RED). 

There are a few ways to avoid this problem; one is to import the media directly into 
RED for use in the RED effect rather than bringing it in from the AE timeline; another 
is to precompose the media in the AE timeline before bringing it into RED; another is 
to use only project size media from the host timeline in RED.

•   Set the After Effects resolution to 100% before opening Red. Otherwise, image quality 
is reduced because After Effects does not provide full-sized frames. Likewise, if After 
Effects is set at less than full resolution (100%), previews at Full size appear in reduced 
quality.

•   To display the After Effects timeline�s timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. You can open the 
Preferences window by choosing Edit > Preferences. 

•   You should always apply Red to a project-sized layer in After Effects. When working 
with a different size layer, import it separately (as video or as a still image Þle).

•   Users working in 16x9 or non-broadcast square pixel (non4x3) aspect ratios must set 
the Video Aspect menu in the General tab of the Preferences window. This menu 
defaults to 4:3 Aspect Ratio, so it is usually necessary to change the preferences when 
working in 16x9 or non-broadcast square pixel (non4x3) aspect ratios.

•   You can also use Automatic Duck to import your entire timeline into Boris Red. See 
�Support for Automatic Duck Composition Import� on page 584 in Volume I of the 
Red User Guide for details.

•   To use a trimmed source clip in Boris Red, you must either precompose or use the Use 
Percent Done option. See your After Effects documentation for details.

Installing into Adobe® Premiere Pro®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.
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5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second �Component Selection� window displays the default component selections 
of Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette 
and the BCC Plugins. Users are encouraged to install all of these items. Choosing the 
BCC Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend the default path of C:\Program Files\Boris FX, Inc. Click Next.

8. Click Install to begin the installation. To change any of your installation settings, click 
Back.

A Setup status window updates a status bar as each of the components is installed.

9. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

10. Click Next.

11. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

12. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

13. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Transition

1. Place the clips you want to use in the transition on the Video 1a and Video 1b tracks, 
overlapping them enough to create a transition of the desired length.

2. In the Transitions palette, locate the Boris Red icon. Drag the icon onto the Transitions 
track between the two clips on Video 1a and Video 1b.

3. Double-click the Transition icon in the timeline to enter the Red interface. You can now 
open a settings Þle from the KeyFrame library, or create your own effect

4. To exit the Boris Red interface, click either Cancel to close Boris Red without saving 
changes to the effect or Apply to close Boris Red and apply changes to the effect.

5. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.



Applying Boris Red as a Filter

1. Select a clip in the timeline.

2. In the Transitions Window, select the Video Tab. In the 3rd Party Folder, choose the 
Boris Red Filter. The Boris Red interface opens.

You can now open a settings Þle from the KeyFrame library, or create your own effect.

NOTE: To preview the Boris effect when you return to the Premiere timeline, press 
the Alt key and drag the time indicator along the track.

When using any Boris Red effect that creates an alpha channel (such as a keying 
effect, a shape that does not Þll the screen, a particle effect, or a title), the alpha 
channel appears black (rather than transparent) in the preview until you perform 
the steps in the following section.

Applying Boris Red as a Composition Clip

1. Choose New from the File menu. 

2. Choose Boris Red Composition. The Boris Red interface opens.

3. You can now create a Boris Red effect and use it as a source in your timeline for 
transitions and Þlters. The new comp clip appears in the Project window and can be 
dragged into the Premiere timeline as a clip.

4. To exit the Red interface, click either Cancel to close Red without saving changes to the 
effect or Apply to close Red and apply changes to the effect. Render Red effects the 
same way you would render any other effect. 

Tips for Using Boris Red with Premiere Pro

•   When using a Red effect that creates an alpha channel (such as a title, a shape that does 
not Þll the screen, or a particle effect), the alpha channel appears black (rather than 
transparent) in the preview until you Control-click the effect in the timeline, choose 
Video Options > Transparency and in the Key Type menu, choose Alpha.

•   Premiere is limited to two source track inputs. To use additional images and Þles, add 
the images directly within Red. Enter the Red interface and add unlimited tracks in the 
Red timeline, importing movie and still image Þles, creating color, natural and 
gradient tracks and layering spline and text tracks over your effect.

•   To display the Premiere sequence timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. You can open the 
Preferences window by choosing Boris Red > Preferences (Macintosh) or Edit > 
Preferences (Windows). 
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Installing into Avid® Systems
The following instructions are for Avid® systems, including Media Composer®, 
Symphony®, Xpress Mac®, XpressDV®, and Xpress Pro®.

NOTE: Boris Red 3GL should work with any Avid product that support the AVX 
plug-in architecture. If you are using a product such as Newscutter® Effects that 
has not yet been qualiÞed, call or email Boris technical support for detailed 
installation instructions. 

NOTE: Due to a problem on Avid�s side when initializing the 1.5 plug-in 
architecture, Windows users with versions of Avid previous to Media Composer 
v11, Symphony v4, XPress v4 or XPressDV 3.5 should install Boris Red using the 
AVX 1.0 install choice. This issue was resolved by Avid in recent versions of these 
products.   Windows users with Media Composer v11 or later, Symphony v4 or 
later, XPress v4 or later and Xpress 3.5 or later should use the install choice for 
AVX 1.5.

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. 

NOTE: Due to a problem on Avid�s side when initializing the 1.5 plug-in 
architecture, Windows users with versions of Avid previous to Media Composer 
v11, Symphony v4, XPress v4 or XPressDV 3.5 should install Boris Red using the 
AVX 1.0 install choice. This issue was resolved by Avid in later versions of these 
products. Windows users with Media Composer v11 or later, Symphony v4 or 
later, XPress v4 or later and Xpress 3.5 or later should use the install choice for AVX 
1.5.

6. Click Next.



7. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

8. A Component Selection window displays the installer components� target directories. 
We recommend the default path of C:\Program Files\Boris FX, Inc. Click Next.

9. Click Install to begin the installation. Or, if you want to change any of your installation 
settings, click Back.

10. A Setup status window updates a status bar as each of the components is installed.

11. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

12. Click Next.

13. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

14. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

15. The Þrst time you browse the KeyFrame Library within the Boris Library Browser you 
must generate thumbnail images for the effects. To do this, open the Library Browser 
by choosing Window > Library Browser. Select an effect or effect folder in the Browser, 
and click the Generate Thumbnails button. For more information on using the 
KeyFrame Library see the Red users guide

Important Note for AVX 1.0 Users

When using the Boris Red 3GL AVX 1.0 plug-in, video frames will not update in the Boris 
timeline when creating your effect. This is a limitation of Avid�s AVX 1.0 architecture which 
does not impact rendering of your effect. The Boris Red 3GL AVX 1.5 plug-in does display 
updated video frames in Boris from the Avid timeline.
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Applying Boris Red as a Filter or Transition

1. Open the Effects Palette from the Tools 
menu. Boris Red appears as an effect 
category on the left. Click to select the 
Boris Red category.

Several different types of Boris effects 
appear: Boris Red 1-Input, 2-Input, 4-
Input and 6-Input, Boris Red Title-Matte 
and Boris Red Transition. 

The instructions for applying effects are the same whether you apply a Boris Red, 
Boris GRAFFITI or Boris FX effect. 

2. Choose the appropriate effect on the right side of the Effects Palette:

• If you want to Boris Red as a transition between two clips, choose Boris Red 
Transition effect. See the next section for details.

• Otherwise, choose the effect that corresponds to the number of video tracks from 
the Avid timeline that you want to use in Boris Red. For example, if you want to 
Þlter a single track from the Avid timeline, use the Boris Red 1-Input effect. If you 
want to apply multiple tracks of titles to a single track from the Avid timeline, you 
would also choose the Boris Red 1-Input effect.

• To apply Red to an Avid title or matte key, choose Boris Red Title-Matte Effect. See 
the next section for details.

3. Drag the icon for the desired effect into a clip or into a transition between two clips.

4. Enter Effects Mode. 

5. If you are using a Boris Transition effect, type a duration in the Duration Þeld in the 
Effect Editor. If you are using any other Red effect, the duration is determined by the 
duration of the clip to which you apply the effect.

6. In the Effect Editor, click the Other Options button.

The Red interface appears, containing one track 
for each input in the effect. You can add as many 
new tracks as you want, though you are limited to 
the number of inputs for the type of effect you are 
using. For example, if you use a Boris Red 4-input 
effect, you are limited to four tracks from the Avid 
timeline. However, you can create as many Boris 
Red tracks as you want. You can now open a 
settings Þle from the KeyFrame Library, or create 
your own custom effect.

Other Options button



7. To exit the Boris Red interface, click either Cancel to close Red without saving changes 
to the effect or Apply to close Red and apply changes to the effect.

8. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your Avid documentation.

NOTE for AVX 1.0 users: Avid versions that support AVX 1.0 preview only a single 
frame of video in Red. The preview frame is taken from the current position of 
Avid�s time indicator. In AVX 1.0, to preview your effect with the updating source 
media, exit the Red interface and preview the effect in the Avid timeline. Versions 
of Avid supporting AVX 1.5 can view all the Avid video frames within Red.

Applying Boris Red as a Title-Matte Effect

You can apply Boris Red directly to titles created in the Avid timeline. For example, if you 
have a bin with saved titles, you could apply a Þlter to the titles in Red.

1. Edit an Avid title or matte key into the Avid timeline.

2. Open the Avid Effect Palette and select Boris Red from the Effect categories.

3. From the list of available Red effects, drag the Boris Red Title-Matte Effect to the title 
or matte key in the Avid timeline.

Dragging the Title-Matte effect onto an Avid title or matte key is a destructive 
process which replaces the title or matte key. Additionally, removing a Title-Matte 
effect removes the title�s nested alpha channel. To remove a Title-Matte effect and 
preserve the title or matte key, use the Undo command instead of the Remove 
Effect command.

4. Click the Other Options button in the Avid Effect Editor to launch the Red Interface and 
create your effect.

If the title or matte key looks blocky when Red opens, select its Face track in the 
timeline. In the Host Media tab, choose Straight Alpha from the Key menu. This 
usually happens automatically.

Replacing a Title-Matte Effect

Since a title is replaced by applying the Title-Matte effect, i to re-edit a title with a Title-
Matte Effect (for example to change the text or a font) you must save the Title-Matte effect 
while you are in Red (in the File menu). Recreate the Avid title and overwrite the older title 
in the Avid timeline. Drag a Red Title-Matte Effect to the new title. In Red, open the saved 
effect and apply it to the new title.
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Tips for Using Boris Red with Avid Systems

•   For the best results with layered effects, only apply the Boris Red Input effect which 
uses the number of tracks you need from the Avid timeline. When applying an effect 
with too many inputs, the extra tracks add overhead to the AVX interface, which slows 
rendering considerably. For example, to use two tracks from the Avid timeline and add 
two tracks of titles, use the Boris Red 2-Input effect not the Boris Red 4-Input effect.

•   Boris Red is limited to six tracks from the Avid timeline. However, you can import 
QuickTime reference Þles as Movie media which allows you to use an unlimited 
number of tracks from your Avid timeline. You need to export the QuickTime reference 
Þles, identify their names and navigate to them in the Movie dialog. For information, 
see your Avid documentation.

•   You can use Automatic Duck to import your entire Avid timeline into Boris Red. See 
�Support for Automatic Duck Composition Import� on page 584 in Volume I of the 
Red User Guide for details.

•   When you have multiple unrendered Boris Red effects in your timeline, you should 
turn off the Avid Render on the Fly option to avoid slowing down your playback.

•   Red reads tracks from the top down. Avid reads tracks from the bottom up. For 
example, you want to create an effect in Boris Red using six tracks from your Avid 
timeline. Add the Boris Red 6-Input effect to the top track in your timeline. However, 
when you open Boris Red, the V6 track from your Avid is the V1 track in Boris Red. To 
keep from getting confused, you may want to rename your tracks in Boris Red.

•   The Avid Title Tool allows you to create many titles in real time. However, the titling 
capabilities in Boris Red are more extensive. One way to optimize your rendering 
times is to create your title in Red then instead of applying the effect, export to 
QuickTime, without the underlying video. Import the QuickTime into the Avid using 
the Avid Codec which includes support for Alpha. If your system supports real-time 
matte keys, the imported title plays in real time. 

•   To optimize the rendering of static titles, create your title in Red. Instead of applying 
the effect, export as a PICT or Targa Þle, without the underlying video. Then import 
the PICT or Targa into the Avid.

•   Unlike some Avid systems, all Boris applications support larger -than-project Þle sizes. 
You can easily import large images for pan-and-zoom documentary-style animations. 
Apply Red to any clip of the proper length. Once Red is open, press the Media icon to 
assign the large Still Image Þle to the track. Animate the scale and position as desired. 
The PICT format limits images to 4000 pixels, which may not be large enough. When 
saving your images, use the TIFF format instead. Images display at 72 dpi in Red 
(standard video resolution), so it makes sense to create images at this size in your still 
image application. This also reduces render times by not processing pixels that video 
can't display. Render times are longer than video renders as sizes increase beyond 
video scale: an image of 4000 x 4000 pixels at 72 dpi is roughly 45 times the size of a 
video frame. Assign as much RAM as possible to your Avid before rendering large 
Þles.



•   Avid systems do not provide support for Adobe After Effects Þlters. However, many 
Adobe After Effects Þlters plug into Boris Red. After Effects Þlters appear in the Red 
Þlter list in the same way native and BCC Þlters do. This allows you to use Red as a 
gasket to apply third-party After Effects Þlters to clips in your Avid timeline. Apply 
and use Adobe After Effects Þlters the same way you would use native Red Þlters. For 
more information on Þlters, see Volume II of the Red User Guide.

•   If you apply a multi-input effect to the Avid timeline with fewer tracks than the 
number of inputs selected for your effect, the monitor displays an unsupported 
resolution error For example, you want to use three video tracks in the Avid timeline 
in a Red effect. Red provides 1,2,4, and 6 input effects. If you apply a Red 4-input effect, 
design the effect, and click Apply; the Avid Record window displays the error. To Þx 
this problem, create a blank fourth video track in the Avid timeline (even if it is not 
referenced by your effect). Then your video displays in the Avid Record window. 
Alternatively, you could apply a Red 2-input effect and import the third track into Red 
as a movie using a QuickTime reference Þle.

•   To display the Avid sequence�s timecode in Red, set the View Time menu in the General 
tab in the Preferences window to Program Timecode. You can open the Preferences 
window by choosing Boris Red > Preferences (Macintosh) or Edit > Preferences 
(Windows). 

Installing into DPS® Velocity®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.
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7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.

8. Click Install to begin the installation. To change any of your installation settings, click 
Back.

A Setup status window updates a status bar as each of the components is installed.

9. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

10. Click Next.

11. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

12. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

13. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Transition Effect in DPS Velocity

1. Right-click a transition icon, then choose Rendered Transition > Plugin Transitions.

2. In the dialog box that appears, choose Boris Red from the menu.

3. Click the Custom button within the Transition Viewer to enter the Boris Red interface.

4. To exit the Boris Red interface, click either Cancel (to close Boris Red without saving 
changes to the effect) or Apply (to close Boris Red and apply changes to the effect).

5. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

Applying Boris Red as a Filter Effect in DPS Velocity

1. Right-click a clip and choose Video Effects.

2. In the Apply Effects window, choose General Plugins from the Filter Categories menu. 
�Boris Red Filter� is now listed within the Available Filters Þeld.

3. Click Boris Red Filter, then click ADD to enter the Boris Red interface.

4. After selecting or creating effects within Boris Red, click Apply. Boris Red Filter is now 
listed within the Effects Selected Þeld.



5. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

NOTE: To re-edit an existing Boris Red Filter, repeat steps 1-2, then select �Boris 
Red� in the �Effects Selected� Þeld and click the �Options� button.

Installing into IMC®, Incite®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.

8. Click Install to begin the installation. Or, if you want to change any of your installation 
settings, click Back.

A Setup status window updates a status bar as each of the components is installed.

9. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

10. Click Next.

11. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.
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12. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

13. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Multi-Layered-Track Filter Effect in Incite

1. Place the clips you want to use onto Incite's video tracks, overlapping them so that all 
are within the desired time frame of the intended multi-layered track effect.

2. In the Keyframe tab, select the Filters tab.

3. Select Boris - Boris Red 3GL. Click ADD to apply the effect.

The Boris Red interface appears.

4. To exit the Boris Red interface, click either Cancel (to close Boris Red without saving 
changes to the effect) or Apply (to close Boris Red and apply changes to the effect).

5. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application's documentation.

Applying Boris Red as a Single-Track Filter Effect in Incite

1. Place the clip you want to use onto Incite's video track.

2. In the Keyframe tab, select the Filters tab.

3. Select Boris - Boris Red 3GL. Click ADD to apply the effect.

The Boris Red interface appears.

4. To exit the Boris Red interface, click either Cancel (to close Boris Red without saving 
changes to the effect) or Apply (to close Boris Red and apply changes to the effect).

5. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application's documentation.

Installing into In:Sync® Speed~Razor® and Blade®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.



3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.

8. Click Install to begin the installation. To change any of your installation settings, click 
Back.

A Setup status window updates a status bar as each of the components is installed.

9. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

10. Click Next.

11. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

12. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

13. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Transition in Speed~Razor and Blade

1. Open the Razor project in which you want to create a transition.

2. Choose File > Add Transition(s). The Add Transition(s) dialog box appears.

3. In Razor's TRANS sub-directory, select FX-BORIS.TRA. Click OK. Boris Red is added 
to your library.
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4. Place the clips you want to transition V1 and V3 so that the overlap for the desired 
duration of the transition. 

5. Drag the Boris Red transition from the Library window to the Construction window 
onto track V2, between the two overlapping clips. The Boris Red interface appears.

6. To exit the Boris Red interface, click either Cancel to close Boris Red without saving 
changes to the effect or Apply to close Boris Red and apply changes to the effect.

7. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

Applying Boris Red as a Filter in Speed~Razor and Blade

1. Open the Razor project for which you want to create an effect.

2. From the main menu, under File, choose Add Effect(s). The Add Effect(s) dialog box 
appears.

3. In Razor's EFFECTS sub-directory, choose FL-Boris.VFX. Click OK. Boris Red is added 
to your library.

4. Drag the Boris Red effect from the Library window to the Construction window onto 
the track below the clip you want to Þlter. The Boris Red Interface appears.

5. To exit the Boris Red interface, click either Cancel to close Boris Red without saving 
changes to the effect or Apply to close Boris Red and apply changes to the effect.

6. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

NOTE: In effect mode, Boris Red can only operate on the current clip (Video 1). 
Video 2 is not available.

Installing into Media 100® iFinish®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.



5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend the default path of C:\Program Files\Boris FX, Inc. Click Next.

8. Click Install to begin the installation. To change any of your installation settings, click 
Back.

A Setup status window updates a status bar as each of the components is installed.

9. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

10. Click Next.

11. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

12. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

13. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris in iFinish

You can apply Boris Red in iFinish as either a transition, Þlter, or Comp Clip.

You can access the Media 100 Bin browser within Boris by the pressing the Media 
icon in the timeline track and selecting Bin Browser from the menu.

Applying Boris as a Transition in iFinish®
1. Place the clips you want to use in the transition on the Video A and Video B tracks, 

overlapping them enough to create a transition of the desired length.
Installation Guide        39



2. Double-click the Transition Arrow (in the FX track between the A and B track.) This 
puts the Edit Suite into Transition mode, where you can set the duration of the 
transition by dragging the red and green trim handles or by typing the total length in 
the Length box. You can also click the appropriate icon to choose a �Start on Cut,� �End 
on Cut,� �Centered on Cut,� or �Custom� transition. 

3. To choose a Red effect, use the buttons in the upper right corner of the Edit Suite. Click 
the third button to display a pop-up menu of DVEs. Choose Boris Red from the menu.

4. To enter the Boris Red interface, click the Custom Settings button. You can now either 
open settings from the KeyFrame library or create your own custom effect.

5. To exit the Boris Red interface, click either Cancel to close Boris Red without saving 
changes to the effect or Apply to close Boris Red and apply changes to the effect.

6. Click Apply in the Edit Suite to apply the changes you made in Boris Red.

7. Render Boris Red effects the same way you would render any other effect. For more 
information, consult your host application�s documentation.

Applying Boris Red as a Filter or Comp Clip 

1. Select either a Bin window or Timeline window and choose New Composition from 
the Tools menu. A Comp Clip is created on Video Track A or in a bin. 

2. Double-click the Comp Clip to put Edit Suite into Edit Clip mode.

3. To enter the Boris Red interface, click the Edit button. You can now open settings from 
the Keyframe Library or create your own custom effect.

4. To exit the Boris Red interface, click Cancel to close Boris Red without saving changes 
to the effect, or Apply to close Boris Red and apply changes to the effect.

5. Click Apply in the Edit Suite to apply the changes you made in Boris Red.

6. Click Render in the Edit Suite to render the Comp Clip you just created.

Applying Boris Red as a Title 

1. Select the Program window or a bin. In the Tools menu, choose New Title.

2. Double-click Title and choose Edit in the Edit Suite.

3. To enter the Boris Red interface, click the Edit button. 

You can now open settings from the Keyframe Library or create your own custom 
effect.

4. To exit the Boris Red interface, click Cancel to close Boris Red without saving changes 
to the effect, or Apply to close Boris Red and apply changes to the effect.

5. Click Apply in the Edit Suite to apply the changes you made in Boris Red.

6. Click Render in the Edit Suite to render the Comp Clip you just created.



Exporting a Media 100 Timeline to Boris Red

You can export your Media 100 timelines directly to the Red Engine. 

1. Copy the Media100ProjectImporter Þle into your �BorisPlugins� folder. 

This Þle should be located on your Media 100 install CD, in the Media 100 After Effects 
Plug-in folder.

2. Choose Export to....After Effects from the Media 100 File menu. 

The Þle that you export from Media 100 has a �.M1A� extension. 

3. Launch the Red Engine and choose File > Import. Navigate to the Þle that you 
exported. 

4. The Red timeline changes to the M1A Þle. 

Tips for using Boris Red with iFinish

•   When you create a Red effect in the Media 100 timeline, the interface opens with the 
settings of the last Red effect you created so that you can easily create a similar effect. 
To create an entirely new effect, choose File > New Project.

•   Titles created with the Constant interpolation play in real time on Media 100 systems 
that support real-time static titles. To animate, change the Default interpolation from 
Constant in the Preferences window.

•   You can open clips from the Bin Browser directly in Red. Press the Media icon on a 
track and choose Bin Browser from the menu that appears. A ßoating window opens 
with all the clips in your Bin Browser. Choose the appropriate clip from the window. 
In the Red timeline, the clip displays the Movie media icon.

•   Red lets you import large images for �pan-and-zoom� documentary-style animations. 
Apply Boris Red to any clip of the appropriate duration. Once Red is open, press the 
Media icon to assign the Still Image File. Animate the scale and position as desired.

The PICT format limits images to 4000 pixels, which may not be large enough. When 
saving your images, use the TIFF format instead. Images display at 72 dpi in Red 
(standard video resolution), so it makes sense to create images at this size. This reduces 
render times by not processing pixels that video can't display. Render times are longer 
than video renders as sizes increase beyond typical video scale: a 4000 x 4000 pixel 
image at 72 dpi is roughly 45 times the size of a video frame. Assign as much RAM as 
possible to Media 100 before rendering large Þles.

•   The current version of Media 100 changes the clip name when digitizing at new 
resolutions, which can cause Boris Red to lose track of the Þle. The easiest way to avoid 
lost media is to use clips at their Þnal resolution inside Boris Red. Otherwise, open 
Boris Red and manually reassign the media with its new name after you redigitize.
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•   To use Þles with alpha channels inside Red, don't place them on the Media 100 
timeline. Media 100 doesn't pass alpha channel information to Red. Apply Red either 
using a solid black clip as a placeholder, or a copy of your clip with alpha. Once inside 
Red, assign the Source media to a Movie Þle or Still Image File, and turn off the 
placeholder track in Media 100. The alpha channel now renders properly.

•   To display the Media 100 sequence timecode in Red, set the View Time menu in the 
General tab in the Preferences window to Program Timecode. 

Installing into Pinnacle® purple®, silver®, Edition®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 

4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A �Component Selection� window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.

8. Click Install to begin the installation. Or, if you want to change any of your installation 
settings, click Back.

9. A Setup status window updates a status bar as each of the components is installed.

10. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

11. Click Next.



12. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system that is fully integrated 
into Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install 
the Intelligent Assistant, follow the onscreen instructions to complete the installation.

13. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

14. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

Applying Boris Red as a Transition Effect in Pinnacle

1. Click and drag your Þrst clip to the timeline. Click and drag the second clip to the 
timeline and place it adjacent to, and touching the Þrst clip.

2. In your project, go to the FX TAB. Choose PLUGIN TRANSITON FX, then ADDED and 
select Boris Red. Drag and drop it onto the cut point between the two clips. Right-click 
the Boris effect and choose Edit. The Transition Options window opens and the default 
Boris effect is displayed in the Preview window. To see the actual.tga Þle rather than 
the gray �V�, click the little Television icon button.

3. Click Custom to open the Boris Red interface.

Applying Boris Red as a Filter Effect in Pinnacle

1. In your project, go to the FX tab. Choose PLUGIN CLIP FILTER FX, then ADDED and 
select Boris Red. Drag and drop it on the middle of the clip you want to Þlter.

2. Right-click the clip and choose FX Properties. A small window opens and lists �Boris 
Red Filter�. Double-click Boris Red Filter to open the Boris Red interface.

Installing into Sony Digital Pictures® Vegas®

1. Quit all applications.

2. Insert the Boris Red CD into the system�s CD-ROM drive. 

NOTE: If (after at least 15 seconds) the �Welcome to Boris Red� window does not 
appear, then double-click setup.exe located within the �install� directory found at 
the root of the Boris Red CD.

3. Read the Software License Agreement. Click I Accept, then click Next. 
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4. Enter your name, company name, and the product serial number (including the 
hyphens) found in the front cover of your User Guide or on the registration card. Click 
Next.

5. A Component Selection window appears with Red 3.0 Engine already selected. 
Additionally select your host from the list below. We recommend you select both 
choices-- the Red Engine and the plugin-Þle(s) for your host. Click Next.

6. A second Component Selection window displays the default component selections of 
Boris Red KeyFrame Library, Boris Red User Guides, 3.0 Styles for the Style Palette and 
the BCC Plugins. Users are encouraged to install all of these items. Choosing the BCC 
Plugins choice will also install the free Delirium plugins. Click Next.

7. A Component Selection window displays the installer components� target directories. 
We recommend you leave the default path of C:\Program Files\Boris FX, Inc. Click 
Next.

8. Click Install to begin the installation. To change any of your installation settings, click 
Back.

9. A Setup status window updates a status bar as each of the components is installed.

10. A Plugin Destination window displays the directory path in the Red plug-in Þle(s) will 
be installed. If this path is incorrect, you can change it using the Change button.

11. Click Next.

12. A Setup Complete window offers a checkbox option to install the Intelligent Assistant. 
The Intelligent Assistant is a sophisticated online help system fully integrated into 
Boris Red 3GL. It is directly accessible from the Help menu. If you choose to install the 
Intelligent Assistant, follow the onscreen instructions to complete the installation.

13. Click Finish. Launch your host application to ensure that installation of Boris Red was 
successful.

14. The Þrst time you launch Boris Red, you must generate thumbnail images for the 
KeyFrame Library effects. To do this, open the Library Browser by choosing Window 
> Library Browser. Select an effect or effect folder in the Browser, and click the Generate 
Thumbnails button. For more information on using the KeyFrame Library, see Chapter 
4, �Creating Effects,� in Volume I of the Red User Guide.

 Applying Boris Red in Sony Digital Pictures Vegas

Beginning with Version 3GL, Boris Red supports Sony Digital Pictures Vegas � version 3.0 
and later. Apply Red as a transition or a video effect.

By default, Vegas caches every video frame. This results in effects not displaying 
correctly after re-editing. To disable the Vegas cache, open the Vegas Preferences 
from the Options menu. Click the Video tab and set Dynamic RAM Preview max 
(MB) to 0. 



Applying Boris Red as a Transition

Boris Red displays in the list of available transitions in the Vegas Transitions window and 
can be applied as a transition the same way you apply any native transition in Vegas. 

The Red timeline will not display updated video frames while launched inside 
Vegas. Only the video frame at the cursor location is displayed in Red�s timeline. 
This limitation of Vegas�s architecture does not impact rendering effects.

1. Drag the Boris Red Transition to the crossfade between two video events or to the fade-
in or fade-out region of a video event.

The Event Effects window opens.

2. Click the Launch Boris FX Button to open the Red interface.

The cursor must be placed within the effect for video to display in Red. Place the 
Vegas cursor on the Þrst frame of the transition to display the Þrst frame in Red. 
Otherwise the frame where the cursor is stopped in Vegas displays in Red.

3. In the Red Timeline window, set the Duration to match the 
duration of your Vegas effect by typing a new value in the 
Duration Þeld and pressing Enter.

If the Red transition duration does not match the Vegas 
transition duration, the rendered Vegas transition will 
appear different than when you create it in Red.

4. Choose Edit > Preferences to open the Preferences window. 

5. In the General tab in the Preferences window, set the Project Options to match the 
project size, FPS and aspect ratio that you are using in Vegas. Click OK to close the 
Preferences window.

6. You can now open settings from the Keyframe Library or create your own custom 
effect.

7. When you Þnish creating your transition effect, press the Apply or Cancel button to 
either apply the effect to Vegas or cancel and leave the transition unchanged.

Applying Boris Red as a Video Effect

Boris Red appears in the list of available video effects in the Video FX window and can be 
applied as a video effect the same way you apply any native video effects in Vegas.

The Red timeline will not display updated video frames while launched inside 
Vegas. Only the video frame at the cursor location displays in Red�s timeline. This 
limitation of Vegas�s architecture does not impact rendering effects.

Set the Red duration to 
match the Vegas duration.
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1. Drag the Boris Red video effect from the Video FX window to an event or track. The 
Event Effects window opens.

2. Click the Launch Boris FX Button to open the Red interface and create your effect.

Place the Vegas cursor on the Þrst frame of the effect to display the Þrst frame in 
Red. Otherwise the frame at the Vegas cursor location displays in Red.

3. In the Red Timeline window, set the effect duration to match 
the duration of your Vegas effect by typing a new value in the 
Duration Þeld and pressing Enter.

If the Red effect duration does not match the Vegas effect 
duration, the rendered effect in Vegas appears 
differently than when you preview it in Red.

4. Choose Edit > Preferences to open the Preferences window. In the General tab in the 
Preferences window, set the Project Options to match the project size, FPS and aspect 
ratio that you are using in Vegas. Click OK to close the Preferences window.

5. You can now open settings from the Keyframe Library or create your own custom 
effect. When you Þnish creating your effect, press the Apply button or Cancel button to 
either apply the effect to Vegas or cancel and leave the event or track unchanged.

Tips for using Boris Red with Sony Digital Pictures Vegas

•   The frame that Vegas Video passes to Red does not necessarily match the Vegas project 
size. Instead this frame is the same size as the frame displayed in the Vegas Preview 
window. Any Preview window setting will work, but best results are achieved by 
setting the Preview window to Best/Full before launching Boris Red.

•   Vegas only previews a single frame of video in Boris Red. The preview frame is taken 
from the current position of the Vegas cursor. To preview your effect with updating 
source media, exit Red and preview the effect in the Vegas Video timeline. 

•   To preview a Red effect in Vegas, you must Þrst click the Apply button. You cannot 
preview changes in Vegas while the Boris Red user interface is launched.

•   By default, Vegas caches every video frame. This results in effects not displaying 
correctly after re-editing. To disable the Vegas cache, open the Vegas Preferences from 
the Options menu. Click the Video tab and set Dynamic RAM Preview max (MB) to 0. 

•   When you Þrst apply a Red Þlter to the Vegas timeline, you may need to wait a moment 
for Red to fully load into memory.

Set the Red duration to 
match the Vegas duration.



Installing and Using Adobe After Effects Filters within Boris Red

Boris Red allows you to access third-party After Effects plug-ins from the Filters menu. This 
means that you can integrate supported plug-ins with your host application. This greatly 
increases the creative options available within your nonlinear editor. Not only can you 
access Þlters directly within Red, but you can combine third-party Þlters with Red effects 
for an unprecedented range of integrated effects creation. 

Boris FX provides a list of AE Þlters supported for use inside Boris Red. Please see the Boris 
web site www.borisfx.com for a list of supported Þlters. For best results, use only supported 
AE Þlters inside Boris Red. 

Boris Red 3GL includes four free DigiEffects Delirium Þlters: DE Day for Night, 
DE Fog Factory, DE Fireworks and DE Electrical Arcs. These Þlters are installed 
in the BorisPlugins folder when you choose to install the BCC Plugins for Red 
using the Boris Red Components install choice in the Red installer. For 
information on how to apply these Þlters to Red effects, see the Boris Red 3GL 
Release Notes. For more information about these Þlters, see the 
DigiEffects_info.pdf documentation included on the Boris Red 3GL CD.

Boris Red does not support AE 4.x Þlters. Only After Effects 3.1 compatible Þlters 
will work inside Boris Red.

Installing AE Filters for Macintosh
Place supported After Effects Þlters in the following folder:

System Folder (or Library)/Application Support/BorisFX\/BorisPlugins.

The Þlters appear in the Filters menu within Boris Red.

Installing AE Filters for Windows
Place supported After Effects Þlters in the following folder:

C:\Program Files\Boris FX, Inc.\BorisPlugins.

The Þlters appear in the Filters menu within Boris Red.
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