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Boris Red 4 ReadMe

This document describes hardware and software requirements and provides any special 
notes that are important for you to know. This document also lists known problems and 
limitations.

Hardware and Software Requirements
The following section describes the Red 4 hardware and software requirements. For the most 
up-to-date information about hardware and software requirements, go to www.borisfx.com.

Supported Operating System
•   Boris Red 4 supports the Windows XP operating system.

Minimum System Requirements
•   A minimum 1 GB of RAM is recommended to run Boris Red, 2 GB preferred.

•   At least 512 MB of memory is recommended using Boris Red standalone.

To run Boris Red, QuickTime version 6.5 or later must be installed on your system. To 
download the standalone version of QuickTime from the Apple Web site go to 
www.apple.com.

http://www.apple.com
http://www.avid.com
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What’s New Red 4

New Library Browser Template Mode
You can now use the Library Browser in a special Template mode. The Boris Red  Library 
Browser allows you to quickly preview and apply settings files from the KeyFrame Library, 
including settings files that you add or customize. The KeyFrame Library is a collection of 
preset effects that is automatically installed on your system when you install Boris Red. You 
can add, remove, or change these settings files at any time. 

Template mode allows you to use the Library Browser to create effects. This mode is most 
useful when creating text effects or when repeatedly applying the same preset. When you are 
in this mode, you simply replace the text for the selected effect template.

When you select the Show Only Browser checkbox in the Preferences window, only the Library 
Browser appears when you work in the Boris Red user interface. This feature is only available 
when you use Boris Red as a plug in. 

1. Access the Preferences window by choosing Edit > Preferences (Windows) or Boris Red 
> Preferences (Macintosh).

2. In the Appearance tab, click to select the Show Only Browser checkbox and click OK to 
apply your changes. Now, only the Library Browser appears when you work in the Boris 
Red user interface. 

3. When you are in Template-only mode, the Library Browser is the only window that 
appears. You can also enter this mode by choosing Window > Library Browser or clicking 
the Open Library Browser button in the timeline.

4. Click the name of any folder in the Available Categories window. Thumbnail images of 
each effect in that folder appear in the Available Effects window.

5. Click any thumbnail image to select the effect. A red box appears around the selected 
thumbnail. Press Play to view an animated RAM preview in the Preview window. 

6. Click the appropriate Template-Mode control to edit your template.

Template Mode Replace Comments

Insert Text Retrieve Comments
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•   Clicking the yellow Template Mode button allows you to toggle in and out of Template 
mode without opening the Preferences window. When you are not in Template 
mode, this is the only control that appears in the Library Browser. 

•   Clicking the red Insert Text button allows you to type text into the Comments window. 
This text replaces the placeholder text that is included in the thumbnail. To replace 
multiple lines of text, press Tab between each line. 

•   Clicking the green Replace Comments button allows you to type comments into the 
Comments window. This text replaces the existing comments. 

•   Clicking the blue Retrieve Comments button allows you to retrieve comments into 
the Comments window. Click this button if you have inserted text into the comments 
window and now want to view the associated comments. 

7. Click the Load Effect button to save the currently selected effect.The effect is applied, 
Boris Red closes and you are returned to your host application.

New Preferences
The following preferences have been added to Boris Red.

Appearance Tab
A new Appearance tab has been added to the Preferences window. The Appearance tab lets 
you set display options for the Boris Red user interface. 

You can access the Preferences window by choosing Edit > Preferences (Windows) or Boris 
Red > Preferences (Macintosh).
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Common Background Colors
These options allow you to customize the colors used in the Boris Red user interface. 

Click the color chip to open the system color picker and choose the desired color.

•   Windows sets the color of the background for all windows in the Boris Red user 
interface.

•   Text sets the color of the text in all windows in the Boris Red user interface.

Timeline Colors Options
The Timeline Colors options allow you to customize the colors used in the Boris Red timeline 
tracks. In previous versions of Boris Red, these options appear in the Preview tab. 

Click the color chip to open the system color picker and choose the desired color.

•   Background sets the color of the timeline background.

•   Selection sets the color of selected tracks in the timeline’s track controls (the left 
side of the timeline).

•   Keyframe sets the color of keyframes.

•   Shape Track sets the color of Shape tracks on the right side of the timeline.
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•   Media Track sets the color of the Media tracks nested inside Shape tracks.

•   Container Track sets the color of 3D Containers and Title Containers.

•   Filter Track sets the color of filter tracks on the right side of the timeline.

Library Browser
When you select the Show Only Browser checkbox, only the Library Browser appears when 
you work in the Boris Red user interface. For more information on this new features, see New 
Library Browser Template Mode.

Plug-Ins and Library Browser Now Accept Aliases
The Boris Red Plug-Ins folder and Library Browser now accept aliases to plug-in and effect 
files and folders on your system and will follow them to the original file or folder.

Aliases in the Library Browser
If you place an effect alias or shortcut to a folder or file in the Library Browser, Boris Red will 
now follow it to another folder or file, as if that folder were where the alias or shortcut is 
placed.

Aliases in the Plug-Ins folder 
If you place an alias or shortcut to a folder or file in the Boris Red Plug-Ins folder, Boris Red 
will now follow it to another folder or file, as if that folder were where the alias or shortcut is 
placed. 

The Boris Red Plug-Ins folder is found in the following location:

Macintosh

<Drive>:Library:Application Support:Boris FX, Inc:BorisPlugins

Windows

c:\Program Files\Boris FX, Inc\BorisPlugins\

This means that you no longer need to make copies of your plug-ins, since you can now keep 
centrally located plug-in set(s). 

Boris Red currently only supports 8-bit plug-ins. Placing an alias or shortcut to 16-bit plug-ins 
in the Boris Red Plugins folder will cause undesirable results.
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Improved Support for Third Party After Effects Plug-Ins
Boris Red expands support for third Party After Effect plug-ins inside Incite. For best results, 
use only supported AE filters inside Boris Red. 

For information on installing and using third Party Plug-Ins, see Important Information on 
Using After Effects Filters and Installing and Using Adobe After Effects Filters within Boris 
Red.

Most of the unsupported filters will not appear in the Boris Red Filter menu even if they are 
installed, or will display an error message when you apply them.

Buena Software
•   Dissolve Factory

•   Effect Essentials

NOTE: The following Buena Effect Essentials filters are not supported: Feedback, 
HSV Curves, HSV MAnipulator, Super RGB Curves.

Conoa
•   Conoa 3Dr

•   Easy Shapes

•   SuperPak

NOTE: You must use the AE 4.0 versions of Conoa filters with Boris Red. Later 
versions will not work.

Cycore
•   Cycore FX HD

NOTE: The following Cycore FX HD filters are not supported: all Time Filters, 
Composite, Environment, Split 2, Repetile.

DigiEffects
•   Aurorix

•   Beserk

•   Cinemotion

•   Delerium
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•   Fantasm

NOTE: Cinemotion Film Motion effects do not work in Red.

NOTE: The following DigiEffects Delerium filters are not supported: Channel Delay, 
Fireworks, Fairy Dust, Film Flash, Muzzle Flash.

NOTE: The following DigiEffects Fantasm filters are not supported: Color by Number, 
Shredder, PixxyUnstripe, PixxyAudio.

Digital Anarchy
•   3D Layer

•   Color Theory

•   Geomancy

•   Gradient

•   Psunami Water

•   Retimer SD and HD

•   Anarchy Toolbox

NOTE: The following Anarchy Toolbox filters are not supported: Anarchist Edge, Color 
Sampler, Gradient Path, Path Distort, Resizer.

Digital Film Tools
•   Digital Film Lab

•   zMatte

•   Composite Suite*

•   55 mm

NOTE: The Frame Averager Composite Suite filter is not supported.

NOTE: Boris Red supports version 55 mm version 2.0 only. Versions 3.0 and 4.0 are 
not supported.

The Foundry
•   KeyLight

•   TinderBox 1, 2, 3

NOTE: The following Tinderbox filters are not supported: T_PseudoColour, T_Blob, 
T_Grad, T_Sky, T_Plasma, T_Glow, T-MeltTime, T_Trail, T_MotionDetect.
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FreshLuft
•   flAIR

Panopticum
•   Camera Noise

•   Compare Mask

•   Engraver

•   Rulers

•   Plugin Galaxy

Profound Effects
•   Swim

Red Giant Software
•   Knoll Light Factory

•   Image Lizard and Composite Wizard

NOTE: The following Image Lounge and Composite Wizard filters are not supported: 
Video Feedback, Wire&RigRemoval, Denoiser, Hall of Time, Color Map, Color 
Matcher, Brimstone, Clouds, Fire, Tunnel, Text.

Re: Vision Effects
•   Fields Kit

•   Re:Fill

•   ReelSmart Motion Blur

•   Shape/Shade

•   SmoothKit

•   Twixtor Pro

•   Video Gogh

Synthetic Aperture
•   Color Finesse

Trapcode
•   Shine

•   Star Glow
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Walker Effects
•   Professional Edition

NOTE: The following Walker Effects filters are not supported: Alpha Tool, Channel 
Offset, Color Composite, Fast Tracker, Glow, Light Wrap.

Preview to Monitor
Preview to Monitor is now available when using Boris Red as a plug-in on some systems.

Enabling Preview to Monitor
To enable the Preview to Monitor feature, start Boris Red and open the Preferences window.

1. Choose File > Preferences.

2. Click to select the Preview tab.

3. In the External Monitor Output section, choose your hardware from the Device menu. The 
Device menu displays all the supported hardware connected to your system.

4. Choose an option from the Mode menu if applicable. For example, if you are using a 
FireWire Converter box, you can choose PAL and NTSC formats from the Mode menu.

5. Click OK to save your settings and exit the Preferences window.

The Preview to Monitor preferences are saved and applied to all Boris Red projects 
unless your Boris Red preference file is rebuilt.

Displaying Frames in your External Monitor
Commands in the Preview menu allow you to set the video display.

When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor is 
enabled and the following three options in the menu become available:

•   Auto-Update Monitor allows every frame of your effect previews to the external video 
monitor. This allows you to drag the CTI in the timeline and view updating frames. 
The image displays on the external monitor, using the Resolution and Quality 
settings specified in the Composite window.

Enabling Auto-Update Monitor will slow Boris Red since every frame is updated in the 
external monitor.

•   Display Frame on Monitor displays the current frame on the external monitor, using 
the Resolution and Quality settings specified in the Composite window. 
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•   Display HQ Frame to Monitor to display the image on the external monitor, using Full 
Resolution and High Quality settings, regardless of the Resolution and Quality 
settings in the Composite window. 

Disconnecting Preview to Monitor
To disconnect Preview to Monitor (for example if you want to connect another device to your 
video board while editing with Boris Red), quit Boris Red. When you restart Boris Red, the 
external monitor is not connected until you choose Connect to External Monitor in the Preview 
menu.

Tips for Using the Preview to Monitor Feature
•   Preview to Monitor automatically disconnects when you exit Boris Red. This means 

each time you start Boris Red, you need to choose Preview > Connect to External 
Monitor in order to reconnect and see your image on the external monitor.

•   To change the Preview to Monitor device or mode, disconnect Boris Red’s Preview 
to Monitor feature by choosing Disconnect External Monitor from the Preview menu. 
Open the Boris Red GL Preference window’s Preview tab to choose a new Device or 
Driver from the External Monitor Output menus. You can also reconnect via the 
Preview menu with those new settings in the same session.

•   Displaying images on an external monitor requires compressing and resizing the 
images. Boris Red might run slower if you have Auto Update enabled. Deselect Auto-
Update Monitor in the Preview menu to remain connected to the external monitor 
but not automatically update frames. 

•   Manually update frames to your external monitor by choosing Preview > Display 
Frame to Monitor, or Preview > Display HQ Frame to Monitor, or by pressing the 
Display Frame to Monitor button on the upper-right corner of the Composite window. 

Supported Preview to Monitor Hardware
You can output video to an external monitor through a FireWire converter box or through 
supported video hardware connected to your system. You can output media at any project 
size and immediately view your working frame without rendering the timeline. 

NOTE: As a standalone, Boris Red does not officially support connecting to hardware 
that is already in use by the host NLE for direct Video Out purposes. The 
standalone version of Boris Red can only use the FireWire output if the NLE 
releases it while Boris Red is running.
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However, Boris Red looks for all possible output devices upon installation, and lists the 
results in the Device menu in the Preview tab of the Boris Red preferences. As a result, users 
may be able to use a different output device for Boris Red than the one that the host 
application uses. The host application may use its own capture hardware for display, leaving 
the FireWire port available. 

Video-out capabilities are also available in the standalone Boris Red. This enables anyone 
with supported video hardware, whether built into their computers, included with their NLEs, 
or provided through third parties, to see the work they create in Boris Red immediately on 
television monitors.

NOTE: Make sure you have the latest drivers installed for the supported video cards.

More Flexibility for Pie Charts
A new Series menu appears in the Chart tab for Pie Charts. This allows more flexible data 
import. Previously, you could only import row-based data into Pie Charts. The Series menu 
lets you orient the chart to include rows or columns as a series. 

•   Rows as Series places the rows vertically in the chart. The information in the first 
row appears in the Legend (if the Enable Legend checkbox is selected in the Legend 
tab).

•   Columns as Series places the columns vertically in the chart. The information in the 
first column appears in the Legend (if the Enable Legend checkbox is selected in 
the Legend tab).

Applying Two Motion Tracker Filters to the Same Track
Two Motion Tracker filters can be applied to the same shape or filter track. Previously, only 
the top-most Motion Tracker filter was recognized. For example, this is useful when motion 
tracking both ends of the wire in the Wire Remover filter.

New Quit and Save As Behavior
When you quit Boris Red, the name of the saved setting is displayed and saved when you 
press OK. The application then quits, which eliminates the extra dialog box that you 
previously had to dismiss. If you want to save the open setting with another name, you can 
press Cancel and then save your setting. If the setting has not been saved previously, the 
dialog prompts you to save it.



Boris Red 4 ReadMe

472 

New Preview to RAM Behavior
When audio is disabled, Preview to RAM now loops the playable frames, rather than playing 
the frames then holding the last frame for the full (or in/out) duration. 

Project Window Improvements
The active composition in the Project window (in Frame view, List view, or Render Queue) is 
framed with a blue outline, which is different than the selection color. This indicates the 
composition that is open in the timeline and saves when you choose Save Composition. 

New Project Window Sorting
Friendlier sorting of compositions in Frame, List and Render Queue views. Columns now sort 
more logically when they contain numbers (i.e. 10 sorts after 9, not after 1). This ordering is 
regardless of where the numbers occur in the name.

New Naming Scheme for New and Duplicated Compositions
When you create a new Composition, duplicate names are now avoided. Previously when you 
created a Project and saved a copy of the Composition several times, you could easily create 
confusion with several compositions of the same name. Duplicated compositions are named 
with “_1”, “_2”, etc. The Save Composition Copy command automatically appends “_1” after 
the name. If you edit the name of Composition 1_1 and choose Save Composition Copy, you 
get Composition 1_1_1, so you can see your version history.

Special Notes

Important Note on OpenGL
Due to the fast rate at which OpenGL card manufacturers release drivers, Boris Red may 
disqualify your OpenGL hardware erroneously. If this happens, you should try to enable 
OpenGL to see if you benefit from OpenGL acceleration. If you have troubles with slowness, 
or render inconsistencies, please disable OpenGL. For information on enabling OpenGL, see 
Enabling OpenGL.

While OpenGL may work in the Boris Red standalone, that does not necessarily mean it will 
work inside your host application. 

Boris Red will make every effort to continue to qualify OpenGL cards and driver versions. 
However, it is important to note that it is impossible to qualify all combinations of OpenGL 
cards, operating system, drivers and host applications. In general you should run the latest 
supported driver available for your OpenGL card.
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Configuring Dual Monitor Systems
On dual monitor systems, use the following instructions to correctly configure your video 
display board. Otherwise, system instability may result.

1. Right-click on the Desktop and choose Properties from the menu that appears.

The Display Properties window opens.

2. Click the Settings tab.

3. In the Settings tab, click the Advanced button.

4. Click the tab with the name of your card on it.

The nView window appears.

1. On the left side of the window, select nView Display Settings.

2. On the right side of the window, choose Dualview from the nView Display Mode menu.

3. Next, on the left side of the window, select Performance & Quality Settings.



Boris Red 4 ReadMe

474 

4. On the right side of the window, select 
Hardware acceleration from the Settings list.

5. Set the Hardware acceleration slider to Multi-
display compatibility mode, the middle 
setting.

6. Click the OK button.

7. Click OK in the Display Properties window.

Dual Monitor Limitations with OpenGL
Due to an issue with the NVidia card, Boris Red crashes if you are running the application on 
a dual monitor system with OpenGL. If you plan on using your Boris Red plug-in on a dual 
monitor system, you need to do one of the following:

•   With OpenGL enabled, you must display the Composite window on the left-hand 
monitor.

•   If you want to display the Composite window on the right-hand monitor, you must 
disable OpenGL.

With OpenGL enabled:

•   The system default displays the Composite window on the left-hand monitor. If it’s 
on the right-hand monitor, click and drag the Composite window to the left-hand 
monitor.

To disable Open GL from the Preferences dialog box:

1. From Boris Red, select Edit > Preferences.

2. Click the Render tab.

3. From the OpenGL Acceleration menu, select Off.

You can then display the Composite window on the right-hand monitor.

To disable Open GL from the Preview menu:

•   From the Composite window, select Preview > OpenGL Mode > Off.

This disables OpenGL. You can then display the Composite window on the right-hand 
monitor.
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Checking your OpenGL Hardware, Software, Drivers and Settings
The first time you launch Boris Red, an internal test is run on your system to determine 
whether your hardware meets the minimum requirements necessary for OpenGL Hardware 
acceleration. If your hardware does not meet the minimum requirements, OpenGL is 
disabled by default on your system. 

1. To perform the OpenGL Hardware test manually, click the Test OpenGL Hardware button 
in the Preferences window’s Render tab.

Depending on the amount of memory your graphics card has, this test may take a few 
minutes to run.

After the test is run, a window displays specifics of the hardware and drivers installed on 
your system which are necessary to run OpenGL. If any test results show your system 
may have problems running OpenGL, the errors are detailed in this window. 

2. If you want, click the Copy to Clipboard button to copy this information to your system 
clipboard. This allows you to print or e-mail this information. 

3. When you finish, click OK to close this window.

Depending on your system, the test may take a few seconds to complete. The test 
stresses your OpenGL hardware, so you should run the test with a typical workload on 
your system. Before you run the OpenGL hardware test, open any graphics applications 
that you usually run while you edit (any graphics intensive applications you are running 
at the time may affect the results).

Boris Red uses the following guidelines for optimal OpenGL performance. Some of this 
information does not affect Boris Red’s hardware testing but is useful for technical support 
if you are having OpenGL problems:

•   Graphics Card - For information, go to www.borisfx.com.

•   OpenGL version - Should be 1.2 and higher.

•   Texture Rectangle - This is an advanced OpenGL image sizing feature. If you are 
having OpenGL problems, this provides useful information for technical support.

•   Texture Memory - Texture Memory displays the amount of memory on the video card 
available for Boris Red to use for textures (layer images).To use Boris Red without 
display or performance problems, Texture Memory must be at least 32MB. Texture 
Memory available is not the absolute of memory on your card, but rather the 
amount available to Boris Red.

•   Texture Dimension displays the maximum texture size that can be used with the 
video card.

http://www.avid.com
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Macintosh OS Version displays the installed version of the Macintosh OS (if you are 
running on a Macintosh system.) Macintosh users must have at least Macintosh OS 
10.2.6 installed to support OpenGL. 

OpenGL Errors
When the OpenGL Hardware Test is run, error messages may display if your system fails. 
These errors display as Hardware Status errors or Critical Testing errors. 

Hardware Status errors report the status of your current system setup against Boris Red’s 
recommended card manufacturer, model and driver. These errors do not prevent you from 
using OpenGL, they just warn that your specific system and setup may cause problems with 
OpenGL. Hardware Status errors can include messages such as insufficient available texture 
memory or reports that your card was not recognized by Boris Red’s internal hardware 
testing. When you receive a Hardware Status error, OpenGL is automatically disabled when 
you launch Boris Red. However, you can manually enable OpenGL in the Boris Red 
Preferences window. 

Critical Testing errors report errors that will not allow you to use OpenGL in Red. When you 
receive a Critical Testing error, OpenGL is automatically disabled when you launch Red. If you 
receive a Critical Testing error, you should not enable OpenGL or you may crash. Certain 
errors are influenced by the display properties set on your video card. The display property 
settings are card-driver specific. As a general rule, the display properties should be set to 32 
bits of color, with the depth buffer set to at least 16 bits. On many cards the OpenGL 
capabilities are reduced when higher display resolution and refresh rates are set.

Enabling OpenGL
You can enable OpenGL in the Preview menu or in the Preferences window.

•   To enable OpenGL in the Boris Red Preference window, choose Edit > Preferences 
(Windows) or Boris Red > Preferences (Macintosh). Click the Render Tab and select 
the Accelerated Draft Preview checkbox. Choose the appropriate choice from the 
OGL Acceleration menu. On, Max. texture caching provides the best performance 
and is the recommended setting.

•   To enable OpenGL in the Preview menu, choose Preview > Open GL Mode. Choose 
the appropriate choice from the submenu. On, Max. texture caching provides the 
best performance and is the recommended setting.
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Troubleshooting OpenGL Issues
To toggle OpenGL off, use the keyboard shortcut Command or Control-[. To turn it back on, 
the keyboard shortcut Command-] (Macintosh) or Control-] (Windows). Menu choices also 
appear in the Preview menu and in the Preferences window. You can still use Boris Red 
without OpenGL or with an older card, you just won’t gain as much acceleration.

Display problems such as white, rainbow or garbage images in the Composite window may 
be related to OpenGL. If this occurs, open the Preference window. In the Render tab, change 
the OpenGL Acceleration menu to use less texture caching. Texture caching is used for 
textures (layer images) and is related to the amount of Texture memory on the video card. 
Display problems related to OpenGL will not affect your rendered effects.

NOTE: If you experience OpenGL problems, setting the OpenGL Acceleration menu to 
use less texture caching improves OpenGL reliability, although it lessens 
OpenGL performance.

Displaying Frames on your External Monitor
Commands in the Preview menu allow you to set the video display. 

When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor is 
enabled and the following three options in the menu become available:

•   When you choose Auto-Update Monitor from the Preview menu, every frame of your 
effect previews to the external video monitor. This allows you to drag the CTI in the 
timeline and view updating frames. The image displays on the external monitor, 
using the Resolution and Quality settings specified in the Composite window.

NOTE: Enabling Auto-Update Monitor slows Boris Red since every frame updates in 
the external monitor. Also, OpenGL Acceleration is disabled in the Composite 
window when you enable Auto-Update.

•   When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite window, 
the current frame displays on the external monitor, using the Resolution and Quality 
settings specified in the Composite window. 

•   When you choose Display HQ Frame to Monitor from the Preview menu, the image 
displays on the external monitor, using Full Resolution and High Quality settings, 
regardless of the Resolution and Quality settings in the Composite window. 
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Disconnecting Preview to Monitor (Standalone) 
When you relaunch Boris Red, the external monitor is not connected until you choose 
Connect to External Monitor in the Preview menu. 

Tips for Using the Preview to Monitor Feature (Standalone) 
•   Preview to Monitor automatically disconnects when you exit Boris Red. This means 

each time you launch Boris Red, you need to choose Preview > Connect to External 
Monitor in order to reconnect and see your image on the external monitor. 

•   Displaying images on an external monitor requires compressing and resizing the 
images. Boris Red may run slower if you have Auto Update enabled. Deselect Auto-
Update Monitor in the Preview menu to remain connected to the external monitor 
but not automatically update frames. 

Manually update frames to your external monitor by choosing Preview > Display Frame 
to Monitor, or Preview > Display HQ Frame to Monitor, or by pressing the Display Frame 
to Monitor button on the upper-right corner of the Composite window. 

Installing and Using Adobe After Effects Filters within Boris Red
Boris Red provides a supported list of AE filters for use inside Boris Red. For best results, use 
only supported AE filters inside Boris Red. 

NOTE: Supported filters were tested on single-processor machines. While these 
filters should also work in multi-processor machines, it is possible you will 
experience unexpected results or your machine may crash. If you have 
problems with supported filters in multi-processor machines, try disabling the 
MP functionality on your machine and recreating your filter effect.

Important Information on Using After Effects Filters
•   Checkboxes and menus cannot be animated. 

•   Time remapping filters do not work in Boris Red.

•   After Effects filters used inside Boris Red might take longer to render than most 
Boris Red effects.

•   None of Adobe's built-in After Effects filters work inside Boris Red.

•   Some of the After Effects filters need to be frame rendered. If renders appear noisy 
or jittery, deselect the “Better Quality Field Rendering” checkbox in the Boris Red 
Preferences window and re-render the effect.

•   If you have more than 900 filters installed in Boris Red, you will not see some filters. 
If you reach the filter limit, when you launch Boris Red a warning asks you to remove 
some files from the Plugins folder and restart Boris Red. You can ignore the warning 



Special Notes

479

dialog and continue to work but you will not have access to all the AE plug-ins inside 
the Plugins folder. You can use the Plugin Filter Manager to hide the filters you don’t 
need. See “Creating Effects “in the Help for more information on using the Plugin 
Filter Manager.

Important Information about Exporting to Flash
Boris Red exports Flash .swf files that are compliant with the Flash 5 architecture. If you are 
using QuickTime to preview your exported .swf files, you need a version of QuickTime that 
supports the Flash 5 format. The following effects are supported for exporting to Flash.

•   Text

•   Spline media

•   2D Charts (which consist of text and spline shapes)

Other bitmap elements such as video or still graphics can be included in the exported Flash 
file and will be JPEG-compressed. In the Export preferences you can set the quality of the 
JPEG compression. 

NOTE: When you export text to Flash, any texture that was applied to the text is 
ignored.

NOTE: When you export text with a gradient fill to Flash, the resulting .swf file is blank.

Exporting as Flash
Boris Red allows you to export files in the Macromedia Flash (SWF) format. This feature 
allows you to export compositions as compact, vector-based files optimized for web viewing. 
For example, you could export a Type On effect to include on a web page.

The SWF format was designed primarily for animated 3D Line Art objects, so it works well 
when exporting settings that contain spline and text animations. Settings that contain video 
or animated bitmaps, however, generate rather large files. You might want to consider 
exporting such animations as a QuickTime or AVI file. 

See “Exporting Effects as Movies” in the Help for more information. 
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There are some limitations with the Flash export feature. You cannot export 3D Extrusion 
tracks as Flash. Settings that contain the 3D Extrusion tracks export as a blank track. The 
Flash export feature does not support shadows or gradients used as Texture tracks. However, 
you can export a static gradient as a bitmap background. 

NOTE: To prepare to export to Flash, you should change any shape track containing 
EPS files, text, or Spline media to 3D Line Art shape. Because you cannot use 
the 3D Line Art shape with the Brush tool, you cannot export brush strokes as 
Flash.

To export a track as a Flash file:

1. Select the appropriate track in the timeline.

2. Choose File > Export > Flash.

A dialog box appears that allows you to name and save the file.

3. Name the track and click Save.

The composition is exported using the Flash Export settings, which are controlled by the 
Preferences window’s Export tab. For more information, see the Help.

Creating Time Effects within Boris Red
The following important notes pertain to Time filters, including Optical Flow.

•   Exporting an effect containing a Time filter (including Optical Flow) with host media 
is NOT recommended. If you want to export from Boris Red with Optical Flow (or any 
Time filter) in the timeline, you should use imported media in the source track.

This is because Boris Red does not receive both fields at set-up (preview). In that case, 
the first field of each frame goes into the motion estimator. If the motion is small from 
one frame to the next, and/or includes little crossing motion, the preview appears close 
to the rendered output. However, if the motion is large, and/or includes a lot of crossing 
motion, it is important for the motion estimator to have access to both fields in order to 
see an accurate preview of the rendered result.

Important Information about Working with Motion Filters
•   You should use the Snap CTI to KeyFrame option (Track > Snap CTI to KeyFrame) 

when working with the Motion filters to avoid confusion. For example, this option is 
not selected and you move the CTI off a selected keyframe. Then you adjust the 
Search and Target parameters using on-screen controls. A new keyframe is not 
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created. Instead, the selected keyframe is adjusted. This could cause your media to 
track incorrectly. If you want to create a new keyframe, you must deselect all 
keyframes before adjusting parameters on-screen.

•   While Interpolation Fields appear next to the Search/Target tab parameters, you 
should not adjust the Interpolation. Leave the Interpolation set to Hold. Adjusting 
the Interpolation will not affect the tracking but may cause on-screen parameters to 
display incorrectly.

•   You can work at Half or Quarter Resolution to achieve a preview of a motion filter. 
But if the motion tracker fails repeatedly, you may have to work at Full Resolution.

•   You can only adjust the Search and Target regions in the Motion filter track's Preview 
window. The Source track does not display the region controls; the Composite 
window does not display the region controls.

•   The field order of the media must match the field order setting in the Media tab. You 
can set this in the Import tab in the Preferences window. See the Help for more 
information.

Important Information Using the KeyFrame Library
The first time you browse the KeyFrame Library effects within the Library Browser you must 
generate thumbnail images for the effects. 

1. Open the Boris Red Library Browser, by choosing Window > Library Browser, clicking the 
Open Library Browser button in the timeline or pressing Control-9.

2. Select an effect or effect folder and click the Generate Thumbnails button. For more 
information on using the KeyFrame Library, see the Help.

NOTE: We recommend that when you build thumbnail previews for the KeyFrame 
Library, you do this in the Boris Red standalone application. Because building 
previews actually renders your effect, this process can take as much as 25-
30% longer in the plug-in than in the Boris Red standalone application.

Keyboard Shortcuts 
The Keyboard Shortcuts is available from the Help or on the Online Library DVD.

New Modifier Keys for Dial controls
When using the mouse on dial controls, you can now use the following modifiers:

•   Press the Shift key to round the marks on the dial controls to the nearest 45 degrees.

•   Press Control to round the marks on the dial controls to the nearest 10 degrees.
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•   Press Shift-Control to round the marks on the dial controls to the nearest 5 degrees.

•   Press Shift-Control and use the mouse wheel to round the marks on the dial controls 
to the nearest 45 degrees.

When tracking with a mouse wheel on dial controls, you can use the following modifiers:

•   Use the mouse wheel with no modifier keys to move the dial controls in 1 degree 
increments.

•   Press the Shift key and use the mouse wheel to round the marks on the dial controls 
to the nearest 10 degrees.

•   Press Control and use the mouse wheel to round the marks on the dial controls to 
the nearest .1 degrees.

Fixed Bugs
The following limitations have been fixed since the last release of Boris Red.

•   The PixelChooser mask no longer renders into final rendered effects.

•   You no longer need to deselect the Shape control in the Composite window’s 
Controls menu to directly manipulate an object’s Mask controls. 

•   Moving a track with nested media up or down in the timeline no longer causes the 
track to open and display all of its subtracks. 

•   In the 2D Particles filters, custom shapes do not truncate anymore.

•   Particles are now visible in the first frame of a preview. 

•   The shortcut for changing color channels to RGB is now labelled correctly. 

•   Render problems do not now occur when you enable a Bump Map for a Spline Object 
or Spline Primitive track in a 3D Model Container. 

•   The Path controls can now adjust multiple selected splines. 

•   When a spline style from the Style Palette is applied to a spline primitive shape, the 
shape does not now reset back to the default shape value. 

•   The Date format Day/Month/Year in the Date/Time generator does not now display 
a comma at the end if you have suppressed the time display. 

•   When Top-Down text is selected, the Text Wrap menu setting is no longer ignored. 

•   Text on a Path moving from right to left will no longer display upside down. 

•   Text Radial edge widths over 18 points no longer appears strange in characters like 
“o” and others with centers. 

•   When both the Reveal and Remove checkboxes are enabled in the Animation tab, 
Position X now animates when you work with extruded Bar and Pie Charts. 



Known Limitations in Red 4

483

•   Removing an extruded Bar Chart by selecting the Reveal Shape checkbox in the 
Animation tab now works correctly.

•   The Animate button can now be in static mode when working with Charts. 

•   When working with a Line Chart in Full Resolution, small nicks or indentations no 
longer appear in the lines. 

•   When you apply a BCC Colorize filter as a standalone filter to the timeline, the 
gradient bar no longer displays black instead of showing colors. 

•   The final render of an Optical Flow effect that is applied to host media now renders 
correctly. 

•   When the default interpolation is set to Constant in the keyframe options palette, 
and a Motion Tracker filter is added to the timeline, resetting the default 
interpolation in the keyframe options palette no longer results in no keyframes 
being generated for the Motion Tracker when you move the tracker target/region. 

•   If you select a preset in the Match Grain filter, the preset name now appears in the 
control. 

Known Limitations in Red 4
Boris Red 4 includes the following known limitations:

General Limitations
•   Still image media does not reload automatically, and you need to use the 

Files>Reload command to update a re-imported still image file that has been 
changed. 

•   You need to deselect the Shape control in the Composite window’s Controls menu 
to directly manipulate an object’s Crop controls. 

•   The text window will only update the text with changes made to the control window 
(such as Margin, Wrap, or Font) when you press the update button in the text 
generator window or close the text generator window.

•   Changes to the controls text window are ignored if the text generator window is open.

•   When cell is set in the Apply To pop-up, none of the changes in the animation tab 
will have an effect on bar charts although the numbers in the numeric entry box 
change to show the animation.

•   Default interpolation is set in the keyframe options palette, not the preferences 
window.

•   When OGL is enabled and you re-enter an effect, the resulting image appears white 
in the Composition window. To change this, press Control + [. This disables the OGL 
preview and revrts to non-OGL mode. 
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•   The Motion Blur button is a global preference. That means that, when you render, all 
settings respect the last setting of this checkbox in the UI. This is not a bug, but can 
be confusing when you render multiple effects in the Render Queue. 

•   If you tumble an object that has an image bump map (such as a movie or still image 
file), you may see a moire pattern as it tumbles. 

•   If you reopen a saved setting where you previously changed the color of a border or 
gradient using the eyedropper, in some instances the color has reverted back to its 
original color. 

•   Paint strokes will not be removed by the Eraser brush when working over a 
transparent background and Eraser Mode is set to Strokes Only.

•   When you save a style to the Materials tab in the Style Palette, it does not correctly 
save the Source type that was used in the Bump Map tab. 

•   The V key in the new Color Preview feature does not work to commit to a color. You 
can use the C key to dynamically preview colors, but you cannot use the V key to 
commit to them. Click the mouse instead. 

•   If you import files into Boris Red that were created in Adobe Illustrator version 9, they 
display as transparent. Save the file in Illustrator version 8 instead. 

•   When you search for a missing media file using the Search button in the Media Files 
window, it may not find files that were moved to another local drive. Manually 
browse to the new location of the file and press the Replace button. 

•   Tracks containing PSD files that have been converted to containers do not correctly 
update if you modify them (for example in Photoshop) and then use the Reload Files 
command. 

•   Files exported to Flash from Boris Red cannot be used in Macromedia Flash 
authoring applications such as Flash MX. 

•   If you use the Keyframe Time field in the timeline to move keyframes, all keyframes 
that a moving keyframe passes are merged to it. Instead, move keyframes past one 
another by dragging the mouse. 

•   Photoshop (.psd) files with adjustment layers display incorrectly in Boris Red if you 
convert their track to a container. Turn off any adjustment layers in Photoshop 
before importing .psd files if you plan to use the Convert to Container command. 

•   Resuming a partial render of an exported QuickTime file may have some undesirable 
side-effects. In particular, video compressed with codecs that use frame-
differencing and data-rate-limiting (such as Sorenson or Cinepak) may exhibit some 
of the following behavior during playback. 

•   Some frames following the resume point may be corrupted. The data rate may be 
slightly larger than expected. Also, if the file includes an audio track, a slight blip 
may be heard at the resume point. This may occur with any codec. 
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•   If you use Frame-Differenced movies in Boris Red (including movies compressed 
with Apple’s QuickTime Animation codec, and some movies compressed with 
Sorenson), you will see reduced performance. The use of Frame-Differenced 
movies is not recommended within Boris Red. 

•   When field media is exported or previewed as frames, only the first field is used. 

•   Using non-square pixel aspect ratios (i.e. 720x480) can distort the EPS media type 
when used with the 3D Plane Shape. Use the 3D Line Art shape instead. 

•   Any effect that uses a filter involving edge detection (for example, RGB Edges) should 
be rendered with the Better Quality Field Rendering checkbox selected. Otherwise, 
the rendered effect will jitter. 

•   Balance and Volume controls have no effect on audio tracks containing AVI files or 
MP3 files. 

•   Boris Red exports Flash.swf files that are compliant with the Flash 5 architecture. If 
you are using QuickTime to preview your exported.swf files, your QuickTime version 
must support the Flash 5 format. Older versions of QuickTime display the 
background as a solid color. 

Limitations with Keyboard Shortcuts
•    The shortcut for hiding marks is listed as (CTRL+ALT+’), however the shortcut does 

not work. Use the menu choice in the Preview menu, or create your own shortcut in 
the Keyboard Shortcuts window instead. See the Help, for more information on 
creating shortcuts.

•   After creating new keyboard shortcuts, certain items in the Windows menu may 
show duplicate keyboard shortcuts (for example, the Filter Palette and Media Files 
window display the same keyboard shortcut). You can assign new shortcuts in the 
Shortcuts window. See the Help, for more information on creating shortcuts.

Limitations with the Spline Object Media Type
•   The Reverse Keyframes command (Track > Reverse Keyframes) does not work in 

Spline effects. 

Limitations with Text Features
•   When using Kanji text, the underline option overlaps certain characters, depending 

on their size. 

•   Tracking controls the global horizontal spacing of the characters in an effect. 
Tracking behaves differently depending on whether the text was created with the 
Text tool or in the Text window. When you create text with the Text tool, the tracking 
honors the justification that is set in the Transform tab. When you create text in the 
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Text window, the tracking is applied with center justification. To track to the right or 
left using text that was created in the Text window, select the text with the Text tool 
and move it slightly. Then set the justification in the Transform tab. The Tracking now 
uses the justification. For information, see the Help.

•   Importing RTF documents using the Insert Text feature in the timeline’s contextual 
menu will cause all tab delimited text to appear on the first line in Boris Red, rather 
than in multiple lines. You will need to manually insert line breaks. 

•   If you Flip an image vertically and then render it through the host, the rendered video 
appears jittery. Enable the “Better Quality Field Rendering” checkbox to render 
correctly.

Limitations with Chart Features
•   Accented letters such as é are not passed from the Chart Editor to the Chart 

Container correctly. Therefore, a Chart Legend or Grid label that uses accented 
characters must be entered directly into the text track, using the Text tool or Text 
window. If this is necessary, it must be done as a final step when building the chart. 
This is because editing the chart data or enabling/disabling the Legend or Grid 
updates this text using Chart Editor text; as a result, the accented characters will be 
lost.

•   On certain systems, extruded pie charts pieces may incorrectly display their corners. 
Reduce the Bevel to 0 to fix this.

•   If you have long names for the X axis (defaults: South, East, West, and North), and 
you are animating the chart the names will not line up with the actual chart.

•   Selecting the “Apply Current Spline Style” checkbox can create unintended changes 
if the setting is modified after another spline style is selected. For example, you 
create a static Line chart setting with the “Apply Current Spline Style” checkbox 
selected. You apply another spline style from the Style Palette to a different track. 
If you then animate the chart, the chart will update with the latest spline style, 
rather than the style originally applied. The workaround is to reapply the original 
spline style from the Style Palette.

Limitations with Filters
•   The Fire filter renders with the fields reversed unless you render it with Better Quality 

Field Rendering enabled.

•   In the Fire filter, when using text as a Map layer, the size of the text is ignored and 
will frequently display garbage. Map text to a Shape, then nest the shape layer 
inside the Fire filter to correct this problem. 
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•   Some filters create effects that evolve over time based on parameter settings. The 
output of these filters (for example Velocity Remap, Particle System, Comet) 
depends on the parameter values for the entire effect; changing a parameter value 
on any frame changes the output for all subsequent frames. If the animation jumps 
after changing a parameter, the jump is probably because Boris Red did not 
invalidate frames that were affected by the change. You can fix this by choosing Edit 
> Purge Frame Cache, and previewing again. Your rendered output does not use the 
cached frames, so even if you forget to purge the frame cache, your final render 
appears correctly.

•   Time filters always use the first field of fielded media when frame rendering or 
previewing.

•   The Motion Tracker Filter’s Analyze button won’t analyze the total length of the effect 
if a movie’s length is shorter than the duration of the effect and the movie is set to 
Loop. 

Limitations with BCC Grain Filters
•   The grain filter presets do not store the grain sample, only the filter settings. If you 

load a Match Grain preset and want to use a stored grain signature, you have to load 
that as well. If you load a DeGrain preset with the “Lock Sample” checkbox enabled, 
Boris Red will not acquire the sample. 

•   The BCC DeGrain and Match Grain filters can only be used when the Boris Red 
Composite window is set to Full Resolution. If you are not in Full Resolution, an error 
message warns you to set the Composite window to Full resolution. If you do not set 
the Composite window to Full Resolution, a red “X” will display in the sample box.

Registration
Make sure to register your product in order to receive the latest technical and upgrade 
information. 

You can register either by filling out the registration form online at: 
http://borisfx.com/support/register.html or by sending us your completed registration card. 

We offer registered users one year of free technical support starting from the date of 
purchase.

Contacting Technical Support
For technical support, contact Boris RED technical support specialists:
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web: http://www.borisfx.com/support/
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