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Introduction

 

Welcome to Boris Red 3.0.2. These Release Notes contain information regarding supported 
hosts, hardware and operating systems, known limitations, and other important 
information about the product.

For information on installing Boris Red 3.0.2 into your host application, see the Installation 
Guide pdf file.

For information about Boris Red software updates, other Boris products, and additional 
resources, visit our web site at www.borisfx.com.

 

What’s New in 3.0.2

 

Red 3.0.2 is a maintenance release to Red 3.0. It replaces Red 3.0.1 which was also a 
maintenance release. Several new features and updates have been added to Red 3.0.2 since 
Red 3.0 including the following. 

See the separate 

 

Red 3.0.2 New Features.pdf 

 

document for explanations of all of the new 
features introduced in Red 3.0.2.

 

Localization

 

Beginning with version 3.0.2, Red is localized in several languages – English, French, 
German, Spanish, Italian, Japanese, Chinese and Korean. Red installs a Boris Language Pack 
file which reads the system language specified on your system and translates its menus into 
that language, if it is supported. Localization should be automatic and requires no work on 
the part of users. 

The Boris Language Pack file is located in the following location.

 

Macintosh

 

Library/Application Support/BorisFX/Boris Language Pack.ecs

 

Windows

 

<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs

 

You can edit the Boris Language Pack files with the Boris Localizer standalone 
application. See “Editing Language Pack Files with the New Boris Localizer” on 
page 3 for details.

 

Editing Language Pack Files with the New Boris Localizer

 

Red version 3.0.2 introduces the Boris Localizer. The Boris Localizer is a standalone 
Mac OS X application used to update the translation or localization of the Red interface into 
one of eight supported languages. Use the Boris Localizer to edit Boris Language Pack files 
which contain translations of Red menus and parameters into various languages. The Boris 
Localizer is available through your reseller.
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Contact your reseller for more information on using the Boris Localizer to edit the 
default Red translations.

 

New Library Browser Template Mode

 

You can now use the Library Browser in a special Template mode. The Boris Library 
Browser allows you to quickly preview and apply settings files from the KeyFrame Library, 
including settings files that you add or customize. The KeyFrame Library is a collection of 
preset effects that is automatically installed on your system when you install Boris Red. You 
can add, remove, or change these settings files at any time. 

Template mode allows you to use the Library Browser to create effects. This mode is most 
useful when creating text effects or when repeatedly applying the same preset. When you 
are in this mode, you simply replace the text for the selected effect template.

When you select the 

 

Show Only Browser checkbox

 

 in the Preferences window, only the 
Library Browser appears when you work in the Boris Red user interface. This feature is only 
available when you use Boris Red as a plug in. It is not available in the Red Engine.

 

1.

 

Access the Preferences window by choosing Edit > Preferences (Windows) or Boris Red 
> Preferences (Macintosh).

 

2.

 

In the Appearance tab, click to select the 

 

Show Only Browser checkbox 

 

and click 

 

OK

 

 to 
apply your changes. Now, only the Library Browser appears when you work in the 
Boris Red user interface. 

 

3.

 

When you are in Template-only mode, the Library Browser is the only window 
that appears. You can also enter this mode by choosing Window > Library 
Browser or clicking the 

 

Open Library Browser button

 

 in the timeline.

Double-click to edit 
the translation
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4.

 

Click the name of any folder in the Available Categories window. Thumbnail images of 
each effect in that folder appear in the Available Effects window.

 

5.

 

Click any thumbnail image to select the effect. A red box appears around the selected 
thumbnail. Press 

 

Play

 

 to view an animated RAM preview in the Preview window. 

 

6.

 

Click the appropriate Template-Mode control to edit your template.

 

•

 

Clicking the yellow 

 

Template Mode

 

 

 

button

 

 allows you to toggle in and out of 
Template mode without opening the Preferences window. When you are not in 
Template mode, this is the only control that appears in the Library Browser. 

 

•

 

Clicking the red 

 

Insert Text button

 

 allows you to type text into the Comments 
window. This text replaces the placeholder text that is included in the thumbnail. 
To replace multiple lines of text, press 

 

Tab

 

 between each line. 

 

•

 

Clicking the green 

 

Replace Comments button

 

 allows you to type comments into the 
Comments window. This text replaces the existing comments. 

 

•

 

Clicking the blue 

 

Retrieve Comments button

 

 allows you to retrieve comments into 
the Comments window. Click this button if you have inserted text into the 
comments window and now want to view the associated comments. 

Selected effect.

Available Categories
window. Click a folder
name to preview the
effects in that folder.

Animated preview of
selected effect

Link to Boris 
FX website.

Effect comments

Quality, Preview, and
Effect buttons

Source Folder menu

Template-mode
controls

Retrieve Comments

Template Mode Replace Comments

Insert Text 
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7.

 

Click the 

 

Load Effect button 

 

to save the currently selected effect.The effect is 
applied, Red closes and you are returned to your host application.

In the following example, the text from the 

 

JitterHue.red

 

 setting in the previous 
example was replaced with the words 

 

Anne’s Jitter

 

. To replace the text, the effect was 
selected, the red Insert Text button was clicked and the new text was entered into the 
comments window.

 

New Preferences

 

A new Appearance tab has been added to the Preferences window. The Appearance tab lets 
you set display options for the Boris Red user interface. 

You can access the Preferences window by choosing Edit > Preferences (Windows) or Boris 
Red > Preferences (Macintosh).

New Text

Template-
mode

controls

Preview of
selected

effect

Selected
effect
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Appearance Tab

Common Background Colors

 

These options allow you to customize the colors used in the Boris Red user interface. This is 
a new feature in Boris Red 3.0.2. 

Click the color chip to open the system color picker and choose the desired color.

 

Windows

 

 

 

sets the color of the background for all windows in the Boris Red user interface.

 

Text

 

 

 

sets the color of the text in all windows in the Boris Red user interface.

 

Timeline Colors Options

 

These options allow you to customize the colors used in the Boris timeline tracks. In 
previous versions of Boris Red, these options appear in the Preview tab. 

Click the color chip to open the system color picker and choose the desired color.

 

Background

 

 

 

sets the color of the timeline background.

 

Selection

 

 sets the color of selected tracks in the timeline’s track controls (the left side of the 
timeline).

 

Keyframe

 

 sets the color of keyframes.

 

Shape Track

 

 

 

sets the color of Shape tracks on the right side of the timeline.

 

Media Track

 

 

 

sets the color of the Media tracks nested inside Shape tracks.
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Container Track

 

 sets the color of 3D Containers and Title Containers.

 

Filter Track

 

 

 

sets the color of filter tracks on the right side of the timeline.

 

Library Browser

 

When you select the 

 

Show Only Browser checkbox

 

, only the Library Browser appears when 
you work in the Boris Red user interface. For more information on this new features, see 
“New Library Browser Template Mode” on page 4.

 

Plug-Ins and Library Browser Now Accept Aliases

 

The Red Plug-Ins folder and Library Browser now accept aliases to plug-in and effect files 
and folders on your system and will follow them to the original file or folder.

 

Aliases in the Library Browser

 

If you place an effect alias or shortcut to a folder or file in the Library Browser, Red will now 
follow it to another folder or file, as if that folder were where the alias or shortcut is placed.

 

Aliases in the Plug-Ins folder 

 

If you place an alias or shortcut to a folder or file in the Red Plug-Ins folder, Red will now 
follow it to another folder or file, as if that folder were where the alias or shortcut is placed. 

The Boris Red Plug-Ins folder is found in the following location:

 

Macintosh

 

<Drive>:Library:Application Support:BorisFX:BorisPlugins

 

Windows

 

c:\Program Files\Boris FX,Inc\BorisPlugins\

 

This means that you no longer need to make copies of your plug-ins, since you can now 
keep centrally located plug-in set(s). For instance, if you already have a copy of BCC 3 in 

 

Application Support:BorisFX:Lib:BCC3BitDepthSupport

 

, you only need place an 
alias/shortcut to that folder inside the BorisPlugins folder. 

Red currently only supports 8-bit plug-ins. Placing an alias or shortcut to 16-bit 
plug-ins in the Boris Plugins folder will cause undesirable results.
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Improved Support for Third Party After Effects Plug-Ins

 

Red 3.0.2 expands support for third Party After Effect plug-ins inside Incite. For best results, 
use only supported AE filters inside Boris Red. Current additions to this list can be found 
on our web site: www.borisfx.com. 

For information on installing and using third Party Plug-Ins, see “Important 
Information on Using After Effects Filters” on page 39 and “Installing AE Filters 
for Windows” on page 39.

Most of the unsupported filters will not appear in the Red Filter menu even if they 
are installed, or will display an error message when you apply them.

 

Buena Software

 

•   

 

Dissolve Factory

 

•   

 

Effect Essentials*

 

*Note: 

 

The following Buena Effect Essentials filters are not supported: 

 

Feedback, 
HSV Curves, HSV MAnipulator, Super RGB Curves

 

.

 

Conoa

 

•   

 

Conoa 3Dr

 

•   

 

Easy Shapes

 

•   

 

SuperPak

 

*Note: 

 

You must use the AE 4.0 versions of Conoa filters with Boris Red. Later 
versions will not work.

 

Cycore

 

•   

 

Cycore FX HD*

 

*Note: 

 

The following Cycore FX HD filters are not supported: 

 

all Time Filters, 
Composite, Environment, Split 2, Repetile.
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DigiEffects

 

•   

 

Aurorix

 

•   

 

Beserk

 

•   

 

Cinemotion*

 

•   

 

Delerium**

 

•   

 

Fantasm***

 

*Note: 

 

Cinemotion Film Motion effects do not work in Red.

 

**Note: 

 

The following DigiEffects Delerium filters are not supported: 

 

Channel 
Delay, Fireworks, Fairy Dust, Film Flash, Muzzle Flash

 

.

 

***Note: 

 

The following DigiEffects Fantasm filters are not supported: 

 

Color by 
Number, Shredder, PixxyUnstripe, PixxyAudio.

 

Digital Anarchy

 

•   

 

3D Layer

 

•   

 

Color Theory

 

•   

 

Geomancy

 

•   

 

Gradient

 

•   

 

Psunami Water

 

•   

 

Retimer SD and HD

 

•   

 

Anarchy Toolbox*

 

*Note: 

 

The following Anarchy Toolbox filters are not supported: 

 

Anarchist Edge, 
Color Sampler, Gradient Path, Path Distort, Resizer.

 

Digital Film Tools

 

•   

 

Digital Film Lab

 

•   

 

zMatte

 

•   

 

Composite Suite*

 

•   55 mm**

*Note: The Frame Averager Composite Suite filter is not supported.

**Note: Red supports version 55 mm version 2.0 only. Versions 3.0 and 4.0 are not 
supported.
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The Foundry

•   KeyLight

•   TinderBox 1, 2, 3*

*Note: The following Tinderbox filters are not supported: T_PseudoColour, 
T_Blob, T_Grad, T_Sky, T_Plasma, T_Glow, T-MeltTime, T_Trail, 
T_MotionDetect.

FreshLuft

•   flAIR

Panopticum

•   Camera Noise

•   Compare Mask

•   Engraver

•   Rulers

•   Plugin Galaxy

Profound Effects

•   Swim

Red Giant Software

•   Knoll Light Factory

•   Image Lizard and Composite Wizard*

*Note: The following Image Lounge and Composite Wizard filters are not 
supported: Video Feedback, Wire&RigRemoval, Denoiser, Hall of Time, Color 
Map, Color Matcher, Brimstone, Clouds, Fire, Tunnel, Text.

Re: Vision Effects

•   Fields Kit

•   Re:Fill

•   ReelSmart Motion Blur

•   Shape/Shade

•   SmoothKit

•   Twixtor Pro

•   Video Gogh
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Synthetic Aperture

•   Color Finesse

Trapcode

•   Shine

•   Star Glow

Walker Effects

•   Professional Edition*

*Note: The following Walker Effects filters are not supported: Alpha Tool, Channel 
Offset, Color Composite, Fast Tracker, Glow, Light Wrap.

New Host and Hardware Specific Features
The following new host or hardware related features have been added to Red 3.0.2.

New Supported Hardware
Red 3.0.2 introduces hardware improvements including the following:

•   The Aja IO board now works with Aja driver version 1.3 and higher. Previously you 
would crash opening the Red Preferences with this board and a driver version earlier 
than 1.3.

•   The Aja Kona II and IO boards installed with the latest drivers (1.3 and higher) now 
allow you to preview out to an external monitor.

Red only supports Aja drivers with the Aja board.

Support for Canopus Edius
Red 3GL now supports the Canopus Edius Pro 3 editing workstation.

Applying Boris Red in Canopus® Edius® 
Canopus Edius allows you to apply Red as a filter and as a transition. Boris Red appears in 
the Edius Effect Palette in both the Video Filters and Transitions directories and can be 
applied the same way you apply any native video effects in Edius. Red works in Edius 
whether or not you have hardware installed.
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Applying Boris Red as a Filter

1. Either drag the Boris Red 3 FL effect from the Effect 
Palette’s Video Effects directory to the appropriate 
clip, or right-click the in the Edius timeline and choose 
Add to Timeline from the menu that appears.

2. Select the clip with Red applied. In the Edius 
Information window, double-click the Boris Red 
3 FL icon to launch Red.

The Red interface opens automatically. You can 
now create or load an effect. 

3. You can also open settings from the Keyframe 
Library or create your own custom effect. When 
you finish creating your effect, press the Apply 
button or Cancel button to either apply the effect 
to Edius or cancel and leave the event or track 
unchanged.

4. Render Boris Red effects the same way you 
would render any other effect. For more 
information, consult the Edius documentation.

Applying Boris Red as a Transition

1. Drag the Boris Red 3 TR effect from the Effect Palette’s 
Transitions directory to a transition in the timeline you 
want to apply Red to. You can apply Boris Red to the 
beginning or end of a clip, or to a transition point 
between two clips.

2. Select the transition in the timeline, and in the Edius 
Information window, double-click the Boris Red 3 TR 
icon to launch Red.

The Red interface opens automatically. You can now 
create or load an effect. 

Double-click to open the Red Interface
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3. You can also open transition settings from the KeyFrame Library or create your own 
custom transition. When you finish creating your effect, press the Apply button or 
Cancel button to either apply the effect to Edius or cancel and leave the event or track 
unchanged.

4. Render Boris Red effects the same way you would render any other effect. For more 
information, consult the Edius documentation.

Preview to Monitor Feature for Avid Systems
Preview to Monitor is now available when using Red as an Avid plug-in on systems running 
Mojo or Adrenaline hardware using Xpress Pro version 4.5 and later, or Media Composer 
Adrenaline version 1.5. Additionally, beginning with Red 3.0.2, Preview to Monitor is 
available to Windows users using the standalone Red Engine on systems running the Mojo 
or Adrenaline hardware.

For more information on Preview to Monitor, see Chapter One in the User Guide.

Enabling Preview to Monitor

To enable the Preview to Monitor feature, launch the Red 3.0.2 Engine and open the 
Preferences window.

1. Choose File > Preferences.

2. Click to select the Preview tab.

3. In the External Monitor Output section, 
choose Avid Hardware from the Device menu. 

The Device menu displays all the supported 
hardware connected to your system.

4. Choose an option from the Mode menu if 
applicable. For example, if you are using a FireWire Converter box, you can choose PAL 
and NTSC formats from the Mode menu.

5. Click OK to save your settings and exit the Preferences window.

The Preview to Monitor preferences are saved and applied to all Red projects 
unless your Red 3.0.2 preference file is rebuilt.

Displaying Frames in your External Monitor

Commands in the Preview menu allow you to set the video display: 

•   When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor 
is enabled and the following three options in the menu become available:
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•   When you choose Auto-Update Monitor from the Preview menu, every frame of your 
effect previews to the external video monitor. This allows you to drag the CTI in the 
timeline and view updating frames. The image displays on the external monitor, using 
the Resolution and Quality settings specified in the Composite window.

Enabling Auto-Update Monitor will slow the Red Engine since every frame is 
updated in the external monitor.

•   When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite 
window, the current frame displays on the external monitor, using the Resolution 
and Quality settings specified in the Composite window. 

•   When you choose Display HQ Frame to Monitor from the Preview menu, the image 
displays on the external monitor, using Full Resolution and High Quality settings, 
regardless of the Resolution and Quality settings in the Composite window. 

Disconnecting Preview to Monitor

To disconnect Preview to Monitor (for example if you want to connect another device to 
your video board while editing with Boris Red), quit Red. When you relaunch Red the 
external monitor is not connected until you choose Connect to External Monitor in the 
Preview menu.

New Compatibility with Avid FX
Like Red, Avid FX reads and writes .red settings and is capable of reading Red or Boris FX 
settings files. However, previous versions of Red did not recognize Avid FX sequences. For 
example, if you created a sequence containing Avid FX effects in an Xpress Studio system, 
then tried to open that sequence in a Symphony system, the effects were not automatically 
recognized.

Because the Avid software is incapable of recognizing two differently named plug-ins as the 
same AVX effect, the two products are not interchangeable. However, Version Red 3.0.2 
offers a method for Red users to read and create sequences with Avid FX effects. When you 
install Red 3.0.2, the AVX 1.5 with Avid FX compatible plugin option installs two AVX 1.5 
plugins, one Red 3GL and one Avid FX. This provides Red users the capability to read and 
create Avid FX effects in their Avid timeline.

Choose Connect to External Monitor 
to display images on the external 
monitor
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Improved Support for Sony Digital Pictures Vegas Video
Boris Red supports Sony Digital Pictures Vegas ™ version 3.0 and later. In Red version 3.0.2, 
the integration with Vegas has been improved with optimizations, bug fixes and the 
addition of several default presets. 

By default, Vegas caches every video frame. This results in effects not displaying 
correctly after re-editing. To disable the Vegas cache, open the Vegas Preferences 
from the Options menu. Click the Video tab and set Dynamic RAM Preview max 
(MB) to 0. 

Improvements to Vegas in Red 3.0.2

•   Mini-timeline removed- The mini-timeline in the Vegas dialog has been removed. 
There were underlying problems with this mini-timeline that could cause Red to crash.

•   Modal window- Red is now a modal window which improves performance inside 
Vegas. This means that when you launch Red, you can no longer toggle back to Vegas 
with Red open. You must apply or cancel out of Red in order to use Vegas again.

•   Faster Rendering of Static Effects- Red 3.0.2 is optimized so that static effects (effects 
that are not keyframed in the Red timeline) render much faster then in Red 3.0. 
Rendering speed increases depend on the complexity of the effect.

•   New Default Presets- Red 3.0.2 includes several new Vegas Video preset files. These 
presets can apply to Red in any context in Vegas Video 5. You can modify these effects 
and save variations as your own custom presets. One new preset, the Alpha Default 
preset provides a way to make Red titles and effects that cut an alpha channel look 
sharp. 

•   Fixed Bugs- Animations longer than one second no longer render twice as fast when 
rendered at Full Quality in interlaced video projects.

Applying Boris Red as a Video Effect

Boris Red appears in the list of available video effects in the Video FX window and can be 
applied as a video effect the same way you apply any native video effects in Vegas.

The Red timeline will not display updated video frames while launched inside 
Vegas. Only the video frame at the cursor location displays in Red’s timeline. This 
limitation of Vegas’s architecture does not impact rendering effects.

1. Drag the Boris Red video effect from the Video FX window to an event or track. The 
Event Effects window opens.

2. Move the Vegas cursor to the first frame of the effect to display the first frame in Red. 
Otherwise the frame at the Vegas cursor location displays in Red.

3. Click the Launch Boris FX Button to open the Red interface and create your effect.
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4. In the Red Timeline window, set the effect duration to match 
the duration of your Vegas effect by typing a new value in the 
Duration field and pressing Enter.

If the Red effect duration does not match the Vegas effect 
duration, the rendered effect in Vegas appears differently 
than when you preview it in Red.

5. Choose Edit > Preferences to open the Preferences window. In the General tab in the 
Preferences window, set the Project Options to match the project size, FPS and aspect 
ratio that you are using in Vegas. Click OK to close the Preferences window.

6. You can now open settings from the Keyframe Library or create your own custom 
effect. When you finish creating your effect, press the Apply button to apply the effect 
to Vegas.

Tips for using Boris Red with Sony Digital Pictures Vegas
•   The frame that Vegas Video passes to Red does not necessarily match the Vegas project 

size. Instead this frame is the same size as the frame displayed in the Vegas Preview 
window. Any Preview window setting will work, but best results are achieved by 
setting the Preview window to Best/Full before launching Boris Red.

•   Vegas only previews a single frame of video in Boris Red. The preview frame is taken 
from the current position of the Vegas cursor. To preview your effect with updating 
source media, exit Red and preview the effect in the Vegas Video timeline. 

•   To preview a Red effect in Vegas, you must first click the Apply button. You cannot 
preview changes in Vegas while the Boris Red user interface is launched.

•   By default, Vegas caches every video frame. This results in effects not displaying 
correctly after re-editing. To disable the Vegas cache, open the Vegas Preferences from 
the Options menu. Click the Video tab and set Dynamic RAM Preview max (MB) to 0. 

For important workflow and notes for Boris Red 3 Vegas Users including several 
methods when using Red for titling and how to use the new default Presets, see 
the separate Red 3.0.2 New Features.pdf document, or Appendix B in the User 
Guide “Working with Host Applications”.

Set the Red duration to 
match the Vegas duration.
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Improved Host Support for IMC Incite
Red 3.0.2 adds functionality to Incite Media and Remote Producer, and adds compatibility 
with the new Container feature in Media and Remote Producer version 3.3.

New Modal User Interface

Boris Red now works modally in Incite. This means that when the Red user interface is 
launched, you cannot toggle back to Incite. You need to apply or cancel out of Red in order 
to use Incite. This new model improves Red’s speed and stability.

Access to 64 Incite Video Tracks

You can now access up to 64 Incite video tracks within Red. To directly access an Incite video 
track within Red, press the Media icon on any track in the Red timeline. Choose the 
appropriate track from the menu that appears.

Import Container Clips in Red (Media and Remote Producer version 3.3 only)

Red can import Incite Container clips, preserving their in and out points in the Red timeline. 
To use this feature, complete the following steps.

1. Create a container clip in Incite and apply Red to this clip.

Incite Container Clip

2. The Red timeline opens with the individual Incite tracks in the container clip. The 
individual track in and out points are respected.

Container Clip Expanded inside the Red Timeline
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What Was New in Red 3.0.1
The previous maintenance release, Red 3.0.1, added the following features and fixed several 
problems below. Red 3.0.2 also includes these fixes.

More Flexibility for Pie Charts

A new Series menu appears in the Chart tab for Pie Charts. This allows more flexible data 
import. Previously, you could only import row-based data into Pie Charts. The Series menu 
lets you orient the chart to include rows or columns as a series. 

•   Rows as Series places the rows vertically in the chart. The information in the first row 
appears in the Legend (if the Enable Legend checkbox is selected in the Legend tab).

•   Columns as Series places the columns vertically in the chart. The information in the 
first column appears in the Legend (if the Enable Legend checkbox is selected in the 
Legend tab).

Apply Two Motion Tracker Filters to the Same Track

Two Motion Tracker filters can be applied to the same shape or filter track. Previously, only 
the top-most Motion Tracker filter was recognized. For example, this is useful when motion 
tracking both ends of the wire in the Wire Remover filter.

Time Filters Enabled for Host Media in Media 100 i

Time filters are now enabled for host media in Media100 i. These filters were previously 
disabled in this host because M100 did not provide alternative time frames to plug-ins. 
Beginning with v8.21 this condition has been fixed.

OpenGL Enabled in Final Cut Pro 4.1

OpenGL is now fully enabled for FCP 4.1 when you run Macintosh OSX 10.3. Previously 
OpenGL was not available in Final Cut Pro with earlier versions of the Macintosh OS.

New Quit and Save As Behavior

When you quit Red, the name of the saved setting is displayed and saved when you press 
OK. The application then quits, which eliminates the extra dialog box that you previously 
had to dismiss. If you want to save the open setting with another name, you can press 
Cancel and then save your setting. If the setting has not been saved previously, the dialog 
prompts you to save it.

New Preview to RAM Behavior

When audio is disabled, Preview to RAM now loops the playable frames, rather than 
playing the frames then holding the last frame for the full (or in/out) duration. 

Project Window Improvements

The active composition in the Project window (in Frame view, List view, or Render Queue) 
is framed with a blue outline, which is different than the selection color. This indicates the 
composition that is open in the timeline and saves when you choose Save Composition. 
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New Project Window Sorting

Red now provides friendlier sorting of compositions in Frame, List and Render Queue 
views. Columns now sort more logically when they contain numbers (i.e. 10 sorts after 9, 
not after 1). This ordering is regardless of where the numbers occur in the name.

New Naming Scheme for New and Duplicated Compositions

When you create a new Composition, duplicate names are now avoided. Previously when 
you created a Project and saved a copy of the Composition several times, you could easily 
create confusion with several compositions of the same name. Duplicated compositions are 
named with “_1”, “_2”, etc. The Save Composition Copy command automatically appends 
“_1” after the name. If you edit the name of Composition 1_1 and choose Save Composition 
Copy, you get Composition 1_1_1, so you can see your version history.

Supported Hosts

Boris Red 3.0.2 supports the following host applications. Because host versions update 
frequently, please visit our website at www.borisfx.com for information on supported 
versions for each host.

Macintosh Windows
Adobe® Premiere® 6.5 Adobe® After Effects® 6.0

Apple® Final Cut Pro® 3.0, 4.0 or 
later

Adobe® Premiere Pro® 1.5

Avid® Media Composer®, Avid 
Symphony® 4.7, 4.8, Avid 
XpressMac®, Avid Xpress DV® 
3.0, 3.5.4, Avid Xpress Pro®4.0 or 
later

Avid® Media Composer®, Avid Symphony®, 
Avid Xpress®, Avid Xpress DV® 3.0, 3.5.4, 
Avid Xpress Pro® 4.0 or later, Avid Xpress 
Studio, Avid|DS 6.0 and later

Media 100 i® 8.1 and later, Media 
100 HD 10.0

Canopus® Edius® 2.5, Edius Pro® 3.0

DPS® Velocity® 8.2

Incite® Media Producer 3.0 and later, Remote 
Producer 3.0 and later

In:Sync® Blade® 2.2, In:Sync Speed~Razor® 5.5

Media 100® iFinish 4.6 

Pinnacle purple®, Pinnacle silver® 4.01, Pinna-
cle Liquid Edition® 6.0

Sony® Vegas® 4.0

Ulead Media Studio Pro® 6.5, 7.0
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Supported Operating Systems

Red 3.0.2 supports the following operating systems. 

Macintosh
Macintosh OS X v10.2.6 and above (see note below). 

To take advantage of the OpenGL features in Red 3.0.2, you must install Macintosh 
OS 10.2.6 or later. Final Cut Pro 4.x users must install Macintosh OS 10.3. 

Windows
Windows 2K®, Windows XP®

Minimum System Requirements

We recommend at least 512 MB of memory assigned to the host application for both 
Macintosh and Windows users using Red 3.0.2.

To run Boris Red 3.0.2, QuickTime version 6.0 or later must be installed on your system. 
Boris Red 3.0.2 supports dual processors, Hyper Threading, and Altivec acceleration.

Localization

Red is localized in several languages – English, French, German, Spanish, Italian, Japanese, 
Chinese and Korean. Red installs a Boris Language Pack file which reads the system 
language specified on your system and translates its menus into that language, if it is 
supported. Localization should be automatic and requires no work on the part of users. The 
Boris Language Pack file is located in the following location.

Macintosh
Library/Application Support/BorisFX/Boris Language Pack.ecs

Windows
<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs

Editing Language Pack files with the Boris Localizer
The Boris Localizer is a standalone Mac OS X application that can be used to update the 
translation of Red in any of its eight supported languages. Use the Boris Localizer to edit 
Boris Language Pack files which contain translations of Red menus and parameters into 
various languages. The Boris Localizer is available through your local Boris reseller.
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Contact your reseller for more information on using the Boris Localizer to edit the 
default Red translations.

Supported Hardware and Drivers

You need the following hardware and system requirements to use the new hardware 
dependent features in Red 3.0.2. For detailed information on the OpenGL feature in Red 
3.0.2. See the Understanding OpenGL pdf on your Red CD or Volume I in the Red User 
Guide.

Important Note on OpenGL Support
Due to the fast rate at which OpenGL card manufacturers release drivers, Red may 
disqualify your OpenGL hardware erroneously. If this happens, you should try to enable 
OpenGL to see if you benefit from OpenGL acceleration. If you have troubles with slowness, 
or render inconsistencies, please disable OpenGL. For information on enabling OpenGL, see 
“Enabling OpenGL” on page 26.

While OpenGL may work in the Red Engine, that does not necessarily mean it will work 
inside your host application. This is due to the fact that some hosts use OpenGL memory, 
leaving it unavailable for Red when you work inside the host.

If your host crashes when trying to apply Red, and you cannot disable OpenGL in your host, 
please contact our technical support staff. They will send you a preferences file that will start 
Boris Red with OpenGL disabled.

BorisFX will make every effort to continue to qualify OpenGL cards and driver versions. 
However, it is important to note that it is impossible to qualify all combinations of OpenGL 
cards, operating system, drivers and host applications. In general you should run the latest 
driver available for your OpenGL card. If you have problems with the latest driver, visit the 
Boris website to see a list of the latest supported driver versions.

Double-click to edit 
the translation 



23
• 
• 
• 
•
•
•

Supported OpenGL Hardware
The following graphics cards and drivers are supported for the new OpenGL features in 
Red 3.0.2. This list is current as of the initial Red 3.0.2 release. Boris FX maintains an updated 
list of tested video cards on our web site: www.Borisfx.com. In general you should 
download and install the latest driver for your GL card. For the latest updates to the list of 
supported cards and drivers, please visit: www.borisfx.com/html/products/RED/table.html.

OpenGL is a cross-platform standard that accelerates the rendering of 2D and 3D graphics. 
Most newer video cards have hardware-based OpenGL acceleration. If your system does 
not include the recommended minimum requirements, Red initially defaults OpenGL to 
Off. You can re-enable OpenGL in the Red Preferences window. You can still use Red 3.0.2 
without OpenGL or with an older card, you just won’t gain as much acceleration while 
working. For details on how to use OpenGL, see Volume I in the Red User Guide.

Final Cut Pro 4.x users must have Macintosh OS 10.3 installed in order to support 
Red’s OpenGL feature. 

Supported Macintosh Hardware
•   ATI Radeon 8500 (and up), Radeon Rage 128 (Macintosh only). 

•   NVidia GeForceFX (all), GeForce 3 and GeForce4 (all)

Supported Windows Hardware
•   ATI FireGL series, Radeon X300 (and up), Radeon 8500 (and up)

•   NVidia Quadro FX (all), Quadro4 900 (and up), GeForce 6800, GeForce PCX, and 
GeForce 3 and GeForce4 (all) 

•   Matrox Parhelia

Note for NVidia users: The NVidia GeForce 2 is not supported for OpenGL in Red 
3.0.2.

Note for ATI users: ATI model cards that are TNT enabled are not supported for 
OpenGL in Red 3.0.2.

As a general rule, you should install and run the latest driver available for your GL 
card. ATI users should not use driver versions previous to 63.68. NVidia users 
should not use driver versions previous to 65.00.

Note for Matrox Parhelia users: The Matrox Parhelia card is not recommended for 
Red users running Ulead Media Studio Pro. See “Important Information for Ulead 
Users” on page 38 for more information.
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Checking your OpenGL Hardware, Software, Drivers and Settings

The first time you launch Boris Red 3.0.2, an internal test is run on your system to determine 
whether your hardware meets the minimum requirements necessary for OpenGL 
Hardware acceleration. If your hardware does not meet the minimum requirements, 
OpenGL is disabled by default on your system. 

To perform the OpenGL 
Hardware test manually, 
click the Test OpenGL 
Hardware button in the 
Preferences window’s 
Render tab.

Depending on the amount of 
memory your graphics card 
has, this test may take a few 
minutes to run.

After the test is run, a window displays specifics of the hardware and drivers installed on 
your system which are necessary to run OpenGL. If any test results show your system may 
have problems running OpenGL, the errors are detailed in this window. 

If you want, click the Copy to Clipboard button to copy this information to your system 
clipboard. This allows you to print or email this information. When you finish, click OK to 
close this window.

Depending on your system, the test may take a few seconds to complete. The test stresses 
your OpenGL hardware, so you should run the test with a typical workload on your system. 
Before you run the OpenGL hardware test, launch any graphics applications that you 
usually run while you edit (any graphics intensive applications you are running at the time 
may affect the results).

Red 3.0.2 uses the following guidelines for optimal OpenGL performance. Some of this 
information does not affect Red’s hardware testing but is useful for technical support if you 
are having OpenGL problems:
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•   Graphics Card-- See the table and notes on page 23. Also see the updated list on the 
Boris FX website.

•   OpenGL version--Should be 1.2 and higher.

•   Driver Version--As a general rule, you should install and run the latest driver available 
for your GL card. ATI users should not use driver versions previous to 63.68. NVidia 
users should not use driver versions previous to 65.00.

•   Texture Rectangle--This is an advanced OpenGL image sizing feature. If you are 
having OpenGL problems, this provides useful information for technical support.

•   Texture Memory-- Texture Memory displays the amount of memory on the video card 
available for Red to use for textures (layer images).To use Red 3.0.2 without display or 
performance problems, Texture Memory must be at least 32MB. Texture Memory 
available is not the absolute of memory on your card, but rather the amount available 
to Red.

•   Texture Dimension displays the maximum texture size that can be used with the video 
card.

•   Macintosh OS Version displays the installed version of the Macintosh OS (if you are 
running on a Macintosh system.) Macintosh users must have at least Macintosh OS 
10.2.6 installed to support OpenGL; Final Cut Pro 4.x users, must have at least 
Macintosh OS 10.3 installed to support OpenGL. 

OpenGL Errors

When the OpenGL Hardware Test is run, error messages may display if your system fails. 
These errors display as Hardware Status errors or Critical Testing errors. 

Hardware Status errors report the status of your current system setup against Red’s 
recommended card manufacturer, model and driver. These errors do not prevent you from 
using OpenGL, they just warn that your specific system and setup may cause problems with 
OpenGL. Hardware Status errors can include messages such as insufficient available texture 
memory or reports that your card was not recognized by Red’s internal hardware testing. 
When you receive a Hardware Status error, OpenGL is automatically disabled when you 
launch Red. However, you can manually enable OpenGL in the Red Preferences window. 

Critical Testing errors report errors that will not allow you to use OpenGL in Red. When 
you receive a Critical Testing error, OpenGL is automatically disabled when you launch 
Red. If you receive a Critical Testing error, you should not enable OpenGL or you may crash.

Final Cut Pro 4.x users must have Macintosh OS version 10.3 installed in order to 
support Red’s OpenGL feature.

Certain errors are influenced by the display properties set on your video card. The 
display property settings are card-driver specific. As a general rule, the display 
properties should be set to 32 bits of color, with the depth buffer set to at least 16 
bits. On many cards the OpenGL capabilities are reduced when higher display 
resolution and refresh rates are set.



26   

• 
• 
• 
•
•
•

Enabling OpenGL

You can enable OpenGL in the Preview menu or in the Preferences window.

•   To enable OpenGL in the Red Preference window, choose Edit > Preferences 
(Windows) or Boris Red > Preferences (Macintosh). Click the Render Tab and select the 
Accelerated Draft Preview checkbox. Choose the appropriate choice from the OGL 
Acceleration menu. On, Max. texture caching provides the best performance and is the 
recommended setting.

•   To enable OpenGL in the Preview menu, choose Preview > Open GL Mode. Choose the 
appropriate choice from the submenu. On, Max. texture caching provides the best 
performance and is the recommended setting.

Troubleshooting OpenGL Issues

To toggle OpenGL off, use the keyboard shortcut Command or Control-[. To turn it back on, 
the keyboard shortcut Command-] (Macintosh) or Control-] (Windows). Menu choices also 
appear in the Preview menu and in the Preferences window. You can still use Red 3.0.2 
without OpenGL or with an older card, you just won’t gain as much acceleration.

Display problems such as white, rainbow or garbage images in the Composite window may 
be related to OpenGL. If this occurs, open the Preference window. In the Render tab, change 
the OpenGL Acceleration menu to use less texture caching. Texture caching is used for 
textures (layer images) and is related to the amount of Texture memory on the video card. 
Display problems related to OpenGL will not affect your rendered effects.

If you experience OpenGL problems, setting the OpenGL Acceleration menu to 
use less texture caching improves OpenGL reliability, although it lessens OpenGL 
performance.

Supported Preview to Monitor Hardware
You can output video to an external monitor through a FireWire converter box or through 
supported video hardware connected to your system. You can output media at any project 
size and immediately view your working frame without rendering the timeline. 

Some hosts have native Preview to Monitor (PTM) where Red passes a frame and the host 
displays it. If a host has this ability, for example Meridien-based Avid systems, then nothing 
changes from the Red 2.x capabilities. However, if a host did not have native PTM ability, 
then you can use the new Preview to Monitor feature. The user does not have hardware 
choices in the Preferences window if Red uses native host PTM (since the host controls the 
hardware connection).

As a plugin, Red does not officially support connecting to hardware that is already 
in use by the host NLE for direct Video Out purposes. The plug-in version of Red 
can only use the FireWire output if the NLE releases it while Red is running. A 
number of hosts (for example Premiere and FCP) will not release control of the 
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primary display hardware. This prevents Red's Preview to Monitor feature from 
working either in the plug-in or the Red Engine until the NLE releases control of 
the FireWire hardware.

However, Red looks for all possible output devices upon installation, and lists the results in 
the Device menu in the Preview tab of the Boris Red preferences. As a result, users may be 
able to use a different output device for Red than the one that the host application uses. The 
host application may use its own capture hardware for display, leaving the FireWire port 
available. 

Video-out capabilities are also available in the standalone Boris Red Engine. This enables 
anyone with supported video hardware, whether built into their computers, included with 
their NLEs, or provided through third parties, to see the work they create in Boris Red 
immediately on television monitors.

Red 3.0.2 supports the following video cards for the new Preview to Monitor (PTM) feature 
in both the Red Engine and while using Red in your host. For detailed information on the 
new PTM feature, see Volume I of the User Guide.

Make sure you have the latest drivers installed for the supported video cards.

Supported PTM Cards

•   Cinewave®

•   Matrox ®Parhelia®

•   AJA® Xena®

•   Canopus® RT® (See note below.)

Note for Macintosh Users: Most cards supporting standard QuickTime video out 
capabilities and drivers should work.

Note for Windows Users: Although the previous cards were internally tested and 
approved, other cards may work as well. We also support standard FireWire out. 
Many Canopus RT boards work, although we cannot guarantee they all will.

Note for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

Note for Final Cut Pro version 4.x Users only: In order to use Red’s Preview to 
Monitor feature, you must turn off the external video in Final Cut Pro before 
launching Red. Choose View > External Video > Off before launching Red, then 
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enable Red’s Preview to Monitor feature when Red is launched. After leaving Red, 
reenable the external video (View > External Video > All Frames) to see Final Cut 
Pro video in the external monitor.

Note for Avid Users: See “Preview to Monitor Feature for Avid Systems” for 
information specific to Avid users about the Preview to Monitor feature.

Once the hardware is connected, choose Connect to Monitor from the Preview menu. 
Commands in the Preview menu allow you to set the video display. You can output media 
at any project size and immediately view your working frame without rendering the 
timeline. 

When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite window, 
the image displays on the external monitor, using the Resolution and Quality settings 
specified in the Composite window. 

When you choose Display HQ on Monitor from the Preview menu, the image displays on 
the external monitor, using the Full Resolution and High Quality settings, regardless of the 
Resolution and Quality settings in the Composite window. When you choose Auto-Update 
Monitor from the Preview menu, every frame of your effect previews to the external video 
monitor connected This allows you to drag the CTI in the timeline and view updating 
frames. This option is not available in some host applications or system configurations.

Once the hardware is connected, configure the Red Preferences to use this feature. See the 
next section for details.

Enabling Preview to Monitor

Note for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

Note for Final Cut Pro version 4.x Users only: In order to use Red’s Preview to 
Monitor feature, you must turn off the external video in Final Cut Pro before 
launching Red. Choose View > External Video > Off before launching Red, then 
enable Red’s Preview to Monitor feature when Red is launched. After leaving Red, 
reenable the external video (View > External Video > All Frames) to see Final Cut 
Pro video in the external monitor.

To enable the Preview to Monitor feature, launch Red and open the Preferences window.

1. Choose File > Preferences (Windows), or Boris Red > Preferences (Macintosh).

2. Click to select the Preview tab.
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3. In the External Monitor Output section, choose 
your Firewire Converter box or Video 
hardware board from the Device menu. 

The Device menu displays all the supported 
hardware connected to your system.

4. Choose an option from the Mode menu if applicable. For example, if you are using a 
Firewire Converter box, you can choose PAL and NTSC formats from the Mode menu.

5. Click OK to save your settings and exit the Preferences window.

The Preview to Monitor preferences save and apply to all Red projects unless your 
Red 3.0.2 preference file is rebuilt.

Displaying Frames on your External Monitor
Commands in the Preview menu allow you to set the video display: 

•   When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor 
is enabled and the following three options in the menu become available:

•   When you choose Auto-Update Monitor from the Preview menu, every frame of your 
effect previews to the external video monitor. This allows you to drag the CTI in the 
timeline and view updating frames. The image displays on the external monitor, using 
the Resolution and Quality settings specified in the Composite window.

Enabling Auto-Update Monitor slows Red since every frame updates in the 
external monitor.

•   When you choose Display Frame on Monitor from the Preview menu or click the 
Display Frame to Monitor button in the upper-right corner of the Composite 
window, the current frame displays on the external monitor, using the Resolution 
and Quality settings specified in the Composite window. 

•   When you choose Display HQ Frame to Monitor from the Preview menu, the image 
displays on the external monitor, using Full Resolution and High Quality settings, 
regardless of the Resolution and Quality settings in the Composite window. 

Disconnecting Preview to Monitor
To disconnect Preview to Monitor (for example if you want to connect another device to 
your video board while editing with Boris Red), exit Red. When you relaunch Red, the 
external monitor is not connected until you choose Connect to External Monitor in the 
Preview menu.
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Tips for Using the Preview to Monitor Feature

Note for Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-
in with FireWire for Red's Preview to Monitor feature, must disconnect before 
clicking the Apply button or FCP will crash. To disconnect, choose Preview > 
Disconnect External Monitor.

Note for Final Cut Pro version 4.x Users: To use Red’s Preview to Monitor feature, 
you must turn off the external video in Final Cut Pro before launching Red. Choose 
View > External Video > Off before launching Red, then enable Red’s Preview to 
Monitor feature when Red launches. After leaving Red, reenable the external video 
(View > External Video > All Frames) to view Final Cut Pro in the external monitor.

Note for Avid Users: See “Preview to Monitor Feature for Avid Systems” for 
Preview to Monitor details specific to Avid Mojo and Adrenaline users.

•   Preview to Monitor automatically disconnects when you exit Red 3.0.2. This means 
each time you launch Red, you need to choose Preview > Connect to External Monitor 
in order to reconnect and see your image on the external monitor.

•   To change the Preview to Monitor device or mode, disconnect Red 3.0.2’s Preview to 
Monitor feature by choosing Disconnect External Monitor from the Preview menu. 
Enter the Red 3.0.1 GL Preference window’s Preview tab to choose a new Device or 
Driver from the External Monitor Output menus. You can also reconnect via the 
Preview menu with those new settings in the same session.

•   Displaying images on an external monitor 
requires compressing and resizing the images. 
Red 3.0.2 may run slower if you have Auto 
Update enabled. Deselect Auto-Update 
Monitor in the Preview menu to remain 
connected to the external monitor but not 
automatically update frames. 

Manually update frames to your external 
monitor by choosing Preview > Display Frame 
to Monitor, or Preview > Display HQ Frame to 
Monitor, or by pressing the Display Frame to 
Monitor button on the upper-right corner of the 
Composite window. Display Frame 

to Monitor 
Button
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Important Note on Missing Filters

Several BCC filters are not included with the Boris Red 3.0.2 installation. Instead, the BCC 
DeGrain, BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC Spiral Blur filters 
are available as a free download to registered users. These filters are available on the 
Downloads page at www.borisfx.com.

You must register Boris Red 3.0.2 to download these filters. See the Installation 
Guide PDF for details on registering.

Important Information for Avid Users

Avid users can now apply Boris Red as a filter to titles created with the Avid Title tool.

Applying Boris Red as a Title-Matte Effect
You can apply Boris Red directly to titles created in the Avid timeline. For example, if you 
have a bin with saved titles, you could apply a filter to the titles in Red.

1. Edit an Avid title or matte key into the Avid timeline.

2. Open the Avid Effect Palette and select Boris Red from the Effect categories.

3. From the list of available Red effects, drag the Boris Red Title-Matte Effect to the title 
or matte key in the Avid timeline.

Dragging the Title-Matte effect onto an Avid title or matte key is a destructive 
process which replaces the title or matte key. Additionally, removing a Title-Matte 
effect removes the title’s nested alpha channel. To remove a Title-Matte effect and 
preserve the title or matte key, use the Undo command instead of the Remove 
Effect command.

4. Click the Other Options button in the Avid Effect Editor to launch the Red interface and 
create your effect.

If the title or matte key looks blocky when Red opens, select its Face track in the 
timeline. In the Host Media tab, choose Straight Alpha from the Key menu. This 
usually happens automatically.

Replacing a Title-Matte Effect

Since a title is replaced by applying the Title-Matte effect, to re-edit a title with a Title-Matte 
Effect (for example to change the text or a font) you must save the Title-Matte effect while 
you are in Red (in the File menu). Recreate the Avid title and overwrite the older title in the 
Avid timeline. Drag a Red Title-Matte Effect to the new title. In Red, open the saved effect 
and apply it to the new title.
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Avid Systems and Preview to Monitor
Red’s Preview to Monitor feature works for Xpress DV, Xpress Pro, and Adrenaline and 
Mojo models only. All other Avid products can use the existing AVX Preview to Monitor 
feature within Red. The AVX Preview to Monitor allows you to see video in an external 
monitor without the extra step of selecting your hardware in Red’s Preference window.

Workaround to Rendering Problem in Earlier Versions of Xpress Pro
A simple workaround has been discovered for rendering problems affecting AVX 1.5 plug-
ins running in earlier versions of Avid Xpress Pro. The problem can be avoided by rendering 
these effects while in Xpress Pro's Green dot mode. 

Avid fixed this problem in the current version of Xpress Pro so you do not need to 
perform this workaround if you are running the latest version.

The problem is not unique to Boris plug-ins; it affects other AVX 1.5 plug-ins as well. AVX 
1.5 plug-ins in Avid Xpress Pro may see a problem in rendered effects that appears as two 
distinct symptoms: 

•   A render glitch that appears as a vertical stretch on the first field of the first frame of an 
effect applied as a filter 

•   A softening of the video image in rendered effects (noticeable even on a straight “pass-
through” effect) 

This occurs using Boris AVX 1.5 products (Red, Boris FX, Graffiti) in Avid Xpress Pro on both 
Windows and Macintosh, but does not occur in Avid Xpress DV or other Avid non-linear 
editors. If you are working with a version of Avid that is affected by this problem, render 
effects in Xpress Pro's Green dot mode. 

Important Information for Edius Users

Due to limitations in the Edius architecture, you need to be aware of the following 
limitations when using Red inside Edius.

Launching Boris Red within Edius
To launch the Red user interface after applying a Boris effect to a clip, the Edius timeline 
cursor must be placed over the effect and the track containing the effect must be selected.

Working with Edius Palettes when Red is Launched
When using Boris Red as a Transition effect in Edius, the Edius Palettes remain above the 
Boris Windows. BorisFX has reported this issue to Canopus and is working with them to 
resolve it in a future release of Edius. Currently, to work around this issue, position the 
Edius Palettes and Boris windows so they don't overlap.
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Editing Previously Rendered Effects
In Edius, when a clip is rendered, that clip is locked down. Any further changes to a Red 
effect will not display in the Edius Preview window until Edius is closed and reopened. To 
work around this limitation, complete the following steps:

1. In the Edius settings, click the Render tab. 

2. In the Delete invalid rendering files section, choose When the Rendered File is Invalid. 

3. Unrender the clip by making a change, such as toggling the checkbox to 
disable/reenable the effect in the Edius Information Palette.

Using Boris Red as a Transition in Edius
Edius includes three types of transitions; In, Out and Single Track. Due to current limitations 
in the Edius plug-in architecture, Boris Red will not work as desired when applied as an Out 
transition. We recommend that you build Red transitions in Edius as either Single Track or 
In transitions.

Important Note on Creating Time Effects within Boris Red
Due to a limitation in the Edius architecture, Red’s Time filters do not work when applied 
to host video in Edius since Red cannot obtain the alternative host video frames needed for 
rendering. If you apply a Time filter to Edius host video, an 'X' displays in the Composite 
window and a default image is displayed. To work around this limitation, import the video 
directly into Red effect as Movie media (rather than referencing it as V1 host video) or create 
the time remapping effect in the standalone Red Engine rather than in the Red plug-in.

For more information on the standalone Red Engine, see the User Guide.

Unexplained Crashes in Edius with OpenGL Enabled
If Edius crashes when trying to apply Red it may be because OpenGL is enabled. If you 
cannot disable OpenGL, launch the standalone Red Engine to disable OpenGL, then you 
should be able to apply Red within Edius as a plug-in. You can also contact our technical 
support staff. They will send you a preferences file that will start Boris Red with OpenGL 
disabled.

Applying Multiple Boris Red Filters to a Clip in Edius
There are some issues you should be aware of when applying multiple Red filters to a clip.
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Stacking Multiple Overlapping Boris Effects

We do not recommend adding multiple Red effects to an Edius clip or stacking clips 
containing Boris effects on multiple layers in the Edius timeline. This may work, but 
depending on your system specifics, multiple Boris effects (>2) on a clip or stacked on top 
of each other may not render properly. Instead, apply a single Red effect to an Edius clip and 
add multiple filters to the clip within Red.

This limitation only applies to effects that overlap exactly. For example, a track 
containing both an in and an out transition would not fall under this suggestion 
(since they can not overlap).

Applying more than one Boris Effect to a Clip

If there is more than one Boris effect applied to a clip, the effect of preceding filters will not 
display in the subsequent filters in the Red User Interface. For example, if first a blur filter 
and then a ripple filter are applied to the same Edius clip, the blur filter effect will not show 
in the effected track when the ripple effect is launched. However, all effects will display 
during render in the Edius Preview window.

Playing Boris Red Effects
Edius timeline playback stops when trying to play through a Boris effect. To fix this, in the 
Edius settings deselect the Stop Playback at Frame Drop in the Playback tab.

Working in Boris Red when Edius is Running
When Red is launched Edius is unable to perform other actions (such as close, etc). It is 
possible to get Edius into a state where it thinks Red is launched, but the Red User Interface 
does not appear. This will functionally lock Edius. 

To resolve this, delete the Red .ini file in the root:\\WINDOWS folder, and launch Red 
again. If this doesn't work, save the Edius project, force a manual close of Edius (Control + 
Alt + Delete), delete the Red .ini file, then launch Edius again. 

Applying Boris Filters within Native Edius Filters
At this time Boris products do not support being launched from inside other Edius filters 
(for example, the Combine or Region Edius filters).
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Important Information for Final Cut Pro Users

Final Cut Pro 4.x users must have Macintosh OS version 10.3 installed in order to 
support Red’s OpenGL feature.

To use Red’s Preview to Monitor feature, you must turn off the external video in 
Final Cut Pro before launching Red. Choose View > External Video > Off before 
launching Red, then enable Red’s Preview to Monitor feature when Red is 
launched. After leaving Red, reenable the external video (View > External Video > 
All Frames) to see Final Cut Pro video in the external monitor.

•   Final Cut Pro 3 users running Red as a plug-in with FireWire for Red's Preview to 
Monitor feature, must disconnect before clicking the Apply button or FCP will crash. 
To disconnect, choose Preview > Disconnect External Monitor.

•   Final Cut Pro 4.x users can now use Boris Red as a transition, taking advantage of a 
new architecture jointly developed between Boris FX and Apple. See Appendix B in 
Volume I of the Red User Guide for information on applying Boris Red as a transition.

•   Red 3.0.2 includes a Static Generator for Final Cut Pro. The Static Generator allows you 
to create a static slate which takes advantage of Final Cut Pro’s real-time capabilities. 
When you apply the Static Generator, the Boris timeline opens with a duration of one 
frame which can then be applied to Final Cut Pro as a static slate.

•   Red 3.0.2 will now correctly field render video in the wells when using a Red FCP 
Generator. This was broken in Red 3.0.1. However, the media placed in the input wells 
for a Red Generator should match the FCP sequence size. Both the Red project size and 
the size of the well video will appear in Red at the FCP sequence size. If the well media 
is not the same as the FCP sequence size, fields won't render correctly.

Additionally, any video put into the input wells of a Red filter should be the same size 
as the clip with Red applied. In the case of Red applied as a filter, the Red project size 
is determined by the size of the filtered media. Once again the size of the filtered media 
needs to match any video in the wells. This will maintain the integrity of fields since 
Red doesn't allow host video inputs of various sizes within the same effect.

In a case that requires media sources whose size will not match the FCP sequence size 
(Generator) or the Filter media size, the best approach is to import that media directly 
into the Boris timeline from disk (rather than from the wells in FCP). This will provide 
you with full flexibility for dealing with non-standard size images, field interpretation, 
and oversize images.

•   To edit an existing Red effect, make sure the playhead is positioned on the effect you 
want to edit before launching Red. Otherwise, the Boris interface will not appear.

•   Do not export from Boris Red unless the FCP resolution is set to 100%. Otherwise, you 
get reduced image quality, because FCP does not provide Red with full-size frames. 
Likewise, if Final Cut Pro is at less than full resolution (100%), previews at full size 
appear in reduced quality.

•   In some instances the Boris Red 3.0.2 plug-in crashes due to an apparent conflict with 
MacsBug v6.6.3. If you have MacsBug 6.6.3 installed and experience crashing, try 
disabling or running an earlier version of MacsBug when using Boris Red.
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•   When you apply Red as a filter of generator, Red gets the project size from the media 
size and the Final Cut Pro project size. However, this is NOT how the Red transition 
works.The Red transition determines its project size by multiplying the Canvas 
window view percentage times the Final Cut Pro Project size. You should set the 
Canvas window to 100% before applying Red as a transition.

For example, you are using 720x480 media in a 720x480 Final Cut Pro project. You 
apply Red to the transition between two clips, but are viewing your Canvas window at 
50%. When you launch Red, the Project and media size will be 260x240 (720x480 
multiplied by .5). If you are viewing your Canvas window at 50%. with Square Pixels 
enabled, Red would set your project size to 360x270 (720X540 multiplied by .5). 
However, when you Apply Red, the media displays at its correct size. If you view the 
Canvas window at 100% or larger, Red displays the media at its correct size.

•   If both Red 3.0.2 and an earlier version of Red are installed in Final Cut Pro, the Effects 
menu lists both versions with the same name: Boris Red. The top item in the list is Boris 
Red 3.0.2 and the second item is the earlier version. We recommend you uninstall 
earlier versions of Red when using Red 3.0.2.

Important Information for Pinnacle Liquid Edition Users

When you apply Boris as a transition and launch Red, Red’s Composite window incorrectly 
displays the outgoing clip as the incoming clip. This is only a cosmetic problem; the 
transition will render correctly in Liquid Edition. To work around this limitation do one of 
the following.

•   Create the transition in Red as if your clips are correct. When you finish, apply back to 
Liquid and render your transition. The final render will be correct. 

•   Alternatively, you can click the Media icon in each track and swap Video 1 and 
Video 2. When you create your transition, it will appear correct in Red. Remember to 
swap them back before applying back to Liquid.

Press the track’s 
media icon to swap 
the incoming (V2) 
and outgoing (V1) 
tracks

Media icon
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Important Information for Premiere Pro Users

Due to limitations in Premiere Pro 1.5, when you apply Red’s Time filters directly to host 
media in the Premiere Pro timeline, you will experience the following problems. 

•   The filter appears to have no affect when you scrub in the timeline. You need to render 
in order to see the effect.

•   Rendered effects may appear to jitter.

The workaround is to apply Time filters within Red by importing the media as a movie file 
and assigning the movie file to a track in the Red timeline. Do not apply Time filters directly 
to host media in the Premiere timeline.

Important Information for Sony Vegas Users

When you create an effect in Red that will output an alpha channel to Vegas (for example a 
title which does not include the background video), when you apply the effect back to the 
vegas timeline you will notice the edges appear rough and contain white fringes. You need 
to reenter Red on the effect and in the Red Preferences set the Local Preferences’ Alpha Type 
menu to Premultiplied with Black. The effect will display correctly when you apply back 
to Vegas. You will need to do this every time you create an effect that outputs alpha.
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Important Information for Ulead Users

Projects in certain versions of ULead Media Studio Pro may display jagged edges 
or reversed fields in rendered Boris effects. If your system shows this problem, you 
can install a registry key that indicates that ULead’s video fields should be 
reversed. This is found on the top level of the Boris CD in the Ulead Field Change 
folder. It also available at www.borisfx.com/download/utilities.php on the Boris 
FX website.

Double-clicking the BorisULeadFieldSwap.reg text file adds a ULead field reversal “key” to 
the Windows Registry. This reverses the upper/lower field of each host video frame. At the 
prompt “Are you sure you want to add the information...to the registry?” choose Yes.

This action can be undone using the BorisULeadFieldNoSwap.reg file, which simply 
removes this key from the Windows registry (if it is present). In previous product releases, 
these files may have been called the "Ulead Field Swap utility". If you have questions about 
running this utility or whether your system exhibits this problem, read the Ulead.txt 
document included with the utility or email Boris technical support specialists at 
support@borisfx.com.

When using Boris as a transition in Ulead, the image quality for host media in the 
Composite window is very poor. Ulead does not pass a full size image. However, 
this does not affect rendering. The effect renders in high quality.

When Using Boris within Ulead with the Matrox Parhelia board, you may run into 
crashing problems. We do not recommend using the Matrox Parhelia board with 
Red running as a plug-in to Ulead.
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Installing and Using Adobe After Effects Filters within Boris Red

Boris FX provides a supported list of AE filters for use inside Boris Red. For best results, use 
only supported AE filters inside Boris Red. An list of Supported, Conditionally Supported 
and Unsupported filters can be found on our website: www.borisfx.com.

Supported filters were tested on single-processor machines. While these filters should also 
work in multi-processor machines, it is possible you will experience unexpected results or 
your machine may crash. If you have problems with supported filters in multi-processor 
machines, try disabling your MP functionality and recreating your filter effect.

Boris Red 3.0.2 includes four free DigiEffects Delirium filters: DE Day for Night, 
DE Fog Factory, DE Fireworks and DE Electrical Arcs. These filters are installed in 
the Boris Plug-ins folder when you install Boris Red 3.0.2. For more information, 
see the DigiEffects_info.pdf and the DeliriumUserGuide.pdf and the Known 
Limitations Filters section on page 53.

Tinder Users: Tinder’s Effect Viewer only works properly with the Red Composite 
window set to Full Resolution. Additionally the Effect Viewer may disappear after 
dragging tracks. Use the regular controls if you experience this problem.

Important Information on Using After Effects Filters
•   Checkboxes and menus cannot be animated. 

•   Time remapping filters do not work in Boris Red.

•   After Effects filters may take longer to render than most Boris Red effects.

•   None of Adobe's built-in After Effects filters work inside Boris Red.

•   If renders appear noisy or jittery, deselect the Better Quality Field Rendering checkbox 
in the Boris Preferences window and re-render the effect.

•   If you have more than 900 filters, you will not see some filters inside Boris Red. If you 
reach the filter limit, when you launch Boris Red a warning asks you to remove some 
files from the BorisPlugins folder. You can ignore the warning and continue to work. 
However, you will not have access to all filters inside the BorisPlugins folder. You can 
use the Plugin Filter Manager to hide the filters you don’t need. See Chapter 4 in 
Volume I of the User Guide for details on using the Plugin Filter Manager.

Installing AE Filters for Macintosh
Macintosh users should place supported After Effects filters or an alias in the following 
folder. The filters appear in the Filters menu within Boris Red.
System Folder (or Library)/Application Support/BorisFX/BorisPlugins

Installing AE Filters for Windows
Windows users should place supported After Effects filters or an alias in the following 
folder. The filters appear in the Filters menu within Boris Red. 
C:\Program Files\Boris FX, Inc.\BorisPlugins
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Important Information about Exporting to Flash
Boris Red allows you to export files in the Macromedia Flash (SWF) format. This allows you 
to export compositions as compact, vector-based files optimized for web viewing. For 
example, you could export a Type On effect to include on a web page.

Red exports Flash .swf files that are compliant with the Flash 5 architecture. If you are using 
QuickTime to preview your exported .swf files, you need a version of QuickTime that 
supports the Flash 5 format. The following effects are supported for exporting to Flash.

•   Text

•   Spline media

•   2D Charts (which consist of text and spline shapes)

Other bitmap elements such as video or still graphics can be included in the exported Flash 
file and will be JPEG-compressed. In the Export preferences you can set the quality of the 
JPEG compression. 

When you export text to Flash, any texture that was applied to the text is ignored.

When you export text with a gradient fill to Flash, the resulting .swf file is blank.

Exporting as Flash
The SWF format was designed primarily for animated 3D Line Art objects, so it works well 
when exporting settings that contain spline and text animations. Settings that contain video 
or animated bitmaps, however, generate rather large files. You might want to consider 
exporting such animations as a QuickTime or AVI file. See “Exporting Effects as Movies” on 
page 297 in Volume I in the Red User Guide for details. 

The Flash export feature has some limitations. You cannot export 3D Extrusion tracks as 
Flash. Settings that contain 3D Extrusion tracks export as a blank track. The Flash export 
feature does not support shadows or gradients used as Texture tracks. However, you can 
export a static gradient as a bitmap background. 

To prepare to export to Flash, you should change any shape track containing EPS 
files, text, or Spline media to 3D Line Art shape. Because you cannot use the 3D 
Line Art shape with the Brush tool, you cannot export brush strokes as Flash.

1. Select the appropriate track in the timeline.

2. Choose File > Export > Flash.

A dialog box appears that allows you to name and save the file.

3. Name the track and click Save.

The composition is exported using the Flash Export settings, which are controlled by 
the Preferences window’s Export tab. 



41
• 
• 
• 
•
•
•

Important Note on Creating Time Effects within Boris Red

The following important notes pertain to Time filters, including Optical Flow.

•   Exporting an effect containing a Time filter (including Optical Flow) with host media 
is NOT recommended. If you want to export from Red with Optical Flow (or any Time) 
filter in the timeline, you should use imported media in the source track.

This is because most hosts will not give Red both fields at set-up (preview). In that case, 
the first field of each frame goes into the motion estimator. If the motion is small from 
one frame to the next, and/or includes little crossing motion, the preview appears close 
to the rendered output. However, if the motion is large, and/or includes a lot of 
crossing motion, it is important for the motion estimator to have access to both fields in 
order to see an accurate preview of the rendered result.

•   Some hosts (such as Canopus Edius and Sony Vegas) do not allow plug-ins to access 
host frames at different times. If your host does not allow Boris Red to access alternate 
frames, an “X” displays in the Composite window when you apply a Time effect to host 
video. If you run into this limitation, instead of applying to host video, set the source 
media for these filters to Movie media files (QuickTime, AVI) instead. This may require 
exporting your timeline video from the host application as a movie. If you are using 
Media 100 i, you can easily bring in native Media 100 movie files through the Bin 
Browser.

•   Premiere Pro only: Due to limitations in Premiere Pro 1.5, when you apply Red’s Time 
filters directly to host media in the Premiere Pro timeline, you will experience the 
following problems. 

• The filter appears to have no affect when you scrub the timeline. You need to 
render in order to see the effect.

• Rendered effects may appear to jitter.

The workaround is to apply Time filters by importing the media as a movie file and 
assigning the movie file to a track in the Red timeline. Do not apply Time filters directly 
to host media in the Premiere timeline.

Important Information about Working with Motion Filters
•   You should use the Snap CTI to KeyFrame option (Track > Snap CTI to KeyFrame) 

when working with the Motion filters to avoid confusion. For example, this option is 
not selected and you move the CTI off a selected keyframe. Then you adjust the Search 
and Target parameters using on-screen controls. A new keyframe is not created. 
Instead, the selected keyframe is adjusted. This could cause your media to track 
incorrectly. If you want to create a new keyframe, you must deselect all keyframes 
before adjusting parameters on-screen.

•   While Interpolation Fields appear next to the Search/Target tab parameters, you 
should not adjust the Interpolation. Leave the Interpolation set to Hold. Adjusting the 
Interpolation will not affect the tracking but may cause on-screen parameters to 
display incorrectly.
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•   You can work at Half or Quarter Resolution to achieve a preview of a motion filter. But 
if the motion tracker fails repeatedly, you may have to work at Full Resolution.

•   You can only adjust the Search and Target regions in the Motion filter track's Preview 
window. The Source track does not display the region controls; the Composite window 
does not display the region controls.

•   The field order of the media must match the field order setting in the Media tab. You 
can set this in the Import tab in the Preferences window. See Volume II in the Red User 
Guide for more information.

Important Information Using the KeyFrame Library

The first time you browse the KeyFrame Library effects within the Library Browser you 
must generate thumbnail images for the effects. 

1. Open the Boris Library Browser, by choosing Window > Library Browser, 
clicking the Open Library Browser button in the timeline or pressing 
Command-9 (Macintosh) or Control-9 (Windows).

2. Select an effect or effect folder and click the Generate Thumbnails button. For more 
information on using the KeyFrame Library, see Volume I of the Red User Guide.

We recommend that you build thumbnail previews for the KeyFrame Library in 
the Red Engine rather than within your host application. Because building 
previews actually renders your effect, this process can take as much as 25-30% 
longer in the plug-in than in the Red Engine.

Also Included with Red 3.0.2

The CD-based installer of Red includes the Intelligent Assistant. The Intelligent Assistant. 
is a sophisticated online help system fully integrated into Boris Red 3.0.2. It is directly 
accessible from the Help menu and offers the equivalent of over 600 pages of text, with over 
three hours of narrated video to take you into as much or as little detail as you need, for any 
kind of task you might want to perform.

Seamlessly integrated into Boris Red, the Intelligent Assistant operates in a resizable 
floating window above Red, so that you can easily work along with provided examples. 
Along with instructions for specific tasks, the Intelligent Assistant also provides insight into 
broader-based effects-creation strategies, a number of tutorials, and creative examples of 
finished projects using illustrated techniques. The Intelligent Assistant is fully searchable 
and hyperlinked. Its modular structure makes it easy to use. Users with internet connections 
can automatically download new content.
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More information is available in Volume I of he Red Users Guide. See “Boris Red 
Online Help: The Intelligent Assistant” for information. The 3.0.2 Try and Buy web 
download does not include the Intelligent Assistant.

New Modifier Keys for Dial controls
When using the mouse on dial controls, you can now use the following modifiers:

•   Press the Shift key to round the marks on the dial controls to the nearest 45 degrees.

•   Press Control (Windows) or Command (Macintosh) to round the marks on the dial 
controls to the nearest 10 degrees.

•   Press Shift-Control (Windows) or Shift-Command (Macintosh) to round the marks on 
the dial controls to the nearest 5 degrees.

•   Press Shift-Control (Windows) or Shift-Command (Macintosh) and use the mouse 
wheel to round the marks on the dial controls to the nearest 45 degrees.

When tracking with a mouse wheel on dial controls, you can use the following modifiers:

•   Use the mouse wheel with no modifier keys to move the dial controls in 1 degree 
increments.

•   Press the Shift key and use the mouse wheel to round the marks on the dial controls to 
the nearest 10 degrees.

•   Press Control (Windows) or Command (Macintosh) and use the mouse wheel to round 
the marks on the dial controls to the nearest .1 degrees.
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Fixed Bugs in Boris Red 3.0.2 since Red 3GL

Red 3.0.2 includes many bug fixes from the initial 3GL version of Red. Fixed bugs include 
the following. Some of the following bugs were fixed in Red 3.0.1:

•   An issue with QuickTime export movies has been fixed, which previously caused a 
crash in certain hosts plug-ins (primarily on Windows AVX hosts). This crash could 
also occur when selecting the QT codec.

•   Final Cut Pro users only: Red 3.0.2 will now correctly field render video in the wells 
when using a Red FCP Generator. This was broken in Red 3.0.1. However, the media 
placed in the input wells for a Red Generator should match the FCP sequence size. Both 
the Red project size and the size of the well video will appear in Red at the FCP 
sequence size. If the well media is not the same as the FCP sequence size, fields won't 
render correctly.

Additionally, any video put into the input wells of a Red filter should be the same size 
as the clip with Red applied. In the case of Red applied as a filter, the Red project size 
is determined by the size of the filtered media. Once again the size of the filtered media 
needs to match any video in the wells. This will maintain the integrity of fields since 
Red doesn't allow host video inputs of various sizes within the same effect.

In a case that requires media sources whose size will not match the FCP sequence size 
(Generator) or the Filter media size, the best approach is to import that media directly 
into the Boris timeline from disk (rather than from the wells in FCP). This will provide 
you with full flexibility for dealing with non-standard size images, field interpretation, 
and oversize images.

•   In Red 3.0 the Preview To Monitor for Avid feature was disabled even when running 
in Meridien-based Avid versions. This was corrected in Red 3.0.1. 

•   Final Cut Pro 4.0 only: The Red banner in the Effect Control tab no longer disappears 
after you apply an effect.

•   Dragging an animated spline track into the mask track of another track now correctly 
preserve the keyframe animation.

•   Spline track keyframe timing information is now properly preserved when tracks are 
copied.

•   Windows only: The Plugin Filter Manager no longer crashes when duplicating a Filter 
set, in certain situations.

•   Windows only: Font styles are now stored with a .B2F extension instead of .B2D. This 
prevents the Text Styles and Font Styles from overlapping and appearing in the same 
tab in the Style Palette.

•   Red 3.0.1 fixed situations where the Render thermometer did not update when you 
worked with either OpenGL enabled, or on an MP system in High Quality mode.

•   Switching vertically from track to track in the timeline using the keyboard now 
properly synchronizes the OpenGL interactors shown in the Composition and Preview 
windows. 

•   Deleting the last used Library Browser folder and then launching Red no longer causes 
Red to hang when trying to restore that folder as the current one. 
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•   The Render Thermometer now updates more consistently.

•   Windows only: Old tool tips no longer randomly display in the Controls window when 
you hover over unrelated areas. 

•   The Delete key now deletes selected items in the Style Palette. 

•   The display of multiple selected items in the Style Palette now indicates the current 
selection when you Shift-select.

•   You can now select contiguous items in a table using by pressing Shift and scrolling 
the mouse wheel.

•   Position X and Position Y no longer act as if they are locked together in the Fire Filter.

•   Macintosh only: Repeatedly pressing Page Up or Page Down now works properly 
when a non-Timeline window is active, except when a text editing field is open.

•   Using the Mouse Wheel to switch a track selection no longer causes the last adjusted 
parameter in the Controls window to copy to the newly selected track.

•   Windows only: You can now successfully apply styles to text in the Text window.

•   The Create Cross Platform Movie checkbox has been removed from the Movie Export 
Settings dialog. Movies are now automatically created crossplatform.

•   The BCC Fast Blur filter no longer crashes if the height of the source is greater than its 
width. This was previously a problem when the filter was applied upstream (on the 
face track) to media, or with a vertically oriented project. 

•   Windows only: Red 3.0.1 improved low-memory handling in the BCC Fast Blur filter.

•   The performance of the Stars filter has been greatly improved.

•   Previous audio files that could not play properly in Preview To Ram with Audio play 
in Red 3.0.1. These tended to be uncompressed WAV or AIFF files.

•   Missing font names are now properly remembered, so you no longer see multiple 
messages complaining that the same font is missing.

•   Macintosh only: Occasions where the scroll bars at the edges of windows disappeared 
have been fixed. 

•   Macintosh only: Audio tracks in the Project window remain as audio tracks when 
dragged into the timeline, they are no longer converted to movie tracks.

•   Macintosh only: OpenGL performance has been improved when working with scaling 
down large textures (for example, 2K+ wide images).

•   If you open a movie file as an audio track then open that same file as a movie file, when 
you change the start time of either track, it no longer affects both. 

•   Instances where the Caps Lock feature didn’t work correctly in the Composite window 
have been fixed. 

•   The Toggle Face/Shape Track Selection button now works correctly for containers.

•   Motion tracking filters no longer contain hidden points in the Tracker Preview window.

•   Windows only: When using Title Containers and switching between the animation 
styles, the keyframes now reset so the container animates correctly.

•   The Motion Tracker filter Apply menu is no longer empty when you apply it 
downstream in a Shape track.
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•   Windows only: The Motion Tracker filter can now be dragged from a Face track to a 
Shape track. 

•   The Motion Tracker filter is now applied downstream (to the Shape track, not the Face 
track) by default.

•   The V key in the new Color Preview feature now works to commit to a color. Use the 
C key to dynamically preview colors, and then use the V key to commit to them. 

•   The Title Container Position Y (Roll) and Position X (Crawl) parameters no longer 
reset when certain other values are changed.

•   Installing a large number of presets for BCC filters no longer increases the rendering 
time. The parameters in these filters no longer become less responsive.

•   The Position X and Position Y parameters no longer act as if their interpolation is 
linked when changing from an interpolation other than Ease In/Out, to Ease In/Out. 

•   Windows only: 3D Sphere effects with Motion Blur enabled no longer render opaque, 
or crash in specific instances. 

•   You no longer crash with OpenGL enabled if you nest a track five times and adjust the 
first shape in the nest. 

•   Final Cut Pro 4.0 only: When you use Red as a Transition in Final Cut Pro 4.x, the Red 
Preferences are now respected. This means that when you relaunch Red as a Transition, 
changes you make to Quality, Resolution and other Red Preferences no longer need to 
be reset each time.

•   Windows only: Many keyboard shortcuts that previously displayed incorrectly have 
been fixed.

•   When you create spline effects using the Add Extruded Pencil button with animated 
borders, the effect no longer exhibits frames that appear different after rendering than 
they did when previewing the effect.

•   The Reveal Animation and Remove now appear correctly in Area Charts.

•   Windows only: The BCC Film Damage filter Hair parameter now functions correctly.

•   Checkboxes and menus from the Controls window no longer display as Option 
Change in the History Palette.

•   Preview to RAM now plays just the rendered section, rather than the entire timeline.

•   If you change the media for an EPS file to a spline object, you no longer crash.

•   Preview to RAM at Half Rate and Preview to RAM at Quarter Rate now preview the 
entire duration at their given rate. 

•   Windows only: If you press the Boris logo at the top of the Tools window, you no longer 
receive a memory error. 

•   Media 100 iFinish only: iFinish now passes the 16:9 ratio to Red in transition mode 
only. The Composite window no longer reflects 4:3.

•   Changing font size on Chart Legends now changes the size of the squares accordingly 
and the circles remain the same size.

•   If you change a Fade Animated Chart from Flat to Extruded, the animation now works 
correctly.
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•   Enabling values and a legend on an Area Chart no longer causes their values to display 
underneath the chart.

•   Resetting a chart now fully resets any color changes you made.

•   Windows only: Oversized images used as media for a background track now show up 
correctly when OpenGL enabled.

•   Windows only: Keyframes now display correctly in the timeline when you create them 
by moving OpenGL interactors if one of the position’s interpolation is set to Constant.

•   Macintosh only: The Red Engine is missing the ram preview to monitor selection.

•   When you map media with an alpha channel to a Cube shape with multiple faces, you 
no longer see different media for the sides of the cube in OpenGL vs. Non-OpenGL 
modes. 

•   Spline shapes no longer shift if you draw a shape with the Brush tool then select the 
Arrow tool.

•   If you have multiple tracks selected in the timeline and move them, the timeline now 
correctly displays the moved tracks. 

•   All settings from the Keyframe Library Backgrounds category now render correctly 
when you apply them with OpenGL enabled.

Known Limitations in Red 3.0.2 

Red 3.0.2 includes the following known limitations. 

General Limitations
•   If you tumble an object that has an image bump map (such as a movie or still image 

file), you may see a moire pattern as it tumbles. 

•   When you save a style to the Materials tab in the Style Palette, it does not correctly save 
the Source type that was used in the Bump Map tab.

•   When you open settings created in previous versions of Red, Red 3.0.2 ignores controls 
that were initially enabled in the Lights 2 and 3 tabs.

•   If you import files into Red that were created in Adobe Illustrator version 9, they 
display as transparent. Save the file in Illustrator version 8 instead.

•   When you search for a missing media file using the Search button in the Media Files 
window, it may not find files that were moved to another local drive. Manually browse 
to the new location of the file and press the Replace button.

•   Tracks containing PSD files that have been converted to containers do not correctly 
update if you modify them (for example in Photoshop) and then use the Reload Files 
command.

•   When you select “Targa Sequence” as a file type when exporting a movie file from Red, 
clicking the compression settings button erroneously displays QuickTime codec 
selections.
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•   Files exported to Flash from Red cannot be used in Macromedia Flash authoring 
applications such as Flash MX.

•   If you use the Keyframe Time field in the timeline to move keyframes, all keyframes 
that a moving keyframe passes are merged to it. Instead, move keyframes past one 
another by dragging the mouse.

•   Photoshop (.psd) files with adjustment layers display incorrectly in Red if you convert 
their track to a container. Turn off any adjustment layers in Photoshop before importing 
.psd files if you plan on converting them to containers.

•   Microsoft DV Type 1 filters do not work in Red as audio tracks.

•   You cannot adjust Volume and Balance for Red audio files do not update after you have 
changed them once.

•   Previewing with audio while you Preview to RAM to Monitor will disconnect Preview 
to an external monitor.

•   Audio waveforms do not update when you adjust the global timeline. This is only a 
display issue and can be corrected by moving something slightly in the Composite 
window.

•   Resuming a partial render of an exported QuickTime file may have some undesirable 
results. In particular, video compressed with codecs that use frame-differencing and 
data-rate-limiting (such as Sorenson or Cinepak) may exhibit the following behavior. 

Some frames following the resume point may be corrupted. The data rate may be 
slightly larger than expected. Also, if the file includes an audio track, a slight blip may 
be heard at the resume point. This may occur with any codec.

•   If you apply a title container to the timeline and add text into the container, you cannot 
successfully change the Background Color (in the Render tab). However, if you disable 
OpenGL, you can change the color if you view in High Quality.

•   If you use Frame-Differenced movies in Boris Red (including movies compressed with 
Apple’s QuickTime Animation codec, and some movies compressed with Sorenson), 
you will see reduced performance within Red. The use of Frame-Differenced movies is 
not recommended within Red.

•   When host field media is exported or previewed as frames, only the first field is used.

•   When an image is full size in the Composite window, you must deselect the Shape 
control in the Composite window’s Controls menu to directly manipulate an object’s 
Mask or Crop controls..

•   Windows only: Balance and Volume controls have no affect on audio tracks containing 
AVI files or MP3 files. 

•   Windows only: Boris Red exports Flash.swf files that are compliant with the Flash 5 
architecture. If you are using QuickTime to preview your exported.swf files, your 
QuickTime version must support the Flash 5 format. Older versions of QuickTime 
display the background as a solid color.
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Limitations with Avid Systems Only

•   Avid 24p media renders with an image quality problem that seems to indicate Red is 
treating it as fielded media. We are working with Avid to quickly correct this problem.

•   Avid XpressDV and Speed~Razor only: The Tool window can be forced into the 
background if you open it then click a window it is floating over.

•   Windows Avid Xpress Pro Only: Due to a problem on Avid’s side, you will crash when 
exporting a QT movie out of Red if you choose Avid’s MPEG 2 codec.

•   Titles created in Avid display garbage in Red when viewed at Full Quality and if the 
visibility for the lower timeline track(s) in Red are disabled.

•   Rendered Red or AvidFX effects on tracks in the Avid timeline above Boris effects don’t 
become unrendered when a change has been made to the Boris effect - even in cases 
where they should become unrendered.

Limitations with Edius Systems Only

•   In Edius, when a clip is rendered, that clip is locked down. Any further changes to a 
Red effect will not display in the Edius Preview window until Edius is closed and 
reopened. To work around this limitation, complete the following steps:

• In the Edius settings, click the Render tab. 

• In the Delete invalid rendering files section, choose When the Rendered File 
is Invalid. 

• Unrender the clip by making a change, such as toggling the checkbox to 
disable/reenable the effect in the Edius Information Palette.

•   At this time Boris products do not support being launched from inside other Edius 
filters (for example, the Combine or Region Edius filters).

Limitations with Final Cut Pro Only

•   Final Cut Pro version 3.0 Users only: FCP 3 users running Red as a plug-in with 
FireWire for Red's Preview to Monitor feature, must disconnect before clicking the 
Apply button or FCP will crash. To disconnect, choose Preview > Disconnect External 
Monitor.

Limitations with Media 100 and iFinish Systems Only

•   iFinish only: Intermittently, iFinish’s Media 100 codec is not available within Red’s 
QuickTime Export options list. Quitting and relaunching iFinish may fix this.
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Limitations with Pinnacle Systems Only

•   Pinnacle Liquid Only: When you apply Boris as a transition and launch Red, Red’s 
Composite window incorrectly displays the outgoing clip as the incoming clip. This is 
only a cosmetic problem; the transition will render correctly in Liquid Edition. To work 
around this limitation do one of the following.

• Create the transition in Red as if your clips are correct. When you finish, apply 
back to Liquid and render your transition. The final render will be correct. 

• Alternatively, you can click the Media icon in each track and swap Video 1 
and Video 2. When you create your transition, it will appear correct in Red. 
Remember to swap them back before applying back to Liquid.

•   When Red is applied to a segment that also has a transition (including a native Liquid 
Transition) applied, the effect previews correctly, but renders as if the effect was 
applied twice (once on the video segment and again during the duration of the 
transition).

•   Although choices appear for accessing video tracks 1 - 32, you can only successfully 
access tracks 1 and 2. Tracks higher than two display as black. This is a limitation of the 
Pinnacle plug-in architecture. 

Limitations with Premiere and Premiere Pro Only

•   Premiere 6 only: When exporting host media through Red, use Fields > None to export 
movies, rather than choosing upper or lower fields.

Limitations with Sony Vegas Only

•   When you create an effect in Red that will output an alpha channel to Vegas (for 
example a title which does not include the background video), when you apply the 
effect back to the vegas timeline you will notice the edges appear rough and contain 
white fringes. You need to reenter Red on the effect and in the Red Preferences set the 
Local Preferences’ Alpha Type menu to Premultiplied with Black. The effect will 
display correctly when you apply back to Vegas. You will need to do this every time 
you create an effect that outputs alpha.

•   If a Boris effect is prerendered in the Vegas timeline, future changes to that effect in 
Boris will be saved but do not appear in the Vegas Preview window until you remove 
the prerender in Vegas (Tools > Clean up Prerendered Video).

•   Vegas only previews a single frame of host video in Boris Red. The preview frame is 
taken from the current position of the Vegas cursor. To preview your effect with 
updating source media, exit Red and preview the effect in the Vegas Video timeline or 
import the video directly into the Red timeline. 

•   Motion Blur does not display in a rendered effect if you apply Red directly to a clip in 
Vegas. Instead, import the media directly into the Red timeline and you will see motion 
blur after you render your effect.
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Limitations with Ulead Only

•   When using Red as a transition in Ulead, the image quality for host media in the 
Composite window is very poor. This is because Ulead does not pass a full size image. 
However, this does not affect rendering. The effect renders in high quality.

•   When Using Red within Ulead with the Matrox Parhelia board, you may run into 
crashing problems. We do not recommend using the Matrox Parhelia board with Red.

•   Projects in certain versions of ULead Media Studio Pro may display jagged edges or 
reversed fields in rendered Boris effects. If your system shows this problem, you can 
install a registry key that indicates that ULead’s video fields should be reversed. This 
is found on the top level of the Boris CD in the Ulead Field Change folder. It also 
available at www.borisfx.com/download/utilities.php on the Boris FX website. For 
more information, see “Important Information for Ulead Users” on page 38.

Limitations with OpenGL
•   Final Cut Pro 4.x users must install Macintosh OX 10.3 installed in order to support 

Red’s OpenGL feature.

•   Extruded shapes inside Z-Space Containers will display in the Composite window in 
OpenGL Draft mode even when the extruded shape is grayed out in the timeline.

Limitations with Keyboard Shortcuts
•    Windows Only: The shortcut for changing color channels to RGB is labelled incorrectly. 

The Preview menu displays Color Channel as (ALT+-), but the actual shortcut is 
(ALT+`). You can assign new shortcuts in the Shortcuts window. See 
Volume I in the User Guide for more information on creating shortcuts.

•    Windows Only: The shortcut for hiding marks is listed as (CTRL+ALT+’), however that 
shortcut does not work. Use the menu choice in the Preview menu, or create your own 
shortcut in the Keyboard Shortcuts window instead. You can assign new shortcuts in 
the Shortcuts window. See Volume I in the User Guide for more information on creating 
shortcuts.

•   Windows Only: After creating new keyboard shortcuts, certain items in the Windows 
menu may show duplicate keyboard shortcuts (for example, the Filter Palette and 
Media Files window display the same keyboard shortcut). You can assign new 
shortcuts in the Shortcuts window. See Volume I in the User Guide for more 
information on creating shortcuts.
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Limitations with the Spline Object Media Type
•   Windows Only: There are instances when you may want to include tracks that use the 

3D Plane shape in a 3D Container that uses the 3D Model Renderer. This allows you to 
apply 3D parameters such as Materials, Textures and Bump Maps. When you use one 
of these two dimensional shapes in a 3D Model container, the track is called a 3D 
Primitive. However, render problems can occur when you enable a Bump Map for a 
Spline Object or Spline Primitive track in a 3D Model Container. Areas of the Bump 
Map can appear as a solid dark color or with dark bands if the track is tumbled or spun 
in 3D space. The workaround for this problem is to extrude the Spline track by 
assigning it the 3D Extrusion shape. Then set the Extrusion and Bevel amounts to 0 to 
maintain the flat look.

•   If you select a group of splines in the Composite window and adjust one of the Path 
track’s control parameters, the changes are not applied to any of the splines. The Path 
controls can only adjust one spline at a time.

•   The Reverse Keyframes command (Track > Reverse Keyframes) does not work in 
Spline effects. 

•   If you apply a spline style from the Style Palette to a spline primitive shape, the shape 
resets back to the default shape values.

Limitations with Text Features
•   Macintosh Only: Many foreign fonts do not display special characters in Red (for 

example the umlaud).

•   When the Text window is open, changes made in the Controls window (such as 
Margin, Wrap, or Font) will not update to the Composite window.

•   The Date format Day/Month/Year in the Date/Time generator displays a comma at the 
end if you have suppressed the time display.

•   Tracking behaves differently depending on whether the text was created with the Text 
tool or in the Text window. When you create text with the Text tool, the tracking honors 
the justification that is set in the Transform tab. When you create text in the Text 
window, the tracking is applied with center justification. If you want to track to the 
right or left using text that was created in the Text window, select the text with the Text 
tool and move it slightly. Then set the justification in the Transform tab. The Tracking 
now uses the justification. For more information, see “Working with the Transform 
Tab” in Volume 1 of the Red User Guide.

•   Importing RTF documents using the Insert Text feature in the timeline’s contextual 
menu will cause all tab delimited text to appear on the first line in Red, rather than in 
multiple lines. You will need to manually insert line breaks. 

•   Text on a Path moving from right to left will display upside down. To correct this, 
manually reverse the path, or click the Reverse Path checkbox in the Path tab. 

•   If you flip an image vertically and then render it through the host, the rendered video 
appears jittery. Enable the Better Quality Field Rendering checkbox to render correctly.
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Limitations with Chart Features
•   Accented letters such as é are not passed from the Chart Editor to the Chart Container 

correctly. Therefore, a Chart Legend or Grid label that uses accented characters must be 
entered directly into the text track, using the Text tool or Text window. If this is 
necessary, it must be done as a final step when building the chart. This is because 
editing the chart data or enabling/disabling the Legend or Grid updates this text using 
Chart Editor text; as a result, the accented characters will be lost.

•   When both the Reveal and Remove checkboxes are enabled in the Animation tab, 
Position X no longer animates when you work with extruded Bar and Pie Charts.

•   Removing an extruded Bar Chart by selecting the Reveal Shape checkbox in the 
Animation tab does not work correctly. Instead of animating the height of the bars 
sequentially, they are simply removed individually. In addition, when this checkbox is 
selected, the Overlap Time parameter is not respected.

•   For the most reliable results, the Animate button should not be in static mode when 
working with charts. For more information, see Chapter 1 in Volume I of the Red User 
Guide.

•   On certain systems, extruded pie charts pieces may incorrectly display their corners. 
Reduce the Bevel to 0 to fix this.

•    If you have long names for the X axis (defaults: South, East, West, and North), and you 
are animating the chart (if you have animation turned on) the names will not line up 
with the actual chart.

•   Selecting the Apply Current Spline Style checkbox can create unintended changes if the 
setting is modified after another spline style is selected. For example, you create a static 
Line chart setting with the Apply Current Spline Style checkbox selected. You apply 
another spline style from the Style Palette to a different track. If you then animate the 
chart, the chart will update with the latest spline style, rather than the style originally 
saved with the effect. The only workaround necessary is to reapply the original spline 
style from the Style Palette.

•   Depending on the scale you set for a Line Chart, you may see small nicks or 
indentations in the lines when you work in Full Resolution. Slightly increase or 
decrease the scale of the line chart to fix this.

Limitations with Filters
•   Windows Only: Do not press the About Box for the Delirium DE Day for Night FX 

filter. You will crash Red. 

•   Avid Xpress DV Only: The final render of an Optical Flow effect that is applied to host 
media renders slightly jittery. To correct this problem, import the timeline video as a 
QuickTime movie.

•   If you apply a filter containing the motion tracker then change the duration of the 
project and analyze the motion, the tracker data will only apply one second’s worth of 
information, not the new duration that you made. To work around this, after you 
change the duration, delete the motion tracker filter and apply it again. 
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•   When the default interpolation is set to Constant in the Preferences window, and a 
Motion Tracker filter is added to the timeline, resetting the default interpolation in the 
Preferences window will result in no keyframes being generated for the Motion Tracker 
when you move the tracker target/region until you exit and re-enter Red.

•   Any effect that uses a filter involving edge detection (for example, RGB Edges) should 
be rendered with the Better Quality Field Rendering checkbox selected. Otherwise, 
the rendered effect will jitter. 

•   In the 2D Particles filters, increasing the particle size scale can cause some custom 
shapes to truncate. You can avoid this by looking at the initial, unscattered particle grid. 
If some particles are cut off by the frame when you increase their size, then they will 
remain cut off throughout the duration of the effect. To avoid this, adjust the size 
parameters so that no particles are initially cut off.

•   The first rendered frame of effects using the 2D Particles Advanced filter will display 
particles, although you will not see particles in the first frame of a preview.

•   The Fire filter renders with the fields reversed unless you render it with Better Quality 
Field Rendering enabled.

•   In the Fire filter, when using text as a Map layer, the size of the text is ignored and will 
frequently display garbage. Map text to a shape, then nest the shape layer inside the 
Fire filter to correct this problem. 

•   Some filters create effects that evolve over time based on their parameter settings. The 
output of these filters (for example Velocity Remap, Particle System, Comet) depends 
on the parameter values for the entire effect; changing a parameter value on any frame 
changes the output for all subsequent frames. If you see a jump in the animation after 
changing a parameter, the jump is probably because Red did not invalidate frames that 
were affected by the change. You can fix this by choosing Edit > Purge Frame Cache, 
and previewing again. Your rendered output does not use the cached frames, so even 
if you forget to purge the frame cache, your final render appears correctly.

•   Time filters do not work with host video when rendering in many hosts. They work 
with Movie media when rendering in the host. For more information on this limitation, 
see “Important Note on Creating Time Effects within Boris Red” on page 41. 

•   Time filters always use the first field of fielded media when frame rendering or 
previewing.

•   The Motion Tracker Filter’s Analyze button won’t analyze the total length of the 
timeline if a movie file’s length is shorter than the duration of the effect and the movie 
file is set to Loop. 

Limitations with BCC Grain Filters
•   The Grain filter presets do not store the grain sample, only the filter settings. If you load 

a Match Grain preset and want to use a stored grain signature, you have to load that as 
well. If you load a DeGrain preset with the Lock Sample checkbox enabled, Red will not 
acquire the sample. 

•   If you select a preset in the Match Grain filter, the preset name does not appear in the 
control.
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•   The BCC DeGrain and Match Grain filters can only be used when Red’s Composite 
window is set to Full Resolution. If you are not in Full Resolution, an error message 
warns you to set the Composite window to Full resolution. If you do not set the 
Composite window to Full Resolution, a red “X” will display in the sample box.

Registration

Make sure to register your product in order to receive the latest technical and upgrade 
information as well as several BCC filters which are not included on the Boris Red 3.0.2 
installation CD. You can register either by filling out the registration form online at 
http://borisfx.com/support/register.html or by sending us your completed registration 
card. 

We offer registered users one year of free technical support starting from the date of 
purchase. In addition, registered users have access to some free upgrades.

The BCC DeGrain, BCC Match Grain, BCC Motion Blur, BCC Radial Blur, and BCC 
Spiral Blur filters are available as a free download to registered users. These filters 
are available on the Downloads page at www.borisfx.com. 

Contacting Technical Support

For technical support, contact Boris Red technical support specialists:

web: http://www.borisfx.com/support/

e-mail: support@borisfx.com

phone: 617-451-9900

hours: 9am-5pm Eastern Time (United States & Canada, GMT –05:00)
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