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Introduction

Welcome to Boris Graffiti 4.0.2. These Release Notes contain information regarding
supported hosts, hardware and operating systems, known limitations, and other important

information about the product.

For information on installing Boris Graffiti 4.0.2 into your host application, see the

Installation Guide pdf file.

Version 4.0.2 is a maintenance release that fixes a number of bugs that appeared in previous
versions of Boris Graffiti. These Release Notes contain important information regarding
supported system requirements, fixed bugs, and known limitations. For information about
Boris Graffiti software updates, other Boris products, and additional resources, visit our

web site at www.borisfx.com.

Supported Hosts and Operating Systems

Boris Graffiti 4.0.2 supports the following host applications. Because host versions update
frequently, please visit our website at www.borisfx.com for information on supported

versions for each host.

Macintosh

Adobe® Premiere® 6.5

Apple® Final Cut Pro® 3.0, 4.0 or
later

Avid® Media Composer®, Avid
Symphony® 4.7, 4.8, Avid
XpressMac®, Avid Xpress DV®
3.0,3.5.4,4.8. Avid Xpress Pro®4.0
or later

Media 100 i® 8.1 and later, Media
100 HD 10.0

Windows
Adobe® After Effects® 6.0
Adobe® Premiere Pro® 1.5

Avid® Media Composer®, Avid Symphony®,
Avid Xpress®, Avid Xpress DV® 3.0, 3.5.4,
Avid Xpress Pro® 4.0 or later, Avid Xpress
Studio, Avid I DS 6.0 and later

Canopus® Edius® 2.5, Edius Pro® 3.0

DPS® Velocity® 8.2

Incite® Media Producer 3.0 and later, Remote
Producer 3.0 and later

In:Sync® Blade® 2.2, In:Sync Speed~Razor® 5.5
Media 100® iFinish 4.6

Pinnacle purple®, Pinnacle silver® 4.01, Pinna-
cle Liquid Edition® 6.0

Sony® Vegas® 4.0
Ulead Media Studio Pro® 6.5, 7.0



Supported Operating Systems
Graffiti 4.0.2 supports the following operating systems.

Macintosh

Macintosh OS X v10.2.6 and above (see note below). Graffiti 4.0.2 is the first version to add
support for Macintosh OS X 10.4.2 (Tiger).

I 7 To take advantage of the OpenGL features in Graffiti, you must install Macintosh
OS 10.2.6 or later. Final Cut Pro 4.x users must install Macintosh OS 10.3 or later.
|

Windows
Windows 2K®, Windows XP®

Minimum System Requirements

We recommend at least 512 MB of memory assigned to the host application for both
Macintosh and Windows users using Graffiti.

To run Boris Graffiti 4.0.2, QuickTime version 6.0 or later must be installed on your system.
Boris Graffiti supports dual processors, Hyper Threading, and Altivec acceleration.

Localization

Graffiti is localized in several languages — English, French, German, Spanish, Italian,
Japanese, Chinese and Korean. Graffiti installs a Boris Language Pack file which reads the
system language specified on your system and translates its menus into that language, if it
is supported. Localization should be automatic and requires no work on the part of users.
The Boris Language Pack file is located in the following location.

Macintosh
Library/Application Support/BorisEX/Boris Language Pack.ecs

Windows
<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs

Editing Language Pack files with the Boris Localizer

The Boris Localizer is a standalone Mac OS X application that can be used to update the
translation of Graffiti in any of its eight supported languages. Use the Boris Localizer to edit
Boris Language Pack files which contain translations of Graffiti menus and parameters into
various languages. The Boris Localizer is available through your local Boris reseller.

B Contact your reseller for more information on using the Boris Localizer to edit the
@ default Graffiti translations.



Supported Hardware and Drivers

You need the following hardware and system requirements to use the hardware dependent
features in Graffiti 4.0.2. For detailed information on the OpenGL feature in Graffiti 4.0.2.
See the Understanding OpenGL pdf on your Graffiti CD or in the Graffiti User Guide.

Important Note on OpenGL Support

Due to the fast rate at which OpenGL card manufacturers release drivers, Graffiti may
disqualify your OpenGL hardware erroneously. If this happens, you should try to enable
OpenGL to see if you benefit from OpenGL acceleration. If you have troubles with slowness,
or render inconsistencies, please disable OpenGL. For information on enabling OpenGL, see
“Enabling OpenGL” on page 7.

While OpenGL may work in the Graffiti KeyFramer, that does not necessarily mean it will
work inside your host application. This is due to the fact that some hosts use OpenGL
memory, leaving it unavailable for Graffiti when you work inside the host.

If your host crashes when trying to apply Graffiti, and you cannot disable OpenGL in your
host, please contact our technical support staff. They will send you a preferences file that
will start Boris Graffiti with OpenGL disabled.

BorisFX will make every effort to continue to qualify OpenGL cards and driver versions.
However, it is important to note that it is impossible to qualify all combinations of OpenGL
cards, operating system, drivers and host applications. In general you should run the latest
driver available for your OpenGL card. If you have problems with the latest driver, visit the
Boris website to see a list of the latest supported driver versions.

Supported OpenGL Hardware

The following graphics cards and drivers are supported for Graffiti's OpenGL features. This
list is current as of the initial Graffiti 4.0.2 release. Boris FX maintains an updated list of
tested video cards on our web site: www.Borisfx.com. In general you should download and
install the latest driver for your GL card. For the latest updates to the list of supported cards
and drivers, please visit: www.borisfx.com/html/products/RED/table.html.

OpenGL is a cross-platform standard that accelerates the rendering of 2D and 3D graphics.
Most newer video cards have hardware-based OpenGL acceleration. If your system does
not include the recommended minimum requirements, Graffiti initially defaults OpenGL to
Off. You can re-enable OpenGL in the Graffiti Preferences window. You can still use Graffiti
without OpenGL or with an older card, you just won’t gain as much acceleration while
working. For details on how to use OpenGL, see the Graffiti User Guide.

B 7 Final Cut Pro 4.x users must have a minimum of Macintosh OS 10.3 installed to
support Graffiti’'s OpenGL feature.
=



Supported Macintosh Hardware
®  ATIRadeon 8500 (and up), Radeon Rage 128 (Macintosh only).
®*  NVidia GeForceFX (all), GeForce 3 and GeForce4 (all)

Supported Windows Hardware
®  ATIFireGL series, Radeon X300 (and up), Radeon 8500 (and up)

*  NVidia Quadro FX (all), Quadro4 900 (and up), GeForce 6800, GeForce PCX, and
GeForce 3 and GeForce4 (all)

Matrox Parhelia

1

Note for NVidia users: The NVidia GeForce 2 is not supported for OpenGL in
Graffiti.

>

|

1

As a general rule, you should install and run the latest driver available for your GL
card. ATI users should not use driver versions previous to 63.68. NVidia users
should not use driver versions previous to 65.00.

>

|

Note for Matrox Parhelia users: The Matrox Parhelia card is not recommended for
Graffiti users running Ulead Media Studio Pro. See “Important Information for
Ulead Users” on page 16 for more information.

>

Checking your OpenGL Hardware, Software, Drivers and Settings

The first time you launch Boris Graffiti, an internal test is run on your system to determine
whether your hardware meets the minimum requirements necessary for OpenGL
Hardware acceleration. If your hardware does not meet the minimum requirements,
OpenGL is disabled by default on your system.

To perform the OpenGL Hardware test

Genetal | Interface | Irmpart Media | Export Media Fr

manually, click the Test OpenGL
Hardware button in the Preferences
window’s Render tab.

E RFender in Draft Mode %While Dragging
E dccelerated Draft Preview

This test may take a few seconds. After [T Let Mouse Clicks Interrupt Rendering
the test is run, a window displays [0 Update Freview With Option Key
SpeCIﬁCS of the hardware and drivers on ‘ OpenGlL Acceleration | On, rmax. texture caching

your system. If any test results show
your system may have problems
running OpenGL, the errors are detailed
in this window.

| [Test OpenCL Hardware<4———

The test stresses your OpenGL hardware, so you should run the test with a typical
workload. Before you run the OpenGL hardware test, launch any applications that you
usually run while you edit (any graphics intensive applications you are running at the time
may affect the results).



If you want, click the Copy to Clipboard button to copy this information to your system
clipboard. This allows you to print or email this information. When you finish, click OK to
close this window.

Graphics Card: ATl Rage 128 OpenGL Engine
OpenGL Version: 1.1

Driver Version: ATI-1.2.22

Texture Rectangle: false

Texture Memory: 12 MB

Mac OS Version: 10.2.6

4 Copy to Clipboard ) E

Graffiti uses the following guidelines for optimal OpenGL performance. Some of this
information does not affect Graffiti's hardware testing but is useful for technical support if
you are having OpenGL problems:

Graphics Card-- See the table and notes on page 4. Also see the updated list on the
Boris FX website.

OpenGL version--Should be 1.2 and higher.

Driver Version--As a general rule, you should install and run the latest driver available
for your GL card. ATI users should not use driver versions previous to 63.68. NVidia
users should not use driver versions previous to 65.00.

Texture Rectangle--This is an advanced OpenGL image sizing feature. If you are
having OpenGL problems, this provides useful information for technical support.

Texture Memory-- Texture Memory displays the amount of memory on the video card
available for Graffiti to use for textures (layer images).To use Graffiti without display
or performance problems, Texture Memory must be at least 32MB. Texture Memory
available is not the absolute of memory on your card, but rather the amount available
to Graffiti.

Texture Dimension displays the maximum texture size that can be used with the video
card.

Macintosh OS Version displays the installed version of the Macintosh OS (if you are
running on a Macintosh system.) Macintosh users must have at least Macintosh OS
10.2.6 installed to support OpenGL; Final Cut Pro 4.x users, must have at least
Macintosh OS 10.3 installed to support OpenGL.

OpenGL Errors

When the OpenGL Hardware Test is run, error messages may display if your system fails.
These errors display as Hardware Status errors or Critical Testing errors.

Hardware Status errors report the status of your current system setup against Graffiti’s
recommended card manufacturer, model and driver. These errors do not prevent you from
using OpenGL, they just warn that your specific setup may cause problems with OpenGL.



Hardware Status errors can include messages such as insufficient texture memory or reports
that your card was not recognized by Graffiti’s internal hardware testing. When you receive
a Hardware Status error, OpenGL is automatically disabled when you launch Graffiti.
However, you can manually enable OpenGL in the Graffiti Preferences window.

Critical Testing errors report errors that will not allow you to use OpenGL in Graffiti. When
you receive a Critical Testing error, OpenGL is automatically disabled when you launch
Graffiti. If you receive a Critical Testing error, you should not enable OpenGL or you may
crash.

Final Cut Pro 4.x users must have at least Macintosh OS version 10.3 installed in
order to support Graffiti’'s OpenGL feature.

Certain errors are influenced by your video card’s display properties, which are
card-driver specific. As a general rule, set the display properties to 32 bits of color,
with the depth buffer set to atleast 16 bits. On many cards OpenGL capabilities are
reduced for higher display resolution and refresh rates.

Enabling OpenGL

You can enable OpenGL in the Preview menu or in the Preferences window.

*  Toenable OpenGL in the Preference window, choose Edit > Preferences (Windows) or
Boris Graffiti > Preferences (Macintosh). Click the Render Tab and select the
Accelerated Draft Preview checkbox. Choose the appropriate choice from the OGL
Acceleration menu. On, Max. texture caching provides the best performance and is the
recommended setting.

*  Toenable OpenGL in the Preview menu, choose Preview > Open GL Mode. Choose the
appropriate choice from the submenu. On, Max. texture caching provides the best
performance and is the recommended setting.

Troubleshooting OpenGL Issues

To toggle OpenGL off, use the keyboard shortcut Command or Control-[. To turn it back on,
the keyboard shortcut Command-] (Macintosh) or Control-] (Windows). Menu choices also
appear in the Preview menu and in the Preferences window. You can still use Graffiti
without OpenGL or with an older card, you just won't gain as much acceleration.

Display problems such as white, rainbow or garbage images in the Composite window may
be related to OpenGL. If this occurs, open the Preference window. In the Render tab, change
the OpenGL Acceleration menu to use less texture caching. Texture caching is used for
textures (layer images) and is related to the amount of Texture memory on the video card.
Display problems related to OpenGL will not affect your rendered effects.

If you experience OpenGL problems, setting the OpenGL Acceleration menu to
use less texture caching improves OpenGL reliability, but lessens performance.




Supported Preview to Monitor Hardware

You can output video to an external monitor through a FireWire converter box or through
supported video hardware connected to your system. You can output media at any project
size and immediately view your working frame without rendering the timeline.

Some hosts have native Preview to Monitor (PTM) where Graffiti passes a frame and the
host displays it, for example Meridien-based Avid systems. However, if a host does not have
native PTM ability, then you can use the Preview to Monitor feature. The user does not have
hardware choices in the Preferences window if Graffiti uses native host PTM (since the host
controls the hardware connection).

already in use by the host NLE for direct Video Out purposes. Graffiti can only use
the FireWire output if the NLE releases it while Graffiti runs. A number of hosts
(for example Premiere and FCP) will not release control of the primary display
hardware. This prevents Graffiti's Preview to Monitor feature from working until
the NLE releases control of the FireWire hardware.

B 7 As a plugin, Graffiti does not officially support connecting to hardware that is

However, Graffiti looks for all possible output devices upon installation, and lists the results
in the Device menu in the Preview tab of the Boris Graffiti preferences. As a result, users
may be able to use a different output device for Graffiti than the one that the host application
uses. The host application may use its own capture hardware for display, leaving the
FireWire port available.

Video-out capabilities are also available in the Boris Graffiti KeyFramer. This enables
anyone with supported video hardware, whether built into their computers, included with
their NLEs, or provided through third parties, to see the work they create in Boris Graffiti
immediately on television monitors.

Graffiti supports the following video cards for the new Preview to Monitor (PTM) feature
in both the Graffiti KeyFramer and while using Graffiti in your host. For detailed
information on the new PTM feature, see the User Guide.

Make sure you have the latest drivers installed for the supported video cards.

Supported PTM Cards

*  (Cinewave®

*  Matrox ®Parhelia®

*  AJA® Xena®

*  Canopus® RT® (See note below.)

Note for Macintosh Users: Most cards supporting standard QuickTime video out
capabilities and drivers should work.




Note for Windows Users: Although the previous cards were internally tested and
approved, other cards may work as well. We also support standard FireWire out.
Many Canopus RT boards work, although we cannot guarantee they all will.

plug-in with FireWire for Graffiti's Preview to Monitor feature, must disconnect
== before clicking the Apply button or FCP will crash. To disconnect, choose Preview
> Disconnect External Monitor.

P I 7 Note for Final Cut Pro version 3.0 Users only: FCP 3 users running Graffiti as a

Monitor feature, you must turn off the external video in Final Cut Pro before
launching Graffiti. Choose View > External Video > Off then enable Graffiti's
Preview to Monitor feature when Graffiti is launched. After leaving Graffiti,
reenable the external video (View > External Video > All Frames) to see Final Cut
Pro video in the external monitor.

P I 7 Note for Final Cut Pro version 4.x Users only: In order to use the Preview to
| ——

Once the hardware is connected, choose Connect to Monitor from the Preview menu.
Commands in the Preview menu allow you to set the video display. You can output media
atany project size and immediately view the working frame without rendering the timeline.

When you choose Display Frame on Monitor from the Preview menu or click the
Display Frame to Monitor button in the upper-right corner of the Composite window,
the image displays on the external monitor, using the Resolution and Quality settings
specified in the Composite window.

When you choose Display HQ on Monitor from the Preview menu, the image displays on
the external monitor, using the Full Resolution and High Quality settings, regardless of the
Resolution and Quality settings in the Composite window. When you choose Auto-Update
Monitor from the Preview menu, every frame of your effect previews to the external video
monitor connected This allows you to drag the CTI in the timeline and view updating
frames. This option is not available in some host applications or system configurations.

Once the hardware is connected, configure the Graffiti Preferences to use this feature. See
the next section for details.

Enabling Preview to Monitor

with FireWire for Graffiti's Preview to Monitor feature, must disconnect before
clicking the Apply button or FCP will crash. To disconnect, choose Preview >
Disconnect External Monitor.

I | 7 Final Cut Pro version 3.0 Users only: FCP 3 users running Graffiti as a plug-in
=—

must turn off the external video in Final Cut Pro before launching Graffiti. Choose

A Final Cut Pro version 4.x Users only: To use the Preview to Monitor feature, you
L—_AAA View > External Video > Off before launching Graffiti, then enable Preview to



10

Monitor when Graffiti is launched. After exiting Graffiti, reenable the external
video (View > External Video > All Frames) to see FCP video in the external
monitor.

Choose File > Preferences (Windows), or Boris Graffiti > Preferences (Macintosh).
Click to select the Preview tab.

In the External Monitor Output section, choose Excternal Manitor Dutput
your Firewire Converter box or Video

. D ice Firetitre v|
hardware board from the Device menu.

Mode #pple Firelire NTSC d

The Device menu displays all the supported
hardware connected to your system.

Choose an option from the Mode menu if applicable. For example, if you are using a
Firewire Converter box, you can choose PAL and NTSC formats from the Mode menu.

Click OK to save your settings and exit the Preferences window.

The Preview to Monitor preferences save and apply to all Graffiti projects unless

2/ | your Graffiti preference file is rebuilt.

Displaying Frames on your External Monitor

Commands in the Preview menu allow you to set the video display:

When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor
is enabled and the following three options in the menu become available:

When you choose Auto-Update Monitor from the Preview menu, every frame of your
effect previews to the external video monitor. This allows you to drag the CTI in the
timeline and view updating frames. The image displays on the external monitor, using
the Resolution and Quality settings specified in the Composite window.

A Enabling Auto-Update Monitor slows Graffiti since every frame updates in the

external monitor.

W=l

When you choose Display Frame on Monitor from the Preview menu or click the
Display Frame to Monitor button in the upper-right corner of the Composite
window, the current frame displays on the external monitor, using the Resolution
and Quality settings specified in the Composite window.

When you choose Display HQ Frame to Monitor from the Preview menu, the image
displays on the external monitor, using Full Resolution and High Quality settings,
regardless of the Resolution and Quality settings in the Composite window.



Disconnecting Preview to Monitor

To disconnect Preview to Monitor (for example if you want to connect another device to
your video board), exit Graffiti. When you relaunch Graffiti, the external monitor is not
connected until you choose Connect to External Monitor in the Preview menu.

Tips for Using the Preview to Monitor Feature

FireWire for Graffiti's Preview to Monitor feature, must disconnect before clicking
the Apply button or FCP will crash. To disconnect, choose Preview > Disconnect
External Monitor.

r—1| Note for Final Cut Pro version 3.0 Users only: FCP 3 users running Graffiti with

feature, you must turn off the external video in Final Cut Pro. Choose View >
External Video > Off before launching Graffiti, then enable Graffiti’s Preview to
Monitor feature when Graffiti launches. After leaving Graffiti, reenable the
external video (View > External Video > All Frames) to view Final Cut Pro in the
external monitor.

r—1| Note for Final Cut Pro version 4.x Users: To use Graffiti’s Preview to Monitor

®  Preview to Monitor automatically disconnects when you exit Graffiti. This means each
time you launch Graffiti, you need to choose Preview > Connect to External Monitor in
order to reconnect and see your image on the external monitor.

*  To change the Preview to Monitor device or mode, disconnect by choosing Disconnect
External Monitor from the Preview menu. Open the Preference window’s Preview tab
to choose a new device or driver from the External Monitor Output menus. You can also
reconnect via the Preview menu with those new settings in the same session.

° Displaying images on an external monitor 8086 Composite
requires compressing and resizing the images.
Graffiti may run slower if Auto Update is
enabled. Deselect Auto-Update Monitor in the
Preview menu to remain connected to the
external monitor but not automatically update
frames.

Manually update frames to your external
monitor by choosing Preview > Display Frame
to Monitor, or Preview > Display HQ Frame to
Monitor, or by pressing the Display Frame to < € =
Monitor button on the upper-right corner of the
Composite window.

e
00:00:00,00 |

Display Frame to
Monitor Button

11
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Important Note on Missing Filters

Several BCC filters (BCC Spiral Blur, BCC Light Zoom and BCC Twirl) are not included with
the Boris Graffiti installation. Instead, these filters are available as a free download to
registered users on the Downloads page at www.borisfx.com.

A You must register Boris Graffiti to download these filters. See the Installation
Guide PDF for details on registering.
| ——

Important Information for Avid Users

Avid users can now apply Boris Graffiti as a filter to titles created with the Avid Title tool.

Applying Boris Graffiti as a Title-Matte Effect

You can apply Boris Graffiti directly to titles created in the Avid timeline. For example, if you
have a bin with saved titles, you could apply a filter to the titles in Graffiti.

1. Edit an Avid title or matte key into the Avid timeline.

2. Open the Avid Effect Palette and select Boris Graffiti from the Effect categories. From
the list of available Graffiti effects, drag the Boris Graffiti Title-Matte Effect to the title
or matte key in the Avid timeline.

Removing a Title-Matte effect removes the title’s nested alpha channel. To remove
a Title-Matte effect and preserve the alpha, use the Undo command instead of the
Remove Effect command.

A The Title-Matte effect is a destructive process which replaces the title or matte key.
A\

3. Click the Other Options button in the Avid Effect Editor to launch Graffiti.

B If the title or matte key looks blocky when Graffiti opens, select its Face track in the
timeline. In the Host Media tab, choose Straight Alpha from the Key menu. This
A usually happens automatically.

Replacing a Title-Matte Effect

Since a title is replaced by applying the Title-Matte effect, to re-edit a title with a Title-Matte
Effect (for example to change the text or a font) you must save the Title-Matte effect while
you are in Graffiti (in the File menu). Recreate the Avid title and overwrite the older title in
the Avid timeline. Drag a Graffiti Title-Matte Effect to the new title. In Graffiti, open the
saved effect and apply it to the new title.

Avid Systems and Preview to Monitor

Graffiti’s Preview to Monitor feature works for Xpress DV, Xpress Pro, and Adrenaline and
Mojo models only. All other Avid products can use the existing AVX Preview to Monitor

feature within Graffiti. The AVX Preview to Monitor allows you to see video in an external
monitor without the extra step of selecting your hardware in Graffiti’s Preference window.



Important Information for Edius Users

Due to limitations in the Edius architecture, you need to be aware of the following
limitations when using Graffiti inside Edius.

Launching Boris Graffiti within Edius

To launch the Graffiti user interface after applying a Boris effect to a clip, the Edius timeline
cursor must be placed over the effect and the track containing the effect must be selected.

Working with Edius Palettes when Graffiti is Launched

When using Boris Graffiti as a Transition effect in Edius, the Edius Palettes remain above the
Boris windows. BorisFX has reported this issue to Canopus and is working with them to
resolve it in a future release of Edius. Currently, to work around this issue, position the
Edius Palettes and Boris windows so they don't overlap.

Editing Previously Rendered Effects

In Edius, when a clip is rendered, that clip is locked. Any changes to a Graffiti effect will not
display in the Edius Preview window until Edius is closed and reopened. To work around
this limitation, complete the following steps:

1. In the Edius settings, click the Render tab.
2. Inthe Delete invalid rendering files section, choose When the Rendered File is Invalid.

3. Unrender the clip by making a change, such as toggling the checkbox to
disable/reenable the effect in the Edius Information Palette.

Unexplained Crashes in Edius with OpenGL Enabled

If Edius crashes when trying to apply Graffiti it may be because OpenGL is enabled. If you
cannot disable OpenGL, launch the standalone Graffiti KeyFramer to disable OpenGL, then
you should be able to apply Graffiti within Edius as a plug-in. You can also contact our
technical support staff. They will send you a preferences file that starts Graffiti with
OpenGL disabled.

Applying Multiple Boris Graffiti Filters to a Clip in Edius

You should be aware of some issues when applying multiple Graffiti filters to a clip.

13
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Stacking Multiple Overlapping Boris Effects

We do not recommend adding multiple Graffiti effects to an Edius clip or stacking clips
containing Graffiti effects on multiple layers in the Edius timeline. Depending on your
system specifics, multiple Boris effects (>2) on a clip may not render properly. Instead, apply
a single Graffiti effect to an Edius clip and add multiple effects to the clip within Graffiti.

_____ This limitation only applies to effects that overlap exactly. For example, a track
[ = containing both an in and an out transition would not fall under this suggestion
L= (since they can not overlap).

Applying More than one Boris Effect to a Clip

If there is more than one Boris effect applied to a clip, the effect of preceding filters will not
display in the subsequent filters in the Graffiti user interface. For example, if first a blur filter
and then a twirl filter are applied to the same Edius clip, the blur filter effect will not show
in the effected track when the ripple effect is launched. However, all effects display during
render in the Edius Preview window.

Playing Boris Graffiti Effects

Edius timeline playback stops when trying to play through a Boris effect. To fix this, in the
Edius settings deselect the Stop Playback at Frame Drop in the Playback tab.

Working in Boris Graffiti when Edius is Running

When Graffiti is launched, Edius is unable to perform other actions (such as closing). It is
possible to get Edius into a state where it thinks Graffiti is launched, but the Graffiti user
interface does not appear. This will functionally lock Edius. To resolve this, delete the
Graffiti .ini file in the root:\ \ WINDOWS folder, and launch Graffiti again. If this doesn't
work, save the Edius project, force a manual close of Edius (Control- Alt-Delete), delete the
Graffiti .ini file, then launch Edius again.

Applying Boris Filters within Native Edius Filters

At this time Boris products do not support being launched from inside other Edius filters
(for example, the Combine or Region Edius filters).

Important Information for Final Cut Pro Users

P 7 Final Cut Pro 4.x users must have at least Macintosh OS version 10.3 installed in
order to support Graffiti’'s OpenGL feature.
=

in Final Cut Pro before launching Graffiti. Choose View > External Video > Off

4 Al before launching Graffiti, then enable Graffiti’s Preview to Monitor feature when
Graffiti is launched. After leaving Graffiti, reenable the external video (View >
External Video > All Frames) to see Final Cut Pro video in the external monitor.

B I 7 To use Graffiti’s Preview to Monitor feature, you must turn off the external video



®  Final Cut Pro 3 users running Graffiti as a plug-in with FireWire for Graffiti's Preview
to Monitor feature, must disconnect before clicking the Apply button or FCP will crash.
To disconnect, choose Preview > Disconnect External Monitor.

*  Graffiti includes a Static Generator for Final Cut Pro. The Static Generator allows you
to create a static slate which takes advantage of Final Cut Pro’s real-time capabilities.
When you apply the Static Generator, the Boris timeline opens with a duration of one
frame which can then be applied to Final Cut Pro as a static slate.

®  Graffiti now correctly field renders video in the wells when using a Graffiti FCP
Generator. However, media placed in the input wells for a Graffiti Generator should
match the FCP sequence size. Both the Graffiti project size and the size of the well video
appear in Graffiti at the FCP sequence size. If the well media is not the same as the FCP
sequence size, fields won't render correctly.

Additionally, any video in the input wells should be the same size as the clip with
Graffiti applied. In the case of Graffiti applied as a filter, the Graffiti project size is
determined by the size of the filtered media. Once again the size of the filtered media
needs to match any video in the wells. This will maintain the integrity of fields since
Graffiti doesn't allow host video inputs of various sizes within the same effect.

To use media whose size doesn’t match the FCP sequence size (Generator) or the Filter
media size, the best approach is to import that media directly into the Boris timeline
from disk (rather than from the wells in FCP). This will provide you with full flexibility
for dealing with non-standard size images, field interpretation, and oversize images.

* Toeditan existing Graffiti effect, make sure the playhead is positioned on the effect you
want to edit before launching Graffiti. Otherwise, the Boris interface will not appear.

*  To export from Graffiti, set the FCP resolution to 100%. Otherwise, you get reduced
image quality, since FCP does not provide full-size frames. Likewise, if Final Cut Prois
at less than full resolution (100%), previews at full size appear in reduced quality.

* Insome instances the Graffiti plug-in crashes due to an apparent conflict with MacsBug
v6.6.3. If you have MacsBug 6.6.3 installed and experience crashing, try disabling or
running an earlier version of MacsBug when using Graffiti.

®  If more than one version of Graffiti is installed, the Effects menu lists both versions with
the same name: Boris Graffiti. The top item in the list is Graffiti 4.0.2 and the second
item is the earlier version. We recommend uninstalling earlier versions.

Important Information for Pinnacle Liquid Edition Users

rendered Boris effects may display jagged edges or reversed fields. If your system
shows this problem, you can install an .ini file to reverse the video fields. This is
available for download at www.borisfx.com/register/download].

P | 1 Due to changes made in the Liquid Edition plug-in architecture in version 6.1,
=

If your system exhibits these problems, simply drag the BorisGRAFFTI4Plug 1.ini file into
the same folder as the Liquid Edition .exe file. This is usually found in the following
location: <Drive>\Program Files\ Liquid.6\ Program folder.
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The .ini file includes the following two parameters:

®  ReverseSrcFieldOrder reverses the field order when it is set to 1 (the default); at a value
of 0 this is disabled and the original field order is used.

*  BottomFieldDominant sets the field dominance. A value of 1 sets lower field
dominance, 0 sets upper field dominance and 3 does not change the dominance.

Once Liquid Edition releases a patch that fixes this problem, this action can be undone by
deleting this file. If you have questions about whether your system exhibits this problem,
email Boris technical support at support@borisfx.com.

Issues with Project Size in Pinnacle Liquid Edition

In most host applications, when you use Boris Graffiti as a plug-in, the effect size is taken
from the host application. However, due to changes made in the Liquid Edition plug-in
architecture in version 6.1, you must manually set the size to match your Pinnacle Liquid
Edition project. To do this, open the Preferences window by choosing Edit > Preferences
(Windows) or Boris Graffiti > Preferences (Macintosh). In the General tab, use the Project
Size menu to set the width and height (in pixels) for your project. This menu provides
project dimensions and FPS for the most common video formats. The Project Size options
includes 720 x 486 NTSC D1, 720 x 480 NTSC DV, 640 x 480 NTSC Square Pixels, 640 x 486
NTSC Square Pixels, 720 x 540 PAL D1 Square Pixels, 720 x 576 PAL D1 DV, 720 x 576 PAL
D1 DV Square Pixels, 1380 x 720 HDTYV, 1920 x 1080 HDTV, 320 x 240 Medium Size and 160
x 120 Small Size.

Important Information for Sony Vegas Users

When you create an effect in Graffiti that will output an alpha channel to Vegas (for example
a title which does not include the background video), when you apply the effect to the Vegas
timeline you will notice the edges appear rough and contain white fringes. You need to
reenter Graffiti and in the Graffiti Preferences set the Local Preferences’ Alpha Type menu
to Premultiplied with Black. The effect will display correctly when you apply back to Vegas.
You need to set this preference every time you create an effect that outputs alpha.

Important Information for Ulead Users

or reversed fields in rendered Boris effects. If your system shows this problem, you
can use a utility to reverse ULead’s video fields. If you have questions about this
utility or whether your system exhibits this problem, email Boris technical support
at support@borisfx.com.

I | 1 Projects in certain versions of ULead Media Studio Pro may display jagged edges
—

I 1 Using Graffiti in Ulead with the Matrox Parhelia board, may cause crashing. We do
not recommend using the Matrox Parhelia board with Graffiti plugged into Ulead.
—



Installing and Using Adobe After Effects Filters within Boris Graffiti

Boris FX provides a supported list of AE filters for use inside Boris Graffiti. For best results,
use only supported AE filters inside Boris Graffiti. An list of Supported, Conditionally
Supported and Unsupported filters can be found on our website: www.borisfx.com.

Supported filters were tested on single-processor machines. While these filters should also
work in multi-processor machines, it is possible you will experience unexpected results or
your machine may crash. If you have problems with supported filters in multi-processor
machines, try disabling your MP functionality and recreating your filter effect.

Composite window set to Full Resolution. Additionally the Effect Viewer may
disappear after dragging tracks. Use the regular controls if you experience this
problem.

A Tinder Users: Tinder’s Effect Viewer only works properly with the Graffiti
VAN

Important Information on Using After Effects Filters

®  Checkboxes and menus cannot be animated.

®  Time remapping filters do not work in Boris Graffiti.

*  After Effects filters may take longer to render than most Boris Graffiti effects.
®  None of Adobe's built-in After Effects filters work inside Boris Graffiti.

*  Ifrenders appear noisy or jittery, deselect the Better Quality Field Rendering checkbox
in the Boris Preferences window and re-render the effect.

*  If you have more than 900 filters, you will not see some filters inside Graffiti. If you
reach the filter limit, when you launch Graffiti a warning asks you to remove some files
from the BorisPlugins folder. You can ignore the warning but you will not have access
to all filters in the BorisPlugins folder. Use the Plugin Filter Manager to hide filters you
don’t need. See the User Guide for details on using the Plugin Filter Manager.

Installing AE Filters for Macintosh

Macintosh users should place supported After Effects filters or an alias in the following
folder. The filters appear in the Filters menu within Boris Graffiti.

System Folder (or Library )/Application Support/BorisFX/BorisPlugins

Installing AE Filters for Windows

Windows users should place supported After Effects filters or an alias in the following
folder. The filters appear in the Filters menu within Boris Graffiti.

C:\Program Files\Boris FX, Inc.\ BorisPlugins

17
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Important Information about Exporting to Flash

Boris Graffiti allows you to export files in the Macromedia Flash (SWF) format. This allows
you to export compositions as compact, vector-based files optimized for web viewing. For
example, you could export a Type On effect to include on a web page.

Graffiti exports Flash .swrf files that are compliant with the Flash 5 architecture. If you are
using QuickTime to preview your exported .swf files, you need a version of QuickTime that
supports the Flash 5 format. The following effects are supported for exporting to Flash.

*  Text

*  Spline media

® 2D Charts (which consist of text and spline shapes)

Other bitmap elements such as video or still graphics can be included in the exported Flash

file and will be JPEG-compressed. In the Export preferences you can set the quality of the
JPEG compression.

B

7 When you export text to Flash, any texture that was applied to the text is ignored.

>

|

B

O

I 7 When you export text with a gradient fill to Flash, the resulting .swf file is blank.

[

Exporting as Flash

The SWF format was designed primarily for animated 3D Line Art objects, so it works well
when exporting settings that contain spline and text animations. Settings that contain video
or animated bitmaps, however, generate rather large files. You might want to consider
exporting such animations as a QuickTime or AVI file. See “Exporting Effects as Movies” on
page 297 in the Graffiti User Guide for details.

The Flash export feature has some limitations. You cannot export 3D Extrusion tracks as
Flash. Settings that contain 3D Extrusion tracks export as a blank track. The Flash export
feature does not support shadows or gradients used as Texture tracks. However, you can
export a static gradient as a bitmap background.

A To prepare to export to Flash, you should change any shape track containing text
or Spline media to the 3D Line Art shape. Because you cannot use the 3D Line Art

L&==1 shape with the Brush tool, you cannot export brush strokes as Flash.

=

Select the appropriate track in the timeline.

N

Choose File > Export > Flash.
A dialog box appears that allows you to name and save the file.

3. Name the track and click Save.

The composition is exported using the Flash Export settings, which are controlled by
the Preferences window’s Export tab.



Important Information Using the KeyFrame Library

The first time you browse the KeyFrame Library effects within the Library Browser you
must generate thumbnail images for the effects.

1.

Open the Boris Library Browser, by choosing Window > Library Browser,
clicking the Open Library Browser button in the timeline or pressing
Command-9 (Macintosh) or Control-9 (Windows).

Select an effect or effect folder and click the Generate Thumbnails button. For more
information on using the KeyFrame Library, see the Graffiti User Guide.

We recommend that you build thumbnail previews for the KeyFrame Library in
the Graffiti KeyFramer rather than within your host application. Because building

2= previews actually renders your effect, this process can take as much as 25-30%

longer in the plug-in than in the Graffiti KeyFramer.

Fixed Bugs in Boris Graffiti since Version 4.0

Graffiti 4.0.2 includes many bug fixes from the initial version 4.0 of Graffiti. Fixed bugs
include the following. Some of the following bugs were fixed in earlier versions of Graffiti.

Graffiti now correctly supports Macintosh OS X 10.4.2 (Tiger).
Graffiti 4.0.2 settings now correctly open in Red 3.0.4.

Awid only: Graffiti now correctly installs into Avid Xpress Pro 4.8 and Adrenaline 1.8
systems.

An issue with QuickTime export movies has been fixed, which previously caused a
crash in certain hosts plug-ins (primarily on Windows AVX hosts). This crash could
also occur when selecting the QT codec.

German umlaut fonts now correctly display in Graffiti.
Third-party Asian fonts now appear correctly when typing in the Text window.

Final Cut Pro users only: Graffiti version 4.02 now correctly field renders synthetic
media (titles and splines) when you apply as a generator. However, this fix will not
work for legacy projects from FCP version 3.0. A previously version corrected a related
problem so that other media types would field render video in the wells when using an
FCP Generator. However, the media placed in the input wells for a Generator should
match the FCP sequence size. Both the Graffiti size and the size of the well video will
appear in Graffiti at the FCP sequence size. If the well media is not the same as the FCP
sequence size, fields won't render correctly.

Additionally, any video in the input wells should be the same size as the filtered clip.
When applied as a filter, the Graffiti project size is determined by the size of the filtered
media which needs to match any video in the wells. This will maintain the integrity of
fields since Graffiti doesn't allow host video inputs of various sizes within the same
effect.
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In a case that requires media sources whose size will not match the FCP sequence size
(Generator) or the filter media size, the best approach is to import that media into the
Graffiti timeline from disk (rather than from the wells in FCP). This provides flexibility
for dealing with non-standard size images, field interpretation, and oversize images.

In Graffiti 3.0 the Preview To Monitor for Avid feature was disabled even when running
in Meridien-based Avid versions. This was corrected in Graffiti 3.0.1.

Final Cut Pro 4.0 only: The Graffiti banner in the Effect Control tab no longer
disappears after you apply an effect.

Final Cut Pro 4.0 only: In earlier versions, Graffiti could crash when applied as a filter
or static generator in a setup that included a custom screen layout, such as color
correction. This problem would occur when relaunching the Graffiti user interface.
This problem has been corrected.

The 1-2-1 Deflicker preference is now correctly saved with your Preferences file.

Premiere Pro only: Transitions and presets no longer appear vertically stretched when
applied in Premiere Pro 1.5.

Premiere Pro only: Shapes no longer appear and render stretched when previewing a
Premiere Pro timeline at High Quality.

Pinnacle Liquid Edition 6.1 only: Fields are no longer reversed when rendering a
Graffiti effect in Pinnacle Liquid version 6.1. See “Important Information for Pinnacle
Liquid Edition Users” on page 15 for details.

Dragging an animated spline track into the mask track of another track now correctly
preserve the keyframe animation.

Spline track keyframe timing information is now properly preserved when tracks are
copied.

Windows only: Crashes that occurred in certain situations when duplicating filter sets
in the Plugin Filter Manager have been corrected.

Windows only: Font styles are now stored with a .B2F extension instead of .B2D. This
prevents the Text Styles and Font Styles from overlapping and appearing in the same
tab in the Style Palette.

Graffiti 4.0.1 fixed situations where the Render thermometer did not update when you
worked with either OpenGL enabled, or on an MP system in High Quality mode.
Switching vertically from track to track in the timeline using the keyboard now
properly synchronizes the OpenGL interactors shown in the Composition and Preview
windows.

Deleting the last used Library Browser folder and then launching Graffiti no longer
causes Graffiti to hang when trying to restore that folder as the current one.

The Render Thermometer now updates more consistently.

Windows only: Old tool tips no longer randomly display in the Controls window when
you hover over unrelated areas.

The Delete key now deletes selected items in the Style Palette.

The display of multiple selected items in the Style Palette now indicates the current
selection when you Shift-select.
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You can now select contiguous items in a table using by pressing Shift and scrolling
the mouse wheel.

Position X and Position Y no longer act as if they are locked together in the Fire Filter.

Macintosh only: Repeatedly pressing Page Up or Page Down now works properly
when a non-Timeline window is active, except when a text editing field is open.

Using the Mouse Wheel to switch a track selection no longer causes the last adjusted
parameter in the Controls window to copy to the newly selected track.

Windows only: You can now successfully apply styles to text in the Text window.

The Create Cross Platform Movie checkbox has been removed from the Movie Export
Settings dialog. Movies are now automatically created crossplatform.

The BCC Fast Blur filter no longer crashes if the height of the source is greater than its
width. This was previously a problem when the filter was applied upstream (on the
face track) to media, or with a vertically oriented project.

Windows only: Graffiti improved low-memory handling in the BCC Fast Blur filter.

Missing font names are now properly remembered, so you no longer see multiple
messages complaining that the same font is missing.

Macintosh only: Occasions where the scroll bars at the edges of windows disappeared
have been fixed.

Macintosh only: OpenGL performance has been improved when working with scaling
down large textures (for example, 2K+ wide images).

If you open a movie file as an audio track then open that same file as a movie file, when
you change the start time of either track, it no longer affects both.

Instances where the Caps Lock feature didn’t work correctly in the Composite window
have been fixed.

The Toggle Face/Shape Track Selection button now works correctly for containers.

Windows only: When using Title Containers and switching between the animation
styles, the keyframes now reset so the container animates correctly.

The V key in the Color Preview feature now works to commit to a color. Use the C key
to dynamically preview colors, and then use the V key to commit to them.

The Title Container Position Y (Roll) and Position X (Crawl) parameters no longer
reset when certain other values are changed.

Installing a large number of presets for BCC filters no longer increases the rendering
time. The parameters in these filters no longer become less responsive.

The Position X and Position Y parameters no longer act as if their interpolation is
linked when changing from an interpolation other than Ease In/Out, to Ease In/Out.

Windows only: 3D Sphere effects with Motion Blur enabled no longer render opaque,
or crash in specific instances.

You no longer crash with OpenGL enabled if you nest a track five times and adjust the
first shape in the nest.
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Final Cut Pro 4.0 only: When you use Graffiti as a Transition in Final Cut Pro 4.x, the
Graffiti Preferences are now respected. This means that when you relaunch Graffiti as
a Transition, changes you make to Quality, Resolution and other Graffiti Preferences no
longer need to be reset each time.

Windows only: Many keyboard shortcuts that displayed incorrectly have been fixed.
When you create spline effects using the Add Extruded Pencil button with animated
borders, the effect no longer exhibits frames that appear different after rendering than
they did when previewing the effect.

Windows only: The BCC Film Damage filter Hair parameter now functions correctly.

Checkboxes and menus from the Controls window no longer display as Option
Change in the History Palette.

Preview to RAM now plays just the rendered section, rather than the entire timeline.

Preview to RAM at Half Rate and Preview to RAM at Quarter Rate now preview the
entire duration at their given rate.

Windows only: If you press the Boris logo at the top of the Tools window, you no longer
receive a memory error.

Media 100 iFinish only: iFinish now passes the 16:9 ratio to Graffiti in transition mode
only. The Composite window no longer reflects 4:3.

Changing font size on Chart Legends now changes the size of the squares accordingly
and the circles remain the same size.

If you change a Fade Animated Chart from Flat to Extruded, the animation now works
correctly.

Enabling values and a legend on an Area Chart no longer causes their values to display
underneath the chart.

Resetting a chart now fully resets any color changes you made.

Windows only: Oversized images used as media for a background track now show up
correctly when OpenGL enabled.

Windows only: Keyframes now display correctly in the timeline when you create them
by moving OpenGL interactors if one of the position’s interpolation is set to Constant.

When you map media with an alpha channel to a Cube with multiple faces, you no
longer see different media for the sides of the cube in OpenGL vs. Non-OpenGL
modes.

Spline shapes no longer shift if you draw a shape with the Brush tool then select the
Arrow tool.

If you have multiple tracks selected in the timeline and move them, the timeline now
correctly displays the moved tracks.

All settings from the Keyframe Library Backgrounds category now render correctly
when you apply them with OpenGL enabled.



Known Limitations in Graffiti 4.0.2

Graffiti 4.0.2 includes the following known limitations.

General Limitations

If you tumble an object that has an image bump map, you may see a moire pattern as
it tumbles.

When you save a style to the Materials tab in the Style Palette, it does not correctly save
the Source type that was used in the Bump Map tab.

When you open settings created in previous versions of Graffiti, Graffiti 4.0.2 ignores
controls that were initially enabled in the Lights 2 and 3 tabs.

When you search for a missing media file using the Search button in the Media Files
window, it may not find files that were moved to another local drive. Manually browse
to the new location of the file and press the Replace button.

Tracks containing PSD files that are converted to containers do not correctly update if

you modify them (for example in Photoshop) and then use the Reload Files command.

When you choose Targa Sequence as a file type when exporting a movie file, clicking
the Compression Settings button erroneously displays QuickTime codec selections.

Files exported to Flash from Graffiti cannot be used in Macromedia Flash authoring
applications such as Flash MX.

If you use the Keyframe Time field in the timeline to move keyframes, all keyframes
that a moving keyframe passes are merged to it. Instead, move keyframes past one
another by dragging the mouse.

Photoshop (.psd) files with adjustment layers display incorrectly in Graffiti if you
convert their track to a container. Turn off any adjustment layers in Photoshop before
importing .psd files if you plan on converting them to containers.

Microsoft DV Type 1 filters do not work in Graffiti as audio tracks.

You cannot adjust Volume and Balance for Graffiti audio files do not update after you
have changed them once.

Previewing with audio while you Preview to RAM to Monitor will disconnect Preview
to an external monitor.

Audio waveforms do not update when you adjust the global timeline. This is only a
display issue and can be corrected by moving something slightly in the Composite
window.

Resuming a partial render of an exported QuickTime file may have some undesirable
results. In particular, video compressed with codecs that use frame-differencing and
data-rate-limiting (such as Sorenson or Cinepak) may exhibit the following behavior.

Some frames following the resume point may be corrupted. The data rate may be
slightly larger than expected. Also, if the file includes an audio track, a slight blip may
be heard at the resume point. This may occur with any codec.
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If you apply a title container to the timeline and add text into the container, you cannot
successfully change the Background Color (in the Render tab). However, if you disable
OpenGL, you can change the color if you view in High Quality.

If you use Frame-Differenced movies (including movies compressed with Apple’s
QuickTime Animation codec and some movies compressed with Sorenson), you will
see reduced performance. The use of Frame-Differenced movies is not recommended
within Graffiti.

When host field media is exported or previewed as frames, only the first field is used.

When an image is full size in the Composite window, you must deselect the Shape
control in the Composite window’s Controls menu to directly manipulate an object’s
Mask or Crop controls.

Windows only: Balance and Volume controls have no affect on audio tracks containing
AVI files or MP3 files.

Windows only: Boris Graffiti exports Flash.swf files that are compliant with the Flash
5 architecture. If you are using QuickTime to preview your exported.swf files, your
QuickTime version must support the Flash 5 format. Older versions of QuickTime
display the background as a solid color.

Limitations with Avid Systems Only

Avid 24p media renders with an image quality problem that seems to indicate Graffiti
is treating it as fielded media. We are working with Avid to quickly correct this
problem.

Avid XpressDV and Speed~Razor only: The Tool window can be forced into the
background if you open it then click a window it is floating over.

Windows Avid Xpress Pro Only: Due to a problem on Avid’s side, you will crash when
exporting a QT movie from Graffiti if you choose Avid’s MPEG 2 codec.

Titles created in Avid display garbage in Graffiti when viewed at Full Quality and if the
visibility for the lower timeline track(s) in Graffiti are disabled.

Rendered Graffiti or AvidFX effects on tracks in the Avid timeline above Boris effects
aren’t unrendered when a change is made to the Boris effect - even in cases where they
should become unrendered.

Limitations with Edius Systems Only

In Edius, when a clip is rendered, that clip is locked. Any changes to a Graffiti effect
will not display in the Edius Preview window until Edius is closed and reopened. To
work around this limitation, complete the following steps:

In the Edius settings, click the Render tab. In the Delete invalid rendering files section,

choose When the Rendered File is Invalid. Unrender the clip by making a change, such
as toggling the checkbox to disable/reenable the effect in the Edius Information Palette.

At this time Boris products do not support being launched from inside other Edius
filters (for example, the Combine or Region Edius filters).



Limitations with Final Cut Pro Only

Final Cut Pro version 3.0 Users only: FCP 3 users running Graffiti as a plug-in with
FireWire for Graffiti's Preview to Monitor feature, must disconnect before clicking the
Apply button or FCP will crash. To disconnect, choose Preview > Disconnect External
Monitor.

Limitations with Media 100 and iFinish Systems Only

iFinish only: Intermittently, iFinish’s Media 100 codec is not available within Graffiti’s
QuickTime Export options list. Quitting and relaunching iFinish may fix this.

Limitations with Pinnacle Systems Only

Pinnacle Liquid Only: When you apply Boris as a transition and launch Graffiti,
Graffiti’s Composite window incorrectly displays the outgoing clip as the incoming
clip. This is only a cosmetic problem and the transition will render correctly in Liquid.
To work around this limitation, do one of the following.

Create the transition in Graffiti as if your clips are correct. When you finish, apply the
effect to Liquid and render your transition. The final render will be correct.

Alternatively you can press the Media icon in each Graffiti track and swap Video 1 and
Video 2. When you create your transition it will look correct in Graffiti. Remember to
swap them back before applying to Liquid.

When Graffiti is applied to a segment that also has a transition (including a native
Liquid Transition) applied, the effect previews correctly, but renders as if the effect was
applied twice (once on the video segment and again during the duration of the
transition).

Although choices appear for accessing video tracks 1 - 32, you can only successfully

access tracks 1 and 2. Tracks higher than two display as black. This is a limitation of the
Pinnacle plug-in architecture.

Limitations with Premiere and Premiere Pro Only

Premiere 6 only: When exporting host media through Graffiti, use Fields > None to
export movies, rather than choosing upper or lower fields.

Limitations with Sony Vegas Only

When you create an effect in Graffiti that will output an alpha channel to Vegas (for
example a title which does not include the background video), when you apply the
effect back to the vegas timeline you will notice the edges appear rough and contain
white fringes. You need to reenter Graffiti on the effect and in the Graffiti Preferences
set the Local Preferences’ Alpha Type menu to Premultiplied with Black. The effect
will display correctly when you apply back to Vegas. You will need to do this every
time you create an effect that outputs alpha.

If a Boris effect is prerendered in the Vegas timeline, future changes to that effect in
Boris will be saved but do not appear in the Vegas Preview window until you remove
the prerender in Vegas (Tools > Clean up Prerendered Video).
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®  Vegas only previews a single frame of host video in Boris Graffiti. The preview frame
is taken from the current position of the Vegas cursor. To preview your effect with
updating source media, exit Graffiti and preview the effect in the Vegas Video timeline
or import the video directly into the Graffiti timeline.

®*  Motion Blur does not display in a rendered effect if you apply Graffiti directly to a clip
in Vegas. Instead, import the media directly into the Graffiti timeline and you will see
motion blur after you render your effect.

Limitations with Ulead Only

*  When using Graffiti as a transition in Ulead, the image quality for host media in the
Composite window is very poor. This is because Ulead does not pass a full size image.
However, this does not affect rendering. The effect renders in high quality.

*  When using Graffiti within Ulead with the Matrox Parhelia board, you may run into
crashing problems. We do not recommend using the Matrox Parhelia board with
Graffiti.

®  Projects in certain versions of ULead Media Studio Pro may display jagged edges or
reversed fields in rendered Boris effects. If your system shows this problem, you can
install a registry key that indicates that ULead’s video fields should be reversed. This
is found on the top level of the Boris CD in the Ulead Field Change folder. It also
available at www.borisfx.com /download / utilities.php on the Boris FX website. For
more information, see “Important Information for Ulead Users” on page 16.

Limitations with OpenGL

° Final Cut Pro 4.x users must install a minimum Macintosh OX 10.3 installed in order
to support Graffiti's OpenGL feature.

Limitations with Keyboard Shortcuts

*  Windows Only: After creating new keyboard shortcuts, certain items in the Windows
menu may show duplicate keyboard shortcuts (for example, the Filter Palette and
Media Files window display the same keyboard shortcut). You can assign new
shortcuts in the Shortcuts window. See the User Guide for details on creating shortcuts.

Limitations with the Spline Object Media Type

* Ifyou select a group of splines in the Composite window and adjust one of the Path
track’s control parameters, the changes are not applied to any of the splines. The Path
controls can only adjust one spline at a time.

®  The Reverse Keyframes command (Track > Reverse Keyframes) does not work in
Spline effects.

* If you apply a spline style from the Style Palette to a spline primitive shape, the shape
resets back to the default shape values.



Limitations with Text Features

When the Text window is open, changes made in the Controls window (such as
Margin, Wrap, or Font) will not update to the Composite window.

The Date format Day/Month/Year in the Date/ Time generator displays a comma at the
end if you have suppressed the time display.

Tracking behaves differently depending on whether the text was created with the Text
tool or in the Text window. When you create text with the Text tool, the tracking honors
the justification that is set in the Transform tab. When you create text in the Text
window, the tracking is applied with center justification. If you want to track to the
right or left using text that was created in the Text window, select the text with the Text
tool and move it slightly. Then set the justification in the Transform tab. The Tracking
now uses the justification. For details, see “Working with the Transform Tab” in the
User Guide.

Importing RTF documents using the Insert Text feature in the timeline’s contextual
menu will cause all tab delimited text to appear on the first line in Graffiti, rather than
in multiple lines. You will need to manually insert line breaks.

Text on a Path moving from right to left will display upside down. To correct this,
manually reverse the path, or click the Reverse Path checkbox in the Path tab.

If you flip an image vertically and then render it through the host, the rendered video
appears jittery. Enable the Better Quality Field Rendering checkbox to render correctly.

Limitations with Chart Features

Accented letters such as é are not passed from the Chart Editor to the Chart Container
correctly. Therefore, a Chart Legend or Grid label that uses accented characters must be
entered directly into the text track, using the Text tool or Text window. If this is
necessary, it must be done as a final step when building the chart. This is because
editing the chart data or enabling / disabling the Legend or Grid updates this text using
Chart Editor text; as a result, the accented characters will be lost.

When both the Reveal and Remove checkboxes are enabled in the Animation tab,
Position X no longer animates when you work with extruded Bar and Pie Charts.

Removing an extruded Bar Chart by selecting the Reveal Shape checkbox in the
Animation tab does not work correctly. Instead of animating the height of the bars
sequentially, they are simply removed individually. In addition, when this checkbox is
selected, the Overlap Time parameter is not respected.

For the most reliable results, the Animate button should not be in static mode when
working with charts. For more information, see the Graffiti User Guide.

On certain systems, extruded pie charts pieces may incorrectly display their corners.
Reduce the Bevel to 0 to fix this.

If you have long names for the X axis (defaults: South, East, West, and North), and you
are animating the chart (if you have animation turned on) the names will not line up
with the actual chart.
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®  Selecting the Apply Current Spline Style checkbox can create unintended changes if the
setting is modified after another spline style is selected. For example, you create a static
Line chart with the Apply Current Spline Style checkbox selected. You apply another
spline style from the Style Palette to a different track. If you then animate the chart, the
chart will update with the latest spline style, rather than the style originally saved with
the effect. The only workaround necessary is to reapply the original spline style from
the Style Palette.

*  Depending on the scale you set for a Line Chart, you may see small nicks or
indentations in the lines when you work in Full Resolution. Slightly increase or
decrease the scale of the line chart to fix this.

Limitations with Filters

*  Any effect that uses a filter involving edge detection (for example, RGB Edges) should
be rendered with the Better Quality Field Rendering checkbox selected. Otherwise,
the rendered effect will jitter.

*  Inthe 2D Particles filters, increasing the particle size scale can cause some custom
shapes to truncate. You can avoid this by looking at the initial, unscattered particle grid.
If some particles are cut off by the frame when you increase their size, then they will
remain cut off throughout the duration of the effect. To avoid this, adjust the size
parameters so that no particles are initially cut off.

®  The first rendered frame of effects using the 2D Particles Advanced filter will display
particles, although you will not see particles in the first frame of a preview.

Registration

Make sure to register your product in order to receive the latest technical and upgrade
information as well as several BCC filters which are not included on the Boris Graffiti 4.0.2
installation CD. You can register either by filling out the registration form online at
http:/[borisfx.com/support/register.html or by sending us your completed registration card.

We offer registered users one year of free technical support starting from the date of
purchase. In addition, registered users have access to some free upgrades.

Contacting Technical Support

For technical support, contact Boris Graffiti technical support specialists:
web: http:/ / www.borisfx.com /support/
e-mail: support@borisfx.com

phone: 617-451-9900



hours: 9am-5pm Eastern Time (United States & Canada, GMT -05:00)

29



	Introduction
	Supported Hosts and Operating Systems
	Supported Operating Systems
	Macintosh
	Windows

	Minimum System Requirements
	Localization
	Macintosh
	Windows
	Editing Language Pack files with the Boris Localizer

	Supported Hardware and Drivers
	Important Note on OpenGL Support
	Supported OpenGL Hardware
	Checking your OpenGL Hardware, Software, Drivers and Settings
	OpenGL Errors
	Enabling OpenGL
	Troubleshooting OpenGL Issues

	Supported Preview to Monitor Hardware
	Supported PTM Cards

	Enabling Preview to Monitor
	Displaying Frames on your External Monitor
	Disconnecting Preview to Monitor
	Tips for Using the Preview to Monitor Feature

	Important Note on Missing Filters
	Important Information for Avid Users
	Applying Boris Graffiti as a Title-Matte Effect
	Replacing a Title-Matte Effect

	Avid Systems and Preview to Monitor

	Important Information for Edius Users
	Launching Boris Graffiti within Edius
	Working with Edius Palettes when Graffiti is Launched
	Editing Previously Rendered Effects
	Unexplained Crashes in Edius with OpenGL Enabled
	Applying Multiple Boris Graffiti Filters to a Clip in Edius
	Stacking Multiple Overlapping Boris Effects
	Applying More than one Boris Effect to a Clip

	Playing Boris Graffiti Effects
	Working in Boris Graffiti when Edius is Running
	Applying Boris Filters within Native Edius Filters

	Important Information for Final Cut Pro Users
	Important Information for Pinnacle Liquid Edition Users
	Issues with Project Size in Pinnacle Liquid Edition

	Important Information for Sony Vegas Users
	Important Information for Ulead Users
	Installing and Using Adobe After Effects Filters within Boris Graffiti
	Important Information on Using After Effects Filters
	Installing AE Filters for Macintosh
	Installing AE Filters for Windows

	Important Information about Exporting to Flash
	Exporting as Flash

	Important Information Using the KeyFrame Library
	Fixed Bugs in Boris Graffiti since Version 4.0
	Known Limitations in Graffiti 4.0.2
	General Limitations
	Limitations with Avid Systems Only
	Limitations with Edius Systems Only
	Limitations with Final Cut Pro Only
	Limitations with Media 100 and iFinish Systems Only
	Limitations with Pinnacle Systems Only
	Limitations with Premiere and Premiere Pro Only
	Limitations with Sony Vegas Only
	Limitations with Ulead Only

	Limitations with OpenGL
	Limitations with Keyboard Shortcuts
	Limitations with the Spline Object Media Type

	Limitations with Text Features
	Limitations with Chart Features
	Limitations with Filters

	Registration
	Contacting Technical Support

