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The Boris Localizer

 

The Boris Localizer is a standalone Mac OS X application used to update the translation or 
localization of BCC Þlters in any of its eight supported languages. Use the Boris Localizer to 
edit Boris Language Pack Þles which contain translations of BCC menus and parameters 
into various languages. 

 

System Requirements

 

The Boris Localizer is a Macintosh application which requires that Macintosh OS 10.3.x is 
installed on your system.

 

Note for Windows users:

 

 The Language Pack Þle can be edited on a Macintosh 
OS X system using the Localizer, and the Þle can be copied onto a BCC 3.0.1 
Windows system. Place the edited Language Pack.ecs Þle in the following location 
on Windows systems (rewrite the older Language Pack.ecs Þle).

 

<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs. 

Note for Windows users:

 

 See Appendix A: Editing Boris Language Pack Þles on 
Windows systems for information on how you can update the Boris Language 
Pack Þle on a Windows system.

 

Supported Languages

 

BCC 3.0.1 supports localization into the following eight languages; 

 

English, French, 
German, Spanish, Italian, Japanese, Chinese 

 

and

 

 Korean

 

.

 

Understanding the Localizer

 

Boris Continuum versions 3.0.1 (and later) use a main dictionary Þle called 

 

Boris Language 
Pack.ecs 

 

when translating its menus and Þlter parameters into various languages. This Þle 
is installed in the following location when you perform a full install of BCC 3.0.1 on a 
Macintosh system.

 

/Library/Application Support/BorisFX/Boris Language Pack.ecs

 

The Boris Localizer allows you to edit the Language Pack Þle in signiÞcant ways; 

 

•   

 

Adding better translations for a particular language,

 

•   

 

Adding and removing strings, 

 

•   

 

Filtering its contents to show any missing translations, 
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•   

 

Searching for strings that match a particular word or phrase.

 

Installing the Localizer

 

Copy and uncompress the Boris Localizer Þle to your system. The Localizer can reside 
anywhere on your drive.

 

The User Interface

 

Using the commands in the Localizer is easy. This section details how to use the features 
found in the toolbar, and main window.

 

Starting the Localizer

 

Double-click the Boris Localizer icon to launch the Localizer. Choose File > Open and 
browse to the location of the Boris Language Pack.ecs Þle. The Þle is located in the following 
directory on a Macintosh system after you install BCC 3.01.

 

Library/Application Support/BorisFX/Boris Language Pack.ecs

 

The Boris Localizer opens the Boris Language Pack Þle.
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Getting Started

 

Using the Localizer is easy. To add or change the translation for a string, locate the string in 
the String list. Click its disclosure triangle or double-click the string. The languages and 
current translations for the string display in the Translation column. Double-click the 
particular translation and type the new word or phrase. 

In the example below, the word 

 

Quality

 

, which by default has only an English translation in 
the Localizer, is manually translated into Italian (

 

Qualitå

 

).

When you type in a new word or phrase, all instances of that string in any BCC Þlter are 
updated. Choose File > Save to save the Language Pack Þle when you Þnish. 

 

Using the Search feature

 

Use the Search feature to quickly search for a word, or part of a word that matches BCC 
strings. Searching makes it easy to translate all instances of a particular phrase or word.

In the example below, a search on the word 

 

lock

 

 is performed, displaying all of the strings 
that include lock.

Double-click to edit 
the translation 
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Seeing your changes

 

1.

 

To see your changes inside BCC Þlters, relaunch the host application where you have 
BCC installed. BCC Þlters automatically translate into the language set in your 
operating system

 

Important Note for Final Cut Pro Users: 

 

Final Cut Pro caches Þlters and parameters. 
In order to see updated Localizer changes in FCP, you may need to delete the 

 

Final 
Cut Pro POA Cache

 

 Þle. After using the Localizer, search for the 

 

Final Cut Pro 
POA Cache

 

 Þle and delete it before launching Final Cut Pro. You must delete this 
cache Þle every time between using the Localizer and relaunching Final Cut Pro.

 

Using The Toolbar

 

The 

 

Add String button

 

 allows you to add a new string to the dictionary to 
translate. You may need to use this feature if you run across a word or phrase 
in a BCC Þlter which is not in the Language Pack Þle, and you want it 
translated. When you add a string, it will appear at the bottom of the Strings 
list. Press the 

 

Sort Strings button

 

 to sort the Strings list in alphabetical order. 
By default, the new string will be translated in English and you will need to 
manually translate it for all of the other languages.

The 

 

Remove String button

 

 lets you remove a selected string, and all of its 
translations from the dictionary.

The 

 

Sort Strings button

 

 sorts all of the strings in the Language Pack Þle in 
alphabetical order. 

 

Using the Customize Button

 

Pressing the 

 

Customize Button

 

 gives you access to advanced features that should 
only be used by engineers or as directed by Boris Technical Support. Do not use 
these features unless directed to by Boris Support or you may cause BCC not to 
recognize your Language Pack Þle.

Pressing the

 

 Add Language button prompts 

 

you to select one of the eight languages 
supported by the Localizer. A new translation for the given language is then added for each 
of the strings in the dictionary if that language was previously deleted or missing.
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Pressing the 

 

Remove Language button 

 

prompts you to select one of the eight languages 
supported by the Localizer. All translations for that language are then removed from the 
dictionary.

Pressing the 

 

Merge Dictionary button

 

 prompts you to select another dictionary Þle. You 
can then merge the translations from the selected Þle into the current dictionary, with the 
option to overwrite or keep the existing translations for those strings that appear in both 
dictionaries.

 

Using the Main Window

 

The 

 

At runtime, use: menu

 

 should be left with 

 

Automatic

 

 chosen. This menu allows you to 
select the language that will be used when you use BCC Þlters in your host. Automatic is 
the default value, and will map to whatever language the system is using. Other choices in 
the menu are available only for testing purposes and selecting one of the could cause your 
system to display garbage characters or crash.

The 

 

Show Strings menu 

 

Þlters the strings in the dictionary to display only those that are 
missing a translation for a given language. When 

 

All

 

 is selected (the default), all of the 
strings included in the BCC Þlters are displayed. 

 

Choose strings 

 

missing the Italian translation

 

 to 
display only the strings that aren�t translated into Italian

 

Type a word or phrase into the 

 

Search Þeld

 

 to quickly search for a word, or part of a word 
that matches BCC strings. Searching makes it easy to translate all instances of a particular 
phrase or word.
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Appendix A: Editing Language Pack Files on Windows Systems

 

The Boris Localizer is a Macintosh-only application. Windows users have a couple of 
options to edit the XML-based Boris Language Pack.ecs Þle on their machines. 

 

•   

 

Editing the Language Pack Þle using Notepad, 

 

•   

 

Purchasing and using a commercial XML editing application such as Altova�s xmlspy. 
(www.altova.com).

The following steps outline both methods.

 

Using Notepad to edit Language Pack Files

 

You can use the Windows Notepad application to edit the Boris Language Pack Þle. The 
process is very crude. The Language Pack Þle will appear as one huge block of text. Follow 
the steps below to use Notepad.

 

1.

 

Quit out of the host application you have BCC Þlters installed into.

 

2.

 

Locate the 

 

Boris Language Pack.ecs

 

 Þle on your system. It should be found in the 
following location. 

 

<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs. 

 

If this Þle is not installed on your system, download it from our web site 
www.borisfx.com.

 

3.

 

It is a good idea to duplicate this Þle and put a the duplicate on your system where you 
can Þnd it in the event you make a mistake when you are editing the original and need 
to revert to the unedited version.

 

4.

 

Double-click the 

 

Boris Language Pack.ecs

 

 Þle to open it. The Þle will not automatically 
open in Notepad, you will need to browse to the Notepad application and choose it in 
order to use Notepad to open it. 
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5.

 

The resulting Þle is a large block of text.

 

6.

 

Choose Edit > Find to search for a word or phrase in BCC that you want to edit. The 
example below shows a search for the word 

 

Stain

 

.

Raw Text Strings are proceeded and followed by 

 

<key> 

 

and 

 

</key>

 

. For example, the 
string Stain appears as 

 

<key>Stain</key>

 

 (highlighted below). Once you locate the 
word or phrase you searched for, you then need to locate and replace the particular 
translation you want to update.
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7.

 

Translations for each of the eight supported languages are proceeded and followed by 
a unique language code enclosed in carets. The language codes are as follows.

 

•   

 

<en> English

 

•   

 

<fr> French

 

•   

 

<de> German

 

•   

 

<it> Italian

 

•   

 

<ja> Japanese

 

•   

 

<zh> Chinese

 

•   

 

<ko> Korean

 

•   

 

<es> Spanish

In the above example, you can see that the translations for Stain are easily identiÞed 
because they are proceeded and followed by their unique language code.

 

8.

 

Replace the translation for your language with the new word or phrase. In some 
instances, you will see squares instead of translation for particular languages. This 
means that the characters for that language are not supported on your system.

There are Þve unsupported characters you should not use when replacing a 
translation. See the section below for more information.

 

9.

 

When you are Þnished editing the Boris Language Pack Þle, save the Þle into its default 
location:

 

<Drive>\Program Files\Boris FX, Inc.\Boris Language Pack.ecs. 

Text String English 
translation

French 
translation

German 
translation
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10.

 

Relaunch the host application you are running BCC to see your changes. BCC Þlters 
automatically translate into the language that your operating system is set to.

 

Unsupported Characters when using Notepad

 

Five characters are unsupported when editing Language Pack Þles. Do not use 
these characters when replacing localized text or you may cause the Language 
Pack Þle to not be read by BCC. The unsupported characters are the following.

 

•   

 

& Ampersand

 

•   

 

> Greater than

 

•   

 

< Less than

 

•   

 

� Double quote

 

•   

 

� Single quote

If a character you have typed into the Language Pack Þle causes the Þle to not be 
read by BCC, you may need to revert back to the duplicated Language Pack Þle 
you saved on your system. If you cannot locate that Þle or did not save it, visit the 
BorisFX web site to download a new, unedited version of the Boris Language Pack 
Þle.

 

Using a Commercial XML Editor to edit Language Pack Files

 

You can also purchase a commercial XML editing application such as Altova�s xmlspy to 
edit Boris Language Pack Þles. These applications will display the Boris Language Pack Þles 
in a more easily readable format than Notepad uses. 

Use the steps outlined above to edit Boris Language Pack Þles in a commercial XMLeditor. 
The user interface will be much easier to understand, however the steps to editing the 
Language Pack Þles are the same. 
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